summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-08 02:38:39 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-08 02:38:39 +0000
commit0e8063b76d943229102406dadb09b0987b7cabaa (patch)
tree0c1367b941ba9680b7b08bdf0c6bd91c0f82a9cf /sys-fs/cryptsetup-luks
parentPatch the makefile rather than using autopoint so we dont require cvs #142997. (diff)
downloadgentoo-2-0e8063b76d943229102406dadb09b0987b7cabaa.tar.gz
gentoo-2-0e8063b76d943229102406dadb09b0987b7cabaa.tar.bz2
gentoo-2-0e8063b76d943229102406dadb09b0987b7cabaa.zip
Cleanup src_compile(), punt invalid USE=pic, and make sure that just running autoconf works.
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'sys-fs/cryptsetup-luks')
-rw-r--r--sys-fs/cryptsetup-luks/ChangeLog7
-rw-r--r--sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild34
2 files changed, 19 insertions, 22 deletions
diff --git a/sys-fs/cryptsetup-luks/ChangeLog b/sys-fs/cryptsetup-luks/ChangeLog
index 2c53a75b3861..03d80aa6b11e 100644
--- a/sys-fs/cryptsetup-luks/ChangeLog
+++ b/sys-fs/cryptsetup-luks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/cryptsetup-luks
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/ChangeLog,v 1.36 2006/08/05 21:27:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/ChangeLog,v 1.37 2006/08/08 02:38:39 vapier Exp $
+
+ 08 Aug 2006; Mike Frysinger <vapier@gentoo.org>
+ cryptsetup-luks-1.0.3-r2.ebuild:
+ Cleanup src_compile(), punt invalid USE=pic, and make sure that just running
+ autoconf works.
05 Aug 2006; Mike Frysinger <vapier@gentoo.org>
cryptsetup-luks-1.0.3-r2.ebuild:
diff --git a/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild b/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild
index 6f3392b77882..4cfd08e52579 100644
--- a/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild
+++ b/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild,v 1.9 2006/08/05 21:27:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild,v 1.10 2006/08/08 02:38:39 vapier Exp $
inherit autotools linux-info eutils flag-o-matic multilib
@@ -11,7 +11,8 @@ SRC_URI="http://luks.endorphin.org/source/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 arm ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="dynamic nls pic selinux"
+IUSE="dynamic nls selinux"
+RESTRICT="confcache"
DEPEND=">=sys-fs/device-mapper-1.00.07-r1
>=dev-libs/libgcrypt-1.1.42
@@ -19,8 +20,6 @@ DEPEND=">=sys-fs/device-mapper-1.00.07-r1
selinux? ( sys-libs/libselinux )
!sys-fs/cryptsetup"
-RESTRICT="confcache"
-
dm-crypt_check() {
ebegin "Checking for dm-crypt support"
linux_chkconfig_present DM_CRYPT
@@ -43,38 +42,31 @@ dm-crypt_check() {
pkg_setup() {
linux-info_pkg_setup
- dm-crypt_check;
+ dm-crypt_check
}
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-selinux.patch
- rm -f po/Makefile.in.in #142362
- autopoint -f || die
- AT_M4DIR="${S}/m4" eautoreconf
+ eautoconf || die
+ touch aclocal.m4 Makefile.in configure
}
src_compile() {
- local PIC_FLAG=""
- if use pic ; then
- PIC_FLAG="--with-pic"
- fi
-
if use dynamic ; then
ewarn "If you need cryptsetup for an initrd or initramfs then you"
ewarn "should NOT use the dynamic USE flag"
epause 5
- econf --sbindir=/bin --disable-static --libdir=/usr/$(get_libdir) "${PIC_FLAG}" \
- $(use_enable nls) \
- $(use_enable selinux) \
- || die
- else
- econf --sbindir=/bin --enable-static --libdir=/usr/$(get_libdir) "${PIC_FLAG}" \
+ fi
+
+ econf \
+ --sbindir=/bin \
+ $(use_enable !dynamic static) \
+ --libdir=/usr/$(get_libdir) \
$(use_enable nls) \
$(use_enable selinux) \
|| die
- fi
emake || die
}
@@ -83,7 +75,7 @@ src_install() {
make DESTDIR="${D}" install || die "install failed"
rmdir "${D}/usr/$(get_libdir)/cryptsetup"
insinto /lib/rcscripts/addons
- newconfd ${FILESDIR}/cryptfs.confd cryptfs
+ newconfd "${FILESDIR}"/cryptfs.confd cryptfs
doins "${FILESDIR}"/dm-crypt-{start,stop}.sh
}