summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-30 17:11:29 +0000
committerMike Frysinger <vapier@gentoo.org>2010-12-30 17:11:29 +0000
commit1135e96f9da7f3e7975c623b2c4822be3acc4070 (patch)
treef283ff30fbb9cba4cdace8344c1e1dbcb2882d3c /sys-fs/cryptsetup/cryptsetup-1.2.0-r1.ebuild
parentRemove the gcc4.4 patch, not needed for -r2 (diff)
downloadgentoo-2-1135e96f9da7f3e7975c623b2c4822be3acc4070.tar.gz
gentoo-2-1135e96f9da7f3e7975c623b2c4822be3acc4070.tar.bz2
gentoo-2-1135e96f9da7f3e7975c623b2c4822be3acc4070.zip
Convert to IUSE=+static and make it work again #350105 by Casey Carter.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/cryptsetup/cryptsetup-1.2.0-r1.ebuild')
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.2.0-r1.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/sys-fs/cryptsetup/cryptsetup-1.2.0-r1.ebuild b/sys-fs/cryptsetup/cryptsetup-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..9ce5a2b5e26c
--- /dev/null
+++ b/sys-fs/cryptsetup/cryptsetup-1.2.0-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.2.0-r1.ebuild,v 1.1 2010/12/30 17:11:29 vapier Exp $
+
+EAPI="2"
+
+inherit linux-info eutils multilib libtool
+
+MY_P=${P/_rc/-rc}
+DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
+HOMEPAGE="http://code.google.com/p/cryptsetup/"
+SRC_URI="http://cryptsetup.googlecode.com/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="+static nls selinux"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND=">=sys-fs/lvm2-2.02.64
+ >=dev-libs/libgcrypt-1.1.42
+ >=dev-libs/libgpg-error-1.0-r1
+ >=dev-libs/popt-1.7
+ >=sys-fs/udev-124
+ || ( >=sys-libs/e2fsprogs-libs-1.41 <sys-fs/e2fsprogs-1.41 )
+ selinux? ( sys-libs/libselinux )
+ !sys-fs/cryptsetup-luks"
+
+pkg_setup() {
+ local CONFIG_CHECK="~DM_CRYPT ~CRYPTO ~CRYPTO_CBC"
+ local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup)\n"
+ local WARNING_CRYPTO_CBC="CONFIG_CRYPTO_CBC:\tis not set (required for kernel 2.6.19)\n"
+ local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup)\n"
+ check_extra_config
+}
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --sbindir=/sbin \
+ --enable-shared \
+ --libdir=/usr/$(get_libdir) \
+ $(use_enable static static-cryptsetup) \
+ $(use_enable nls) \
+ $(use_enable selinux)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ use static && { mv "${D}"/sbin/cryptsetup{.static,} || die ; }
+ dodoc TODO ChangeLog README NEWS
+
+ insinto /$(get_libdir)/rcscripts/addons
+ newins "${FILESDIR}"/1.1.3-dm-crypt-start.sh dm-crypt-start.sh || die
+ newins "${FILESDIR}"/1.1.3-dm-crypt-stop.sh dm-crypt-stop.sh || die
+ newconfd "${FILESDIR}"/1.0.6-dmcrypt.confd dmcrypt || die
+ newinitd "${FILESDIR}"/1.0.5-dmcrypt.rc dmcrypt || die
+}
+
+pkg_postinst() {
+ ewarn "This ebuild introduces a new set of scripts and configuration"
+ ewarn "than the last version. If you are currently using /etc/conf.d/cryptfs"
+ ewarn "then you *MUST* copy your old file to:"
+ ewarn "/etc/conf.d/dmcrypt"
+ ewarn "Or your encrypted partitions will *NOT* work."
+ elog "Please see the example for configuring a LUKS mountpoint"
+ elog "in /etc/conf.d/dmcrypt"
+ elog
+ elog "If you are using baselayout-2 then please do:"
+ elog "rc-update add dmcrypt boot"
+ elog "This version introduces a command line arguement 'key_timeout'."
+ elog "If you want the search for the removable key device to timeout"
+ elog "after 10 seconds add the following to your bootloader config:"
+ elog "key_timeout=10"
+ elog "A timeout of 0 will mean it will wait indefinitely."
+ elog
+ elog "Users using cryptsetup-1.0.x (dm-crypt plain) volumes must use"
+ elog "a compatibility mode when using cryptsetup-1.1.x. This can be"
+ elog "done by specifying the cipher (-c), key size (-s) and hash (-h)."
+ elog "For more info, see http://code.google.com/p/cryptsetup/wiki/FrequentlyAskedQuestions#6._Issues_with_Specific_Versions_of_cryptsetup"
+}