summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-21 14:42:08 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-21 14:42:08 +0000
commitd480bf17454e35cbcd512b56ccf32036dedf11b7 (patch)
treead5f7380606a44422b565b6a479cc244e05aa7e6 /sys-fs/davl/files
parentalpha/sparc stable wrt #297306 (diff)
downloadgentoo-2-d480bf17454e35cbcd512b56ccf32036dedf11b7.tar.gz
gentoo-2-d480bf17454e35cbcd512b56ccf32036dedf11b7.tar.bz2
gentoo-2-d480bf17454e35cbcd512b56ccf32036dedf11b7.zip
Fix building with -Wl,--no-as-needed wrt #248417 by Kevin Pyle.
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/davl/files')
-rw-r--r--sys-fs/davl/files/davl-1.2.1-asneeded.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-fs/davl/files/davl-1.2.1-asneeded.patch b/sys-fs/davl/files/davl-1.2.1-asneeded.patch
new file mode 100644
index 000000000000..ad3a6bd4aa43
--- /dev/null
+++ b/sys-fs/davl/files/davl-1.2.1-asneeded.patch
@@ -0,0 +1,43 @@
+diff -ur a/src/cdavl/Makefile b/src/cdavl/Makefile
+--- a/src/cdavl/Makefile 2005-08-03 23:25:17.000000000 -0500
++++ b/src/cdavl/Makefile 2009-02-12 23:30:25.000000000 -0600
+@@ -4,10 +4,6 @@
+ include $(PATH_LIST)
+
+
+-CC = gcc
+-DEBUG =
+-#DEBUG = -DDEBUG
+-CFLAGS = -Wall -g -O -D_FILE_OFFSET_BITS=64 $(DEBUG)
+ HEADERS = cdavl.h ../common/util.h ../drv/liveinfo_app.h
+ OBJS = ../common/util.o
+ CDAVL = cdavl
+diff -ur a/src/gdavl/Makefile b/src/gdavl/Makefile
+--- a/src/gdavl/Makefile 2005-08-03 23:25:17.000000000 -0500
++++ b/src/gdavl/Makefile 2009-02-12 23:31:31.000000000 -0600
+@@ -4,22 +4,14 @@
+ include $(PATH_LIST)
+
+
+-CC = gcc
+-CFLAGS1 = -Wall -g -O `gtk-config --cflags --libs`
+-CFLAGS2 = -Wall -g -O `pkg-config --cflags --libs gtk+-2.0`
+-CFLAGS = -D$(GTK_VER)
+-ifeq ($(GTK_VER), GTK2)
+- CFLAGS += $(CFLAGS2)
+-else
+- CFLAGS += $(CFLAGS1)
+-endif
++CFLAGS += -D$(GTK_VER) `pkg-config --cflags gtk+-2.0`
++LDLIBS = `pkg-config --libs gtk+-2.0`
+ DEBUG =
+ #DEBUG = -D DEBUG
+ GDAVL = gdavl
+
+
+-$(GDAVL): gdavl.c if.c gdavl.h
+- $(CC) $(CFLAGS) $(DEBUG) -o $(GDAVL) gdavl.c if.c
++$(GDAVL): gdavl.o if.o
+
+ clean:
+ rm -rf $(GDAVL) *.o test/*.png test/log test/test.log