summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-06-02 21:50:53 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-06-02 21:50:53 +0000
commit5ed51957fa2ffd9ed53fe06d84904037ca416fa3 (patch)
treea6eecd8df2647a4fca4b19661ab2832993aa8e53 /sys-fs/dd-rescue/dd-rescue-1.03.ebuild
parentRemoved sash and mac-fdisk from the stage3 profile because problems with 2.6 ... (diff)
downloadgentoo-2-5ed51957fa2ffd9ed53fe06d84904037ca416fa3.tar.gz
gentoo-2-5ed51957fa2ffd9ed53fe06d84904037ca416fa3.tar.bz2
gentoo-2-5ed51957fa2ffd9ed53fe06d84904037ca416fa3.zip
Closing #52431.
Diffstat (limited to 'sys-fs/dd-rescue/dd-rescue-1.03.ebuild')
-rw-r--r--sys-fs/dd-rescue/dd-rescue-1.03.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-fs/dd-rescue/dd-rescue-1.03.ebuild b/sys-fs/dd-rescue/dd-rescue-1.03.ebuild
new file mode 100644
index 000000000000..f3e6ac26542c
--- /dev/null
+++ b/sys-fs/dd-rescue/dd-rescue-1.03.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dd-rescue/dd-rescue-1.03.ebuild,v 1.1 2004/06/02 21:50:53 aliz Exp $
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+
+S=${WORKDIR}/${MY_PN}
+DESCRIPTION="similar to dd but can copy from source with errors"
+HOMEPAGE="http://www.garloff.de/kurt/linux/ddrescue/"
+SRC_URI="http://www.garloff.de/kurt/linux/ddrescue/${MY_P}.tar.gz"
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~sparc"
+
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ sed -i -e "s:^CFLAGS.*:CFLAGS = ${CFLAGS}:" \
+ Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc COPYING README.dd_rescue
+}
+