summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-12-05 10:22:04 +0000
committerTim Harder <radhermit@gentoo.org>2011-12-05 10:22:04 +0000
commit145fe4b401fe835fe3394a923e1d716f429a7d7a (patch)
treed91683399d86fdc811b81d9453ffb64d3ce2be27 /sys-fs/dd-rescue
parentUse REQUIRED_USE instead of providing sane defaults wrt #392683 by Murph <Mat... (diff)
downloadgentoo-2-145fe4b401fe835fe3394a923e1d716f429a7d7a.tar.gz
gentoo-2-145fe4b401fe835fe3394a923e1d716f429a7d7a.tar.bz2
gentoo-2-145fe4b401fe835fe3394a923e1d716f429a7d7a.zip
Version bump. Update to EAPI 4.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/dd-rescue')
-rw-r--r--sys-fs/dd-rescue/ChangeLog9
-rw-r--r--sys-fs/dd-rescue/dd-rescue-1.24.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/sys-fs/dd-rescue/ChangeLog b/sys-fs/dd-rescue/ChangeLog
index 4065cf4bd236..81dc7be8c0e8 100644
--- a/sys-fs/dd-rescue/ChangeLog
+++ b/sys-fs/dd-rescue/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/dd-rescue
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dd-rescue/ChangeLog,v 1.17 2010/11/19 18:53:47 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dd-rescue/ChangeLog,v 1.18 2011/12/05 10:22:04 radhermit Exp $
+
+*dd-rescue-1.24 (05 Dec 2011)
+
+ 05 Dec 2011; Tim Harder <radhermit@gentoo.org> +dd-rescue-1.24.ebuild:
+ Version bump. Update to EAPI 4.
19 Nov 2010; Justin Lecher <jlec@gentoo.org> dd-rescue-1.23.ebuild:
Import Prefix Changes
diff --git a/sys-fs/dd-rescue/dd-rescue-1.24.ebuild b/sys-fs/dd-rescue/dd-rescue-1.24.ebuild
new file mode 100644
index 000000000000..c03b07c3fae9
--- /dev/null
+++ b/sys-fs/dd-rescue/dd-rescue-1.24.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dd-rescue/dd-rescue-1.24.ebuild,v 1.1 2011/12/05 10:22:04 radhermit Exp $
+
+EAPI=4
+
+inherit base toolchain-funcs
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Similar to dd but can copy from source with errors"
+HOMEPAGE="http://www.garloff.de/kurt/linux/ddrescue/"
+SRC_URI="http://www.garloff.de/kurt/linux/ddrescue/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~arm ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="static kernel_linux elibc_glibc"
+
+S=${WORKDIR}/${MY_PN}
+
+src_compile() {
+ use static && append-flags -static
+
+ # Passing LDFLAGS together with CFLAGS is not often a good idea, but
+ # in this case it makes it possible to avoid patching; after all it
+ # only builds the progrma whole, not with object files.
+ #
+ # The falloc target creates a dd_rescue binary that uses the
+ # fallocate() function, present in Kernel 2.6.23 and later and GLIBC
+ # 2.10 and later. If somebody can think of a better way to
+ # optionally use it, suggestions are welcome.
+ emake RPM_OPT_FLAGS="${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" \
+ $(use kernel_linux && use elibc_glibc && echo "falloc")
+}
+
+src_install() {
+ # easier to install by hand than trying to make sense of the
+ # Makefile.
+ into /
+ dobin dd_rescue
+
+ dodoc README.dd_rescue
+}