summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-08-26 14:06:14 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-08-26 14:06:14 +0000
commit315e792e942df4a1c6cff353d4088533f3a6811e (patch)
tree1ed8fe6e38cba8093305260bd8ca5290af4d934a /sys-fs/device-mapper/device-mapper-1.02.22.ebuild
parentVersion bump. Fixes bug #190014. (diff)
downloadgentoo-2-315e792e942df4a1c6cff353d4088533f3a6811e.tar.gz
gentoo-2-315e792e942df4a1c6cff353d4088533f3a6811e.tar.bz2
gentoo-2-315e792e942df4a1c6cff353d4088533f3a6811e.zip
Version bumped. Added patch for option info --export, and updated udev-rules to use these. That should solve bug #189404.
(Portage version: 2.1.3.7)
Diffstat (limited to 'sys-fs/device-mapper/device-mapper-1.02.22.ebuild')
-rw-r--r--sys-fs/device-mapper/device-mapper-1.02.22.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sys-fs/device-mapper/device-mapper-1.02.22.ebuild b/sys-fs/device-mapper/device-mapper-1.02.22.ebuild
new file mode 100644
index 000000000000..f69fe30642b9
--- /dev/null
+++ b/sys-fs/device-mapper/device-mapper-1.02.22.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/device-mapper-1.02.22.ebuild,v 1.1 2007/08/26 14:06:14 zzam Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Device mapper ioctl library for use with LVM2 utilities"
+HOMEPAGE="http://sources.redhat.com/dm/"
+SRC_URI="ftp://sources.redhat.com/pub/dm/${PN}.${PV}.tgz
+ ftp://sources.redhat.com/pub/dm/old/${PN}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND="selinux? ( sys-libs/libselinux )"
+
+S=${WORKDIR}/${PN}.${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch ${FILESDIR}/device-mapper-1.02.22-export-format.diff
+}
+
+src_compile() {
+ econf --sbindir=/sbin $(use_enable selinux) || die "econf failed"
+ emake || die "compile problem"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ # move shared libs to /
+ mv "${D}"/usr/$(get_libdir) "${D}"/ || die "move libdir"
+ dolib.a lib/ioctl/libdevmapper.a || die "dolib.a"
+ gen_usr_ldscript libdevmapper.so
+
+ insinto /etc
+ doins "${FILESDIR}"/dmtab
+ insinto /lib/rcscripts/addons
+ doins "${FILESDIR}"/dm-start.sh
+
+ newinitd "${FILESDIR}"/device-mapper.rc device-mapper || die
+
+ insinto /etc/udev/rules.d/
+ newins "${FILESDIR}"/64-device-mapper.rules-1.02.22 64-device-mapper.rules
+
+ dodoc INSTALL INTRO README VERSION WHATS_NEW
+}
+
+pkg_preinst() {
+ local l=${ROOT}/$(get_libdir)/libdevmapper.so.1.01
+ [[ -e ${l} ]] && cp "${l}" "${D}"/$(get_libdir)/
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /$(get_libdir)/libdevmapper.so.1.01
+
+ elog "device-mapper volumes are no longer automatically created for"
+ elog "baselayout-2 users. If you are using baselayout-2, be sure to"
+ elog "run: # rc-update add device-mapper boot"
+}