summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2009-09-09 21:02:11 +0000
committerThomas Sachau <tommy@gentoo.org>2009-09-09 21:02:11 +0000
commit61539a6fd13834fdd61354b99934ed21da94c1ee (patch)
treeb6205131d4b9ba6e1543c8b9e2ad032e5ed02170 /sys-fs/dmraid
parentRemove poppler-0.11* mask. 0.12.0 is in-tree. (diff)
downloadgentoo-2-61539a6fd13834fdd61354b99934ed21da94c1ee.tar.gz
gentoo-2-61539a6fd13834fdd61354b99934ed21da94c1ee.tar.bz2
gentoo-2-61539a6fd13834fdd61354b99934ed21da94c1ee.zip
Proxy commit for Ian Stakenvicius, see ChangeLog for details
(Portage version: 2.2_rc40-r1/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/dmraid')
-rw-r--r--sys-fs/dmraid/ChangeLog9
-rw-r--r--sys-fs/dmraid/dmraid-1.0.0_rc14.ebuild4
-rw-r--r--sys-fs/dmraid/dmraid-1.0.0_rc15-r1.ebuild75
3 files changed, 85 insertions, 3 deletions
diff --git a/sys-fs/dmraid/ChangeLog b/sys-fs/dmraid/ChangeLog
index 2f9cadd2eda9..1e4fc393fe26 100644
--- a/sys-fs/dmraid/ChangeLog
+++ b/sys-fs/dmraid/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/dmraid
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/ChangeLog,v 1.18 2009/09/08 14:17:37 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/ChangeLog,v 1.19 2009/09/09 21:02:11 tommy Exp $
+
+ 08 Sep 2009; Ian Stakenvicius <ian@aerobiology.ca>
+ dmraid-1.0.0_rc14.ebuild, +dmraid-1.0.0_rc15-r1.ebuild,
+ +files/dmraid-1.0.0_rc15-devsk-isw.patch,
+ +files/dmraid-1.0.0_rc15-undo-p-rename.patch:
+ Updated SRC_URI for rc14, bumped rc15 to -r1 (for ~ppc) to apply patches to
+ fix bug #275566 and bug #275451
08 Sep 2009; Samuli Suominen <ssuominen@gentoo.org>
dmraid-1.0.0_rc14.ebuild:
diff --git a/sys-fs/dmraid/dmraid-1.0.0_rc14.ebuild b/sys-fs/dmraid/dmraid-1.0.0_rc14.ebuild
index 0ab2983d73fc..382c5c08969e 100644
--- a/sys-fs/dmraid/dmraid-1.0.0_rc14.ebuild
+++ b/sys-fs/dmraid/dmraid-1.0.0_rc14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/dmraid-1.0.0_rc14.ebuild,v 1.4 2009/09/08 14:17:37 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/dmraid-1.0.0_rc14.ebuild,v 1.5 2009/09/09 21:02:11 tommy Exp $
inherit linux-info flag-o-matic
@@ -9,7 +9,7 @@ MY_P=${PN}-${MY_PV}
DESCRIPTION="Device-mapper RAID tool and library"
HOMEPAGE="http://people.redhat.com/~heinzm/sw/dmraid/"
-SRC_URI="http://people.redhat.com/~heinzm/sw/dmraid/src/${MY_P}.tar.bz2"
+SRC_URI="http://people.redhat.com/~heinzm/sw/dmraid/src/old/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
diff --git a/sys-fs/dmraid/dmraid-1.0.0_rc15-r1.ebuild b/sys-fs/dmraid/dmraid-1.0.0_rc15-r1.ebuild
new file mode 100644
index 000000000000..2f96bdf969b3
--- /dev/null
+++ b/sys-fs/dmraid/dmraid-1.0.0_rc15-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/dmraid-1.0.0_rc15-r1.ebuild,v 1.1 2009/09/09 21:02:11 tommy Exp $
+
+inherit linux-info flag-o-matic
+
+MY_PV=${PV/_/.}
+
+DESCRIPTION="Device-mapper RAID tool and library"
+HOMEPAGE="http://people.redhat.com/~heinzm/sw/dmraid/"
+SRC_URI="http://people.redhat.com/~heinzm/sw/dmraid/src/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static selinux"
+
+DEPEND="|| ( >=sys-fs/lvm2-2.02.45
+ sys-fs/device-mapper )
+ selinux? ( sys-libs/libselinux
+ sys-libs/libsepol )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}/${MY_PV}
+
+pkg_setup() {
+ if kernel_is lt 2 6 ; then
+ ewarn "You are using a kernel < 2.6"
+ ewarn "DMraid uses recently introduced Device-Mapper features."
+ ewarn "These might be unavailable in the kernel you are running now."
+ fi
+ if use static && use selinux ; then
+ eerror "ERROR - cannot compile static with libselinux / libsepol"
+ die "USE flag conflicts."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-destdir-fix.patch"
+ epatch "${FILESDIR}/${P}-devsk-isw.patch"
+ epatch "${FILESDIR}/${P}-undo-p-rename.patch"
+}
+
+src_compile() {
+ econf \
+ $(use_enable static static_link) \
+ $(use_enable selinux libselinux) \
+ $(use_enable selinux libsepol)
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc CHANGELOG README TODO KNOWN_BUGS doc/* || die "dodoc failed"
+}
+
+pkg_postinst() {
+ einfo "For booting Gentoo from Device-Mapper RAID you can use Genkernel."
+ einfo " "
+ einfo "Genkernel will generate the kernel and the initrd with a statically "
+ einfo "linked dmraid binary (its own version which may not be the same as this version):"
+ einfo " emerge -av sys-kernel/genkernel"
+ einfo " genkernel --dmraid --udev all"
+ einfo " "
+ einfo "If you would rather use this version of DMRAID with Genkernel, copy the distfile"
+ einfo "from your distdir to '/usr/share/genkernel/pkg/' and update the following"
+ einfo "in /etc/genkernel.conf:"
+ einfo " DMRAID_VER=\"${MY_PV/_/.}\""
+ einfo " DMRAID_SRCTAR=\"\${GK_SHARE}/pkg/${A}\""
+ einfo " "
+ ewarn "DMRAID should be safe to use, but no warranties can be given"
+ einfo " "
+}