summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-11 00:49:01 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-11 00:49:01 +0000
commit0ea5db55ac14f06907c88216aee5c2ffba2b87f6 (patch)
treefb9579a2b092a5457b1ee63e149693cdb73f9811 /sys-fs/e2fsprogs
parentVersion bump. (diff)
downloadgentoo-2-0ea5db55ac14f06907c88216aee5c2ffba2b87f6.tar.gz
gentoo-2-0ea5db55ac14f06907c88216aee5c2ffba2b87f6.tar.bz2
gentoo-2-0ea5db55ac14f06907c88216aee5c2ffba2b87f6.zip
old
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/e2fsprogs')
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.41.0.ebuild115
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.41.1.ebuild115
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.41.2.ebuild115
3 files changed, 0 insertions, 345 deletions
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.41.0.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.41.0.ebuild
deleted file mode 100644
index 6b700258ff1a..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.41.0.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.41.0.ebuild,v 1.3 2008/08/16 15:32:12 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs multilib
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="nls elibc_FreeBSD"
-
-RDEPEND="~sys-libs/${PN}-libs-${PV}
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch #99766
- epatch "${FILESDIR}"/${PN}-1.41.0-makefile.patch
- epatch "${FILESDIR}"/${PN}-1.40-fbsd.patch
- # blargh ... trick e2fsprogs into using e2fsprogs-libs
- rm -rf doc
- sed -i -r \
- -e 's:@LIBINTL@:@LTLIBINTL@:' \
- -e '/^LIB(BLKID|COM_ERR|SS|UUID)/s:[$][(]LIB[)]/lib([^@]*)@LIB_EXT@:-l\1:' \
- -e '/^DEPLIB(BLKID|COM_ERR|SS|UUID)/s:=.*:=:' \
- MCONFIG.in || die "muck libs" #122368
- sed -i -r \
- -e '/^LIB_SUBDIRS/s:lib/(blkid|et|ss|uuid)::g' \
- Makefile.in || die "remove subdirs"
- touch lib/ss/ss_err.h
-}
-
-src_compile() {
- # Keep the package from doing silly things
- addwrite /var/cache/fonts
- export LDCONFIG=:
- export CC=$(tc-getCC)
- export STRIP=:
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- econf \
- --bindir=/bin \
- --sbindir=/sbin \
- --enable-${libtype}-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !elibc_uclibc tls) \
- --without-included-gettext \
- $(use_enable nls) \
- $(use_enable userland_GNU fsck) \
- || die
- if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
- die "Preventing included intl cruft from building"
- fi
- emake COMPILE_ET=compile_et MK_CMDS=mk_cmds || die
-
- # Build the FreeBSD helper
- if use elibc_FreeBSD ; then
- cp "${FILESDIR}"/fsck_ext2fs.c .
- emake fsck_ext2fs || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- emake DESTDIR="${D}" install-libs || die
- dodoc README RELEASE-NOTES
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- local lib slib
- for lib in "${D}"/usr/$(get_libdir)/*.a ; do
- slib=${lib##*/}
- mv "${lib%.a}"$(get_libname)* "${D}"/$(get_libdir)/ || die "moving lib ${slib}"
- gen_usr_ldscript ${slib%.a}$(get_libname)
- done
-
- # move 'useless' stuff to /usr/
- dosbin "${D}"/sbin/mklost+found
- rm -f "${D}"/sbin/mklost+found
-
- if use elibc_FreeBSD ; then
- # Install helpers for us
- into /
- dosbin "${S}"/fsck_ext2fs || die
- doman "${FILESDIR}"/fsck_ext2fs.8
-
- # these manpages are already provided by FreeBSD libc
- # and filefrag is linux only
- rm -f \
- "${D}"/sbin/filefrag \
- "${D}"/usr/share/man/man8/filefrag.8 \
- "${D}"/bin/uuidgen \
- "${D}"/usr/share/man/man3/{uuid,uuid_compare}.3 \
- "${D}"/usr/share/man/man1/uuidgen.1 || die
- fi
-}
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.41.1.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.41.1.ebuild
deleted file mode 100644
index 88b9933c95e4..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.41.1.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.41.1.ebuild,v 1.1 2008/09/01 21:01:49 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs multilib
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="nls elibc_FreeBSD"
-
-RDEPEND="~sys-libs/${PN}-libs-${PV}
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch #99766
- epatch "${FILESDIR}"/${PN}-1.41.0-makefile.patch
- epatch "${FILESDIR}"/${PN}-1.40-fbsd.patch
- # blargh ... trick e2fsprogs into using e2fsprogs-libs
- rm -rf doc
- sed -i -r \
- -e 's:@LIBINTL@:@LTLIBINTL@:' \
- -e '/^LIB(BLKID|COM_ERR|SS|UUID)/s:[$][(]LIB[)]/lib([^@]*)@LIB_EXT@:-l\1:' \
- -e '/^DEPLIB(BLKID|COM_ERR|SS|UUID)/s:=.*:=:' \
- MCONFIG.in || die "muck libs" #122368
- sed -i -r \
- -e '/^LIB_SUBDIRS/s:lib/(blkid|et|ss|uuid)::g' \
- Makefile.in || die "remove subdirs"
- touch lib/ss/ss_err.h
-}
-
-src_compile() {
- # Keep the package from doing silly things
- addwrite /var/cache/fonts
- export LDCONFIG=:
- export CC=$(tc-getCC)
- export STRIP=:
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- econf \
- --bindir=/bin \
- --sbindir=/sbin \
- --enable-${libtype}-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !elibc_uclibc tls) \
- --without-included-gettext \
- $(use_enable nls) \
- $(use_enable userland_GNU fsck) \
- || die
- if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
- die "Preventing included intl cruft from building"
- fi
- emake COMPILE_ET=compile_et MK_CMDS=mk_cmds || die
-
- # Build the FreeBSD helper
- if use elibc_FreeBSD ; then
- cp "${FILESDIR}"/fsck_ext2fs.c .
- emake fsck_ext2fs || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- emake DESTDIR="${D}" install-libs || die
- dodoc README RELEASE-NOTES
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- local lib slib
- for lib in "${D}"/usr/$(get_libdir)/*.a ; do
- slib=${lib##*/}
- mv "${lib%.a}"$(get_libname)* "${D}"/$(get_libdir)/ || die "moving lib ${slib}"
- gen_usr_ldscript ${slib%.a}$(get_libname)
- done
-
- # move 'useless' stuff to /usr/
- dosbin "${D}"/sbin/mklost+found
- rm -f "${D}"/sbin/mklost+found
-
- if use elibc_FreeBSD ; then
- # Install helpers for us
- into /
- dosbin "${S}"/fsck_ext2fs || die
- doman "${FILESDIR}"/fsck_ext2fs.8
-
- # these manpages are already provided by FreeBSD libc
- # and filefrag is linux only
- rm -f \
- "${D}"/sbin/filefrag \
- "${D}"/usr/share/man/man8/filefrag.8 \
- "${D}"/bin/uuidgen \
- "${D}"/usr/share/man/man3/{uuid,uuid_compare}.3 \
- "${D}"/usr/share/man/man1/uuidgen.1 || die
- fi
-}
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.41.2.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.41.2.ebuild
deleted file mode 100644
index 2c1670a35a55..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.41.2.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.41.2.ebuild,v 1.7 2008/11/09 09:50:05 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs multilib
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh ~sparc x86 ~x86-fbsd"
-IUSE="nls elibc_FreeBSD"
-
-RDEPEND="~sys-libs/${PN}-libs-${PV}
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch #99766
- epatch "${FILESDIR}"/${PN}-1.41.2-makefile.patch
- epatch "${FILESDIR}"/${PN}-1.40-fbsd.patch
- # blargh ... trick e2fsprogs into using e2fsprogs-libs
- rm -rf doc
- sed -i -r \
- -e 's:@LIBINTL@:@LTLIBINTL@:' \
- -e '/^LIB(BLKID|COM_ERR|SS|UUID)/s:[$][(]LIB[)]/lib([^@]*)@LIB_EXT@:-l\1:' \
- -e '/^DEPLIB(BLKID|COM_ERR|SS|UUID)/s:=.*:=:' \
- MCONFIG.in || die "muck libs" #122368
- sed -i -r \
- -e '/^LIB_SUBDIRS/s:lib/(blkid|et|ss|uuid)::g' \
- Makefile.in || die "remove subdirs"
- touch lib/ss/ss_err.h
-}
-
-src_compile() {
- # Keep the package from doing silly things
- addwrite /var/cache/fonts
- export LDCONFIG=:
- export CC=$(tc-getCC)
- export STRIP=:
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- econf \
- --bindir=/bin \
- --sbindir=/sbin \
- --enable-${libtype}-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !elibc_uclibc tls) \
- --without-included-gettext \
- $(use_enable nls) \
- $(use_enable userland_GNU fsck) \
- || die
- if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
- die "Preventing included intl cruft from building"
- fi
- emake COMPILE_ET=compile_et MK_CMDS=mk_cmds || die
-
- # Build the FreeBSD helper
- if use elibc_FreeBSD ; then
- cp "${FILESDIR}"/fsck_ext2fs.c .
- emake fsck_ext2fs || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- emake DESTDIR="${D}" install-libs || die
- dodoc README RELEASE-NOTES
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- local lib slib
- for lib in "${D}"/usr/$(get_libdir)/*.a ; do
- slib=${lib##*/}
- mv "${lib%.a}"$(get_libname)* "${D}"/$(get_libdir)/ || die "moving lib ${slib}"
- gen_usr_ldscript ${slib%.a}$(get_libname)
- done
-
- # move 'useless' stuff to /usr/
- dosbin "${D}"/sbin/mklost+found
- rm -f "${D}"/sbin/mklost+found
-
- if use elibc_FreeBSD ; then
- # Install helpers for us
- into /
- dosbin "${S}"/fsck_ext2fs || die
- doman "${FILESDIR}"/fsck_ext2fs.8
-
- # these manpages are already provided by FreeBSD libc
- # and filefrag is linux only
- rm -f \
- "${D}"/sbin/filefrag \
- "${D}"/usr/share/man/man8/filefrag.8 \
- "${D}"/bin/uuidgen \
- "${D}"/usr/share/man/man3/{uuid,uuid_compare}.3 \
- "${D}"/usr/share/man/man1/uuidgen.1 || die
- fi
-}