summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-24 08:52:42 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-24 08:52:42 +0000
commit8c360c29aff6c7626108311898991ee265fdc484 (patch)
treecbc27169ffb2d101f461e5e1b7d780e0538e7973 /sys-fs/e2fsprogs
parentmake sure people dont stabilize this (diff)
downloadgentoo-2-8c360c29aff6c7626108311898991ee265fdc484.tar.gz
gentoo-2-8c360c29aff6c7626108311898991ee265fdc484.tar.bz2
gentoo-2-8c360c29aff6c7626108311898991ee265fdc484.zip
Grab fix from upstream for blkid memleak #171844 by Andrej Filipcic and drop ext4 support #167562 by Maurice Volaski.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sys-fs/e2fsprogs')
-rw-r--r--sys-fs/e2fsprogs/ChangeLog9
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.39-r2.ebuild118
-rw-r--r--sys-fs/e2fsprogs/files/digest-e2fsprogs-1.39-r23
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.39-blkid-memleak.patch53
4 files changed, 182 insertions, 1 deletions
diff --git a/sys-fs/e2fsprogs/ChangeLog b/sys-fs/e2fsprogs/ChangeLog
index fac321366f5d..61585bd25908 100644
--- a/sys-fs/e2fsprogs/ChangeLog
+++ b/sys-fs/e2fsprogs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/e2fsprogs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.95 2007/01/26 22:40:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.96 2007/03/24 08:52:42 vapier Exp $
+
+*e2fsprogs-1.39-r2 (24 Mar 2007)
+
+ 24 Mar 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/e2fsprogs-1.39-blkid-memleak.patch, +e2fsprogs-1.39-r2.ebuild:
+ Grab fix from upstream for blkid memleak #171844 by Andrej Filipcic and drop
+ ext4 support #167562 by Maurice Volaski.
26 Jan 2007; Mike Frysinger <vapier@gentoo.org>
files/e2fsprogs-1.39-makefile.patch:
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.39-r2.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.39-r2.ebuild
new file mode 100644
index 000000000000..b4971b705c4c
--- /dev/null
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.39-r2.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.39-r2.ebuild,v 1.1 2007/03/24 08:52:42 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls static"
+
+RDEPEND="~sys-libs/com_err-${PV}
+ ~sys-libs/ss-${PV}
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-apps/texinfo"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-blkid-memleak.patch #171844
+ # Fix locale issues while running tests #99766
+ epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch
+ epatch "${FILESDIR}"/${PN}-1.38-locale.patch #131462
+ # Fix a cosmetic error in mk_cmds's help output.
+ epatch "${FILESDIR}"/e2fsprogs-1.32-mk_cmds-cosmetic.patch
+ epatch "${FILESDIR}"/e2fsprogs-1.39-util-strptime.patch
+ chmod u+w po/*.po # Userpriv fix #27348
+ # Clean up makefile to suck less
+ epatch "${FILESDIR}"/e2fsprogs-1.39-makefile.patch
+ epatch "${FILESDIR}"/e2fsprogs-1.39-parse-types.patch #146903
+ # Fixes libintl handling on non-glibc #122368
+ epatch "${FILESDIR}"/${PN}-1.39-libintl.patch
+
+ # kernel headers use the same defines as e2fsprogs and can cause issues #48829
+ sed -i \
+ -e 's:CONFIG_JBD_DEBUG:__CONFIG_JBD_DEBUG__E2FS:g' \
+ $(grep -rl CONFIG_JBD_DEBUG *) \
+ || die "sed jbd debug failed"
+
+ # fake out files we forked into sep packages
+ sed -i \
+ -e '/^LIB_SUBDIRS/s:lib/et::' \
+ -e '/^LIB_SUBDIRS/s:lib/ss::' \
+ Makefile.in || die "remove subdirs"
+ ln -s "${ROOT}"/usr/$(get_libdir)/libcom_err.a lib/libcom_err.a
+ ln -s "${ROOT}"/$(get_libdir)/libcom_err.so lib/libcom_err.so
+ ln -s /usr/bin/mk_cmds lib/ss/mk_cmds
+ ln -s "${ROOT}"/usr/include/ss/ss_err.h lib/ss/
+ ln -s "${ROOT}"/$(get_libdir)/libss.so lib/libss.so
+
+ # sanity check for Bug 105304
+ if [[ -z ${USERLAND} ]] ; then
+ eerror "You just hit Bug 105304, please post your 'emerge info' here:"
+ eerror "http://bugs.gentoo.org/105304"
+ die "Aborting to prevent screwing your system"
+ fi
+}
+
+src_compile() {
+ # Keep the package from doing silly things
+ export LDCONFIG=/bin/true
+ export CC=$(tc-getCC)
+ export STRIP=/bin/true
+
+ econf \
+ --bindir=/bin \
+ --sbindir=/sbin \
+ --enable-elf-shlibs \
+ --with-ldopts="${LDFLAGS}" \
+ $(use_enable !static dynamic-e2fsck) \
+ --without-included-gettext \
+ $(use_enable nls) \
+ $(use_enable userland_GNU fsck) \
+ || die
+ if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
+ eerror "INTL sanity check failed, aborting build."
+ eerror "Please post your ${S}/config.log file as an"
+ eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
+ die "Preventing included intl cruft from building"
+ fi
+ # Parallel make sometimes fails
+ emake -j1 COMPILE_ET=compile_et || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README RELEASE-NOTES SHLIBS
+ docinto e2fsck
+ dodoc e2fsck/ChangeLog e2fsck/CHANGES
+
+ # Move shared libraries to /lib/, install static libraries to /usr/lib/,
+ # and install linker scripts to /usr/lib/.
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/
+ dolib.a lib/*.a || die "dolib.a"
+ rm -f "${D}"/usr/$(get_libdir)/libcom_err.a #125146
+ local x
+ cd "${D}"/$(get_libdir)
+ for x in *.so ; do
+ gen_usr_ldscript ${x} || die "gen ldscript ${x}"
+ done
+
+ ln -s libext2fs.info.gz $D/usr/share/info/booga.info.gz
+ # move 'useless' stuff to /usr/
+ dosbin "${D}"/sbin/mklost+found
+ rm -f "${D}"/sbin/mklost+found
+
+ # these manpages are already provided by FreeBSD libc
+ use elibc_FreeBSD && \
+ rm -f "${D}"/usr/share/man/man3/{uuid,uuid_compare}.3 \
+ "${D}"/usr/share/man/man1/uuidgen.1
+}
diff --git a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.39-r2 b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.39-r2
new file mode 100644
index 000000000000..7e58444d768b
--- /dev/null
+++ b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.39-r2
@@ -0,0 +1,3 @@
+MD5 06f7806782e357797fad1d34b7ced0c6 e2fsprogs-1.39.tar.gz 3695111
+RMD160 67e77a7cbf0e719fa8b5a8ac6285b334e1c3481b e2fsprogs-1.39.tar.gz 3695111
+SHA256 dc2033447e69a1612881151f6f163e8a3b80e51d16f5e8b3576f3f8ccb325ea3 e2fsprogs-1.39.tar.gz 3695111
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.39-blkid-memleak.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.39-blkid-memleak.patch
new file mode 100644
index 000000000000..ce8ee8a4bcc9
--- /dev/null
+++ b/sys-fs/e2fsprogs/files/e2fsprogs-1.39-blkid-memleak.patch
@@ -0,0 +1,53 @@
+http://bugs.gentoo.org/171844
+
+# HG changeset patch
+# User tytso@mit.edu
+# Date Tue Mar 6 19:56:18 2007 -0500
+# Node ID 5a2a75111d7a6fc4b5ee99663f252a42d5a2b227
+# parent: 69a666bd25f57107a09e5bad0a158b8a810e6a63
+Fix memory leak in blkid library
+
+Addresses Debian Bug: #413661
+
+Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
+
+2007-03-06 Theodore Tso <tytso@mit.edu>
+
+ * devname.c (dm_probe_all), probe.c (blkid_verify): Fix memory
+ leak. (Addresses Debian Bug #413661)
+
+--- a/lib/blkid/devname.c Sun Mar 4 08:17:18 2007 -0500
++++ b/lib/blkid/devname.c Tue Mar 6 19:56:18 2007 -0500
+@@ -305,6 +305,7 @@
+ probe_one(cache, device, dev, BLKID_PRI_DM, only_if_new);
+
+ try_next:
++ free(device);
+ next = names->next;
+ } while (next);
+
+--- a/lib/blkid/probe.c Sun Mar 4 08:17:18 2007 -0500
++++ b/lib/blkid/probe.c Tue Mar 6 19:56:18 2007 -0500
+@@ -886,9 +886,9 @@
+ }
+
+ if (!dev->bid_type) {
+- if (probe.fd >= 0) close(probe.fd);
+ blkid_free_dev(dev);
+- return NULL;
++ dev = 0;
++ goto found_type;
+ }
+
+ found_type:
+@@ -908,7 +908,8 @@
+ free(probe.sbbuf);
+ if (probe.buf)
+ free(probe.buf);
+- close(probe.fd);
++ if (probe.fd >= 0)
++ close(probe.fd);
+
+ return dev;
+ }
+