summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2011-11-22 23:05:54 +0000
committerSebastian Pipping <sping@gentoo.org>2011-11-22 23:05:54 +0000
commitbc9bbd4afa293fe13347ce663f0b711aba9390c1 (patch)
tree2e8bc250ed907054a3c4ec31d8759c760392bc5d /sys-fs/encfs
parentRestrict tests, not going to fiddle with stable version (diff)
downloadgentoo-2-bc9bbd4afa293fe13347ce663f0b711aba9390c1.tar.gz
gentoo-2-bc9bbd4afa293fe13347ce663f0b711aba9390c1.tar.bz2
gentoo-2-bc9bbd4afa293fe13347ce663f0b711aba9390c1.zip
sys-fs/encfs: Bump to 1.7.4 (bug #346299)
(Portage version: 2.1.10.36/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/encfs')
-rw-r--r--sys-fs/encfs/ChangeLog8
-rw-r--r--sys-fs/encfs/encfs-1.7.4.ebuild51
-rw-r--r--sys-fs/encfs/files/encfs-1.7.4-r68:69.patch31
3 files changed, 89 insertions, 1 deletions
diff --git a/sys-fs/encfs/ChangeLog b/sys-fs/encfs/ChangeLog
index d1304f4344e4..414eb4950307 100644
--- a/sys-fs/encfs/ChangeLog
+++ b/sys-fs/encfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/encfs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/ChangeLog,v 1.57 2011/11/22 22:36:22 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/ChangeLog,v 1.58 2011/11/22 23:05:54 sping Exp $
+
+*encfs-1.7.4 (22 Nov 2011)
+
+ 22 Nov 2011; Sebastian Pipping <sping@gentoo.org> +encfs-1.7.4.ebuild,
+ +files/encfs-1.7.4-r68:69.patch:
+ Bump to 1.7.4, looks trivial. Post-release upstream bugfix patch included.
22 Nov 2011; Anthony G. Basile <blueness@gentoo.org> metadata.xml:
Added myself as maintainer
diff --git a/sys-fs/encfs/encfs-1.7.4.ebuild b/sys-fs/encfs/encfs-1.7.4.ebuild
new file mode 100644
index 000000000000..71215351d753
--- /dev/null
+++ b/sys-fs/encfs/encfs-1.7.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/encfs-1.7.4.ebuild,v 1.1 2011/11/22 23:05:54 sping Exp $
+
+EAPI=2
+inherit eutils multilib versionator
+
+DESCRIPTION="An implementation of encrypted filesystem in user-space using FUSE"
+HOMEPAGE="http://www.arg0.net/encfs/"
+SRC_URI="http://encfs.googlecode.com/files/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="xattr"
+
+RDEPEND=">=dev-libs/boost-1.34
+ >=dev-libs/openssl-0.9.7
+ >=dev-libs/rlog-1.4
+ >=sys-fs/fuse-2.7.0"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/pkgconfig
+ xattr? ( sys-apps/attr )
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.7.4-r68:69.patch
+}
+
+src_configure() {
+ BOOST_PKG="$(best_version dev-libs/boost)"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
+ einfo "Building against ${BOOST_PKG}."
+
+ use xattr || export ac_cv_header_attr_xattr_h=no
+
+ econf \
+ --with-boost=${BOOST_INC} \
+ --with-boost-libdir=${BOOST_LIB} \
+ --disable-dependency-tracking
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README
+ find "${D}" -name '*.la' -delete
+}
diff --git a/sys-fs/encfs/files/encfs-1.7.4-r68:69.patch b/sys-fs/encfs/files/encfs-1.7.4-r68:69.patch
new file mode 100644
index 000000000000..0c27095fff16
--- /dev/null
+++ b/sys-fs/encfs/files/encfs-1.7.4-r68:69.patch
@@ -0,0 +1,31 @@
+Index: encfs/base64.cpp
+===================================================================
+--- encfs/base64.cpp (revision 68)
++++ encfs/base64.cpp (revision 69)
+@@ -80,7 +80,7 @@
+ }
+
+ // we have at least one value that can be output
+- char outVal = work & mask;
++ unsigned char outVal = work & mask;
+ work >>= dst2Pow;
+ workBits -= dst2Pow;
+
+@@ -96,8 +96,15 @@
+ *outLoc++ = outVal;
+
+ // we could have a partial value left in the work buffer..
+- if(workBits && outputPartialLastByte)
+- *outLoc = work & mask;
++ if(outputPartialLastByte)
++ {
++ while(workBits > 0)
++ {
++ *outLoc++ = work & mask;
++ work >>= dst2Pow;
++ workBits -= dst2Pow;
++ }
++ }
+ }
+ }
+