summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-03-06 23:17:45 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-03-06 23:17:45 +0000
commit8c7c52021684ff4ed29768310d236bb61285bc0b (patch)
treecf57add33f2591b888ccb65aefeb3f2e838de598 /sys-fs/evms
parentx11-wm/dwm: Version bump (diff)
downloadgentoo-2-8c7c52021684ff4ed29768310d236bb61285bc0b.tar.gz
gentoo-2-8c7c52021684ff4ed29768310d236bb61285bc0b.tar.bz2
gentoo-2-8c7c52021684ff4ed29768310d236bb61285bc0b.zip
Added patch to fix bug #169623. Fixed some problems with the tests.
(Portage version: 2.1.2-r10)
Diffstat (limited to 'sys-fs/evms')
-rw-r--r--sys-fs/evms/ChangeLog6
-rw-r--r--sys-fs/evms/evms-2.5.5-r5.ebuild7
-rw-r--r--sys-fs/evms/files/evms-2.5.5-getpagesize.patch55
3 files changed, 64 insertions, 4 deletions
diff --git a/sys-fs/evms/ChangeLog b/sys-fs/evms/ChangeLog
index 87f3a6563074..60324beefb7b 100644
--- a/sys-fs/evms/ChangeLog
+++ b/sys-fs/evms/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/evms
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/evms/ChangeLog,v 1.62 2007/02/04 19:16:40 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/evms/ChangeLog,v 1.63 2007/03/06 23:17:45 dev-zero Exp $
+
+ 06 Mar 2007; Tiziano Müller <dev-zero@gentoo.org>
+ +files/evms-2.5.5-getpagesize.patch, evms-2.5.5-r5.ebuild:
+ Added patch to fix bug #169623. Fixed some problems with the tests.
04 Feb 2007; Steve Dibb <beandog@gentoo.org> evms-2.5.5-r4.ebuild,
evms-2.5.5-r5.ebuild:
diff --git a/sys-fs/evms/evms-2.5.5-r5.ebuild b/sys-fs/evms/evms-2.5.5-r5.ebuild
index 92330403ee70..0a94e3a64c0a 100644
--- a/sys-fs/evms/evms-2.5.5-r5.ebuild
+++ b/sys-fs/evms/evms-2.5.5-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/evms/evms-2.5.5-r5.ebuild,v 1.5 2007/02/04 19:16:40 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/evms/evms-2.5.5-r5.ebuild,v 1.6 2007/03/06 23:17:45 dev-zero Exp $
WANT_AUTOMAKE="latest"
WANT_AUTOCONF="latest"
@@ -46,6 +46,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-glib_dep.patch"
epatch "${FILESDIR}/${P}-ocfs2.patch"
epatch "${FILESDIR}/${P}-use_disk_group.patch"
+ epatch "${FILESDIR}/${P}-getpagesize.patch"
eautoreconf
}
@@ -125,7 +126,7 @@ src_test() {
einfo " dd if=/dev/zero of=/tmp/evms_test_file bs=1M count=4096"
einfo "- Activate a loop device on this file:"
einfo " losetup /dev/loop0 /tmp/evms_test_file"
- einfo "- export EVMS_TEST_VOLUME=loop0"
+ einfo "- export EVMS_TEST_VOLUME=loop/0"
einfo "The disk has to be at least 4GB!"
einfo "To deactivate the loop-device afterwards:"
einfo "- losetup -d /dev/loop0"
@@ -148,5 +149,5 @@ src_test() {
addwrite /var/lock/evms-engine
cd "${S}/tests/suite"
- PATH="${PATH}:/sbin:/${S}/tests" ./run_tests ${EVMS_TEST_VOLUME} || die "tests failed"
+ PATH="${S}/ui/cli:${S}/tests:/sbin:${PATH}" ./run_tests ${EVMS_TEST_VOLUME} || die "tests failed"
}
diff --git a/sys-fs/evms/files/evms-2.5.5-getpagesize.patch b/sys-fs/evms/files/evms-2.5.5-getpagesize.patch
new file mode 100644
index 000000000000..656d68429b39
--- /dev/null
+++ b/sys-fs/evms/files/evms-2.5.5-getpagesize.patch
@@ -0,0 +1,55 @@
+diff -Naur evms-2.5.5.orig/plugins/swap/swapfs.c evms-2.5.5/plugins/swap/swapfs.c
+--- evms-2.5.5.orig/plugins/swap/swapfs.c 2007-03-06 23:14:01.000000000 +0100
++++ evms-2.5.5/plugins/swap/swapfs.c 2007-03-06 23:14:54.000000000 +0100
+@@ -27,7 +27,6 @@
+ #include <plugin.h>
+ #include <fcntl.h>
+ #include <sys/wait.h>
+-#include <asm/page.h> /* to get PAGE_SIZE */
+ #include <sys/swap.h>
+
+ #include "swapfs.h"
+@@ -341,7 +340,7 @@
+
+ *max_volume_size = (sector_count_t)-1; /* No limit. */
+ *max_object_size = (sector_count_t)-1; /* No limit. */
+- *min_size = (sector_count_t)(PAGE_SIZE * 10); /* 10 page minimum. */
++ *min_size = (sector_count_t)(getpagesize() * 10); /* 10 page minimum. */
+
+ LOG_EXTRA("Volume: %s, min: %"PRIu64", max: %"PRIu64"\n",
+ volume->name, *min_size, *max_volume_size);
+diff -Naur evms-2.5.5.orig/plugins/swap/swapfs.h evms-2.5.5/plugins/swap/swapfs.h
+--- evms-2.5.5.orig/plugins/swap/swapfs.h 2007-03-06 23:14:01.000000000 +0100
++++ evms-2.5.5/plugins/swap/swapfs.h 2007-03-06 23:14:42.000000000 +0100
+@@ -47,8 +47,8 @@
+ #define PUT 1
+ #define SWAPFS_MAGIC_STRING "SWAP_SPACE"
+ #define SWAPFS_MAGIC_STRING2 "SWAPSPACE2"
+-#define SWAPFS_MIN_SIZE (PAGE_SIZE / EVMS_VSECTOR_SIZE * 10)
+-#define SWAP_MAGIC_OFFSET_IN_BYTES (PAGE_SIZE - 10) /* last 10 bytes of first page */
++#define SWAPFS_MIN_SIZE (getpagesize() / EVMS_VSECTOR_SIZE * 10)
++#define SWAP_MAGIC_OFFSET_IN_BYTES (getpagesize() - 10) /* last 10 bytes of first page */
+
+ #define EVMS_Task_swapon EVMS_Task_Plugin_Function + 1
+ #define EVMS_Task_swapoff EVMS_Task_Plugin_Function + 2
+diff -Naur evms-2.5.5.orig/plugins/xfs/fsimxfs.h evms-2.5.5/plugins/xfs/fsimxfs.h
+--- evms-2.5.5.orig/plugins/xfs/fsimxfs.h 2007-03-06 23:14:01.000000000 +0100
++++ evms-2.5.5/plugins/xfs/fsimxfs.h 2007-03-06 23:16:00.000000000 +0100
+@@ -19,7 +19,7 @@
+ */
+
+ #include <uuid/uuid.h>
+-#include <asm/page.h>
++#include <unistd.h> /* for getpagesize() */
+
+ extern plugin_record_t xfs_plugin_record;
+ extern plugin_record_t * my_plugin_record;
+@@ -165,7 +165,7 @@
+ * superblock. This is not the same as the superblock structure, since all of
+ * this space is not currently being used.
+ */
+-#define SIZE_OF_SUPER PAGE_SIZE
++#define SIZE_OF_SUPER getpagesize()
+
+ /* Fixed byte offset of primary superblock */
+ #define XFS_SUPER1_OFF 0x00