summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2012-02-26 17:51:44 +0000
committerHanno Böck <hanno@gentoo.org>2012-02-26 17:51:44 +0000
commita512061ee66412295cd98e71c15b57e6b0f68074 (patch)
tree1811a81e5c55d76cebf8785fa501c5ea6bc29848 /sys-fs/ext3grep
parentpunt zfs-fuse. fails to build. multiple other bugs. can be introduced back to... (diff)
downloadgentoo-2-a512061ee66412295cd98e71c15b57e6b0f68074.tar.gz
gentoo-2-a512061ee66412295cd98e71c15b57e6b0f68074.tar.bz2
gentoo-2-a512061ee66412295cd98e71c15b57e6b0f68074.zip
ext3grep: fix build with e2fsprogs
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/ext3grep')
-rw-r--r--sys-fs/ext3grep/ChangeLog8
-rw-r--r--sys-fs/ext3grep/ext3grep-0.10.1.ebuild4
-rw-r--r--sys-fs/ext3grep/ext3grep-0.10.2.ebuild8
-rw-r--r--sys-fs/ext3grep/files/ext3grep-0.10.2-new-e2fsprogs.diff34
4 files changed, 48 insertions, 6 deletions
diff --git a/sys-fs/ext3grep/ChangeLog b/sys-fs/ext3grep/ChangeLog
index ce5c3564f2cf..8d5a85847870 100644
--- a/sys-fs/ext3grep/ChangeLog
+++ b/sys-fs/ext3grep/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/ext3grep
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext3grep/ChangeLog,v 1.4 2010/07/08 05:13:10 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext3grep/ChangeLog,v 1.5 2012/02/26 17:51:44 hanno Exp $
+
+ 26 Feb 2012; Hanno Boeck <hanno@gentoo.org> ext3grep-0.10.2.ebuild,
+ +files/ext3grep-0.10.2-new-e2fsprogs.diff:
+ Fix build with latest e2fsprogs.
08 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
ext3grep-0.10.2.ebuild:
diff --git a/sys-fs/ext3grep/ext3grep-0.10.1.ebuild b/sys-fs/ext3grep/ext3grep-0.10.1.ebuild
index edba8d013d45..8c8ca16fbd6c 100644
--- a/sys-fs/ext3grep/ext3grep-0.10.1.ebuild
+++ b/sys-fs/ext3grep/ext3grep-0.10.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext3grep/ext3grep-0.10.1.ebuild,v 1.3 2009/09/23 20:50:19 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext3grep/ext3grep-0.10.1.ebuild,v 1.4 2012/02/26 17:51:44 hanno Exp $
inherit eutils
diff --git a/sys-fs/ext3grep/ext3grep-0.10.2.ebuild b/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
index a5875e1ce596..04293ffeaee0 100644
--- a/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
+++ b/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext3grep/ext3grep-0.10.2.ebuild,v 1.2 2010/07/08 05:13:10 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext3grep/ext3grep-0.10.2.ebuild,v 1.3 2012/02/26 17:51:44 hanno Exp $
EAPI=3
inherit eutils
@@ -16,6 +16,10 @@ IUSE="debug pch"
src_prepare() {
epatch "${FILESDIR}"/${PN}-0.10.1-gcc44.patch
+
+ # Fix build against latest e2fsprogs, taken from
+ # https://code.google.com/p/ext3grep/issues/detail?id=34
+ epatch "${FILESDIR}"/${P}-new-e2fsprogs.diff
}
src_configure() {
diff --git a/sys-fs/ext3grep/files/ext3grep-0.10.2-new-e2fsprogs.diff b/sys-fs/ext3grep/files/ext3grep-0.10.2-new-e2fsprogs.diff
new file mode 100644
index 000000000000..45b54b807bd7
--- /dev/null
+++ b/sys-fs/ext3grep/files/ext3grep-0.10.2-new-e2fsprogs.diff
@@ -0,0 +1,34 @@
+diff -ur ext3grep-0.10.1/src/ext3.h ext3grep-0.10.1.new/src/ext3.h
+--- ext3grep-0.10.1/src/ext3.h 2008-04-09 11:20:31.000000000 +0000
++++ ext3grep-0.10.1.new/src/ext3.h 2011-12-10 07:00:50.000000000 +0000
+@@ -24,6 +24,17 @@
+ #ifndef EXT3_H
+ #define EXT3_H
+
++// this trickery needs to happen before ext2_fs is included so
++// bail out if it has already been included by another path
++#ifdef _LINUX_EXT2_FS_H
++ #error please include this file before any other includes of ext2fs/ext2_fs.h
++#endif
++
++// some versions of the ext2 headers call this s_frags_per_group and some
++// call it s_clusters_per_group, define one to the other so our code works
++// with both
++#define s_clusters_per_group s_frags_per_group
++
+ // Use the header files from e2progs (http://e2fsprogs.sourceforge.net)
+ // We can use these headers and then everything named ext2 or ext3.
+ #include <ext2fs/ext2_fs.h> // Definitions of ext2, ext3 and ext4.
+@@ -110,6 +121,12 @@
+ __u32 faddr(void) const { return i_faddr; }
+ __u16 uid_high(void) const { return i_uid_high; }
+ __u16 gid_high(void) const { return i_gid_high; }
++#ifndef i_reseved2
++ //i_reseved2 has been split into two fields in recent
++ //versions of the headers, luckilly we can still access
++ //it in one peice through the hurd side of the union
++ #define i_reserved2 osd2.hurd2.h_i_author
++#endif
+ __u32 reserved2(void) const { return i_reserved2; }
+
+ void set_reserved2(__u32 val) { i_reserved2 = val; }