summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-22 12:43:53 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-22 12:43:53 +0000
commit0cd2967e3fca1947469dc3111b428ba74c872bf0 (patch)
treea0466763e571b48a0e99801d892c875f7cdbe9ef /sys-fs/fuse4bsd/fuse4bsd-0.3.0.ebuild
parentRemove 3.4.1 for GLSA 200607-23 (diff)
downloadgentoo-2-0cd2967e3fca1947469dc3111b428ba74c872bf0.tar.gz
gentoo-2-0cd2967e3fca1947469dc3111b428ba74c872bf0.tar.bz2
gentoo-2-0cd2967e3fca1947469dc3111b428ba74c872bf0.zip
Add fuse4bsd ebuild, for FUSE's FreeBSD kernel module and userland. Ebuild by Robert Sebastian Gerus (bug #133548).
(Portage version: 2.1_rc1-r4)
Diffstat (limited to 'sys-fs/fuse4bsd/fuse4bsd-0.3.0.ebuild')
-rw-r--r--sys-fs/fuse4bsd/fuse4bsd-0.3.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-fs/fuse4bsd/fuse4bsd-0.3.0.ebuild b/sys-fs/fuse4bsd/fuse4bsd-0.3.0.ebuild
new file mode 100644
index 000000000000..e3bd20f04780
--- /dev/null
+++ b/sys-fs/fuse4bsd/fuse4bsd-0.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse4bsd/fuse4bsd-0.3.0.ebuild,v 1.1 2006/05/22 12:43:53 flameeyes Exp $
+
+inherit portability toolchain-funcs
+
+DESCRIPTION="Fuse for FreeBSD"
+HOMEPAGE="http://fuse4bsd.creo.hu/"
+# -sbin is needed for getmntopts.c, hardcoding 6.1 is nasty but can't think of
+# any better solution right now
+SRC_URI="http://fuse4bsd.creo.hu/downloads/${P}.tar.gz
+ mirror://gentoo/freebsd-sbin-6.1.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86-fbsd"
+IUSE=""
+
+DEPEND=">=sys-freebsd/freebsd-sources-6.0
+ virtual/pmake"
+RDEPEND="sys-fs/fuse"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp ${ROOT}/usr/include/fuse/fuse_kernel.h fuse_module/
+ cp ${WORKDIR}/sbin/mount/getmntopts.c mount_fusefs/
+}
+
+src_compile() {
+ tc-export CC
+ $(get_bmake) \
+ KMODDIR=/boot/modules BINDIR=/usr/sbin MANDIR=/usr/share/man/man \
+ MOUNT=${WORKDIR}/sbin/mount \
+ || die "$(get_bmake) failed"
+}
+
+src_install() {
+ dodir /boot/modules
+ $(get_bmake) \
+ KMODDIR=/boot/modules BINDIR=/usr/sbin MANDIR=/usr/share/man/man \
+ DESTDIR=${D} install \
+ || die "$(get_bmake) failed"
+
+ for docdir in ./ ./plaintext_out ./html_chunked_out ./html_aux; do
+ docinto ${docdir}
+ dodoc doc/${docdir}/*
+ done
+}