summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-03-02 13:26:01 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-03-02 13:26:01 +0000
commit5e81bb1879b4bf2946bbca86111d48253ad17cc2 (patch)
tree358da41a14900cf7f18a74cc58f0bd09354b8203 /sys-fs/fuse
parentAllways install Settings .desktop for enviroments following f.d.o menu spec, ... (diff)
downloadgentoo-2-5e81bb1879b4bf2946bbca86111d48253ad17cc2.tar.gz
gentoo-2-5e81bb1879b4bf2946bbca86111d48253ad17cc2.tar.bz2
gentoo-2-5e81bb1879b4bf2946bbca86111d48253ad17cc2.zip
Add fuse.init for Gentoo/FreeBSD
(Portage version: 2.1.2-r11)
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/ChangeLog6
-rw-r--r--sys-fs/fuse/files/fuse-fbsd.init23
-rw-r--r--sys-fs/fuse/files/fuse.init4
-rw-r--r--sys-fs/fuse/fuse-2.6.3.ebuild8
4 files changed, 32 insertions, 9 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 0adf9ab7e0dd..695b20dd4527 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.78 2007/02/26 17:17:01 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.79 2007/03/02 13:26:01 drizzt Exp $
+
+ 02 Mar 2007; Timothy Redaelli <drizzt@gentoo.org> files/fuse.init,
+ +files/fuse-fbsd.init, fuse-2.6.3.ebuild:
+ Add fuse.init for Gentoo/FreeBSD
26 Feb 2007; Daniel Gryniewicz <dang@gentoo.org> fuse-2.6.1.ebuild:
Marked stable on amd64 for bug #150978
diff --git a/sys-fs/fuse/files/fuse-fbsd.init b/sys-fs/fuse/files/fuse-fbsd.init
new file mode 100644
index 000000000000..19b8400eb51d
--- /dev/null
+++ b/sys-fs/fuse/files/fuse-fbsd.init
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need localmount
+}
+
+start() {
+ ebegin "Starting fuse"
+ if ! kldstat -q -m fuse; then
+ kldload fuse >/dev/null 2>&1 || eerror $? "Error loading fuse module"
+ fi
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping fuse"
+ if kldstat -q -m fuse; then
+ kldunload fuse >/dev/null 2>&1 || eerror $? "Error unloading fuse module"
+ fi
+ eend ${?}
+}
diff --git a/sys-fs/fuse/files/fuse.init b/sys-fs/fuse/files/fuse.init
index 8cdc630c1f56..fefb6ae2295b 100644
--- a/sys-fs/fuse/files/fuse.init
+++ b/sys-fs/fuse/files/fuse.init
@@ -36,7 +36,3 @@ stop() {
eend ${?}
}
-
-
-
-
diff --git a/sys-fs/fuse/fuse-2.6.3.ebuild b/sys-fs/fuse/fuse-2.6.3.ebuild
index bd62b1b4896e..beed20a2f567 100644
--- a/sys-fs/fuse/fuse-2.6.3.ebuild
+++ b/sys-fs/fuse/fuse-2.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.3.ebuild,v 1.2 2007/02/23 12:28:43 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.3.ebuild,v 1.3 2007/03/02 13:26:01 drizzt Exp $
inherit linux-mod eutils libtool
@@ -26,7 +26,7 @@ pkg_setup() {
older version from viewcvs"
BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
- fusemoduledir=${ROOT}/lib/modules/${KV_FULL/\ }/fs"
+ fusemoduledir=${ROOT}/lib/modules/${KV_FULL/\ }/fs"
BUILD_TARGETS="all"
ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
fi
@@ -64,13 +64,13 @@ src_install() {
if use kernel_linux ; then
linux-mod_src_install
+ newinitd ${FILESDIR}/fuse.init fuse
else
insinto /usr/include/fuse
doins include/fuse_kernel.h
+ newinitd ${FILESDIR}/fuse-fbsd.init fuse
fi
- newinitd ${FILESDIR}/fuse.init fuse
-
rm -rf "${D}/dev"
}