summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2014-01-28 01:13:50 +0000
committerRick Farina <zerochaos@gentoo.org>2014-01-28 01:13:50 +0000
commit7e79633e2324aba0a89d878a7d5004ff00674447 (patch)
tree693c971cca0c87d6171f48c7b81ac5c7db8b06d9 /sys-fs/go-mtpfs
parentVersion bump (diff)
downloadgentoo-2-7e79633e2324aba0a89d878a7d5004ff00674447.tar.gz
gentoo-2-7e79633e2324aba0a89d878a7d5004ff00674447.tar.bz2
gentoo-2-7e79633e2324aba0a89d878a7d5004ff00674447.zip
can't say I'm proud, but this is about as clean as I can get it, and it works
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'sys-fs/go-mtpfs')
-rw-r--r--sys-fs/go-mtpfs/ChangeLog5
-rw-r--r--sys-fs/go-mtpfs/go-mtpfs-9999.ebuild38
2 files changed, 17 insertions, 26 deletions
diff --git a/sys-fs/go-mtpfs/ChangeLog b/sys-fs/go-mtpfs/ChangeLog
index 78c00f34040a..c87fdeea0265 100644
--- a/sys-fs/go-mtpfs/ChangeLog
+++ b/sys-fs/go-mtpfs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/go-mtpfs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/go-mtpfs/ChangeLog,v 1.4 2014/01/23 17:16:38 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/go-mtpfs/ChangeLog,v 1.5 2014/01/28 01:13:50 zerochaos Exp $
+
+ 28 Jan 2014; Rick Farina <zerochaos@gentoo.org> go-mtpfs-9999.ebuild:
+ can't say I'm proud, but this is about as clean as I can get it, and it works
23 Jan 2014; Rick Farina <zerochaos@gentoo.org> go-mtpfs-9999.ebuild:
horrible, horrible update, that happens to build on hardened
diff --git a/sys-fs/go-mtpfs/go-mtpfs-9999.ebuild b/sys-fs/go-mtpfs/go-mtpfs-9999.ebuild
index b4795b075432..e0f57bde7b5c 100644
--- a/sys-fs/go-mtpfs/go-mtpfs-9999.ebuild
+++ b/sys-fs/go-mtpfs/go-mtpfs-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/go-mtpfs/go-mtpfs-9999.ebuild,v 1.4 2014/01/23 17:16:38 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/go-mtpfs/go-mtpfs-9999.ebuild,v 1.5 2014/01/28 01:13:50 zerochaos Exp $
EAPI=5
@@ -16,45 +16,33 @@ KEYWORDS=""
IUSE=""
COMMON_DEPEND="virtual/libusb
- media-libs/libmtp"
+ virtual/udev"
DEPEND="${COMMON_DEPEND}
dev-libs/go-fuse
- dev-lang/go"
+ dev-lang/go
+ media-libs/libmtp"
+
RDEPEND="${COMMON_DEPEND}"
+#Tests require a connected mtp device
+RESTRICT="test"
+
GO_PN="github.com/hanwen/${PN}"
EGIT_CHECKOUT_DIR="${S}/src/${GO_PN}"
+QA_FLAGS_IGNORED=usr/bin/go-mtpfs
export GOPATH="${S}"
-export GOGCCFLAGS="${CFLAGS}"
-
-#pkg_setup() {
-#}
src_compile() {
- #if gcc-specs-pie ; then
- # filter-flags -fPIE
- # append-ldflags -nopie
- #fi
- go build -ldflags '-nopie' -v -x -work ${GO_PN}/fs || die
- go build -ldflags '-nopie' -v -x -work ${GO_PN}/usb || die
- go build -ldflags '-nopie' -v -x -work ${GO_PN}/mtp || die
-#works on hardened up to here
go build -ldflags '-extldflags=-fno-PIC' -v -x -work ${GO_PN} || die
}
src_test() {
-#none of this works on hardened
- go test ${GO_PN}/fs || die
- go test ${GO_PN}/usb || die
- go test ${GO_PN}/mtp || die
+ go test -ldflags '-extldflags=-fno-PIC' ${GO_PN}/fs || die
+ go test -ldflags '-extldflags=-fno-PIC' ${GO_PN}/usb || die
+ go test -ldflags '-extldflags=-fno-PIC' ${GO_PN}/mtp || die
}
src_install() {
-# go install -v -x -work ${GO_PN}/fs || die
-# go install -v -x -work ${GO_PN}/usb || die
-# go install -v -x -work ${GO_PN}/mtp || die
- go install -ldflags '-extldflags=-fno-PIC' -v -x -work ${GO_PN} || die
+ dobin go-mtpfs
}
-
-#please don't remove commented lines till it works in hardened