summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-06-20 23:57:19 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-06-20 23:57:19 +0000
commit6052baf4ea939c49c72f7ac6b99842bb59100dad (patch)
tree89cf6acf44ecb2a7fe0c51b14bfcaf54507f20d8 /sys-fs/multipath-tools
parentremove unused versions (diff)
downloadgentoo-2-6052baf4ea939c49c72f7ac6b99842bb59100dad.tar.gz
gentoo-2-6052baf4ea939c49c72f7ac6b99842bb59100dad.tar.bz2
gentoo-2-6052baf4ea939c49c72f7ac6b99842bb59100dad.zip
Make multipath-tools work for early boot environments for both baselayout1 and baselayout2. Please read the postinst output if multipath is critical to your environment!
(Portage version: 2.2_pre8/cvs/Linux 2.6.26-rc4-00103-g1beee8d x86_64)
Diffstat (limited to 'sys-fs/multipath-tools')
-rw-r--r--sys-fs/multipath-tools/ChangeLog12
-rw-r--r--sys-fs/multipath-tools/files/init.d-multipath29
-rw-r--r--sys-fs/multipath-tools/files/multipath-start.sh28
-rwxr-xr-xsys-fs/multipath-tools/files/multipath-stop.sh21
-rw-r--r--sys-fs/multipath-tools/files/multipath-tools-0.4.8-build.patch243
-rw-r--r--sys-fs/multipath-tools/multipath-tools-0.4.8.ebuild71
6 files changed, 403 insertions, 1 deletions
diff --git a/sys-fs/multipath-tools/ChangeLog b/sys-fs/multipath-tools/ChangeLog
index 05bdffcda465..ae448b770ed5 100644
--- a/sys-fs/multipath-tools/ChangeLog
+++ b/sys-fs/multipath-tools/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-fs/multipath-tools
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/ChangeLog,v 1.16 2008/02/02 06:09:46 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/ChangeLog,v 1.17 2008/06/20 23:57:18 robbat2 Exp $
+
+*multipath-tools-0.4.8 (20 Jun 2008)
+
+ 20 Jun 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/multipath-tools-0.4.8-build.patch, +files/init.d-multipath,
+ +files/multipath-start.sh, +files/multipath-stop.sh,
+ +multipath-tools-0.4.8.ebuild:
+ Make multipath-tools work for early boot environments for both baselayout1
+ and baselayout2. Please read the postinst output if multipath is critical
+ to your environment!
02 Feb 2008; Christian Faulhammer <opfer@gentoo.org>
multipath-tools-0.4.7-r2.ebuild:
diff --git a/sys-fs/multipath-tools/files/init.d-multipath b/sys-fs/multipath-tools/files/init.d-multipath
new file mode 100644
index 000000000000..68e5a2e7a98d
--- /dev/null
+++ b/sys-fs/multipath-tools/files/init.d-multipath
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/files/init.d-multipath,v 1.1 2008/06/20 23:57:19 robbat2 Exp $
+
+depend() {
+ if [ -e /lib/librc.so ]; then
+ # on baselayout-1 this causes
+ # dependency-cycles with checkroot (before *)
+ before checkfs fsck multipathd lvm
+ after modules
+ fi
+}
+
+start() {
+ if [ ! -e /lib/librc.so ]; then
+ eerror "The $SVCNAME init-script is written for baselayout-2!"
+ eerror "Please do not use it with baselayout-1!".
+ return 1
+ fi
+
+ start_addon multipath
+}
+
+stop() {
+ stop_addon multipath
+}
+
+# vim:ts=4
diff --git a/sys-fs/multipath-tools/files/multipath-start.sh b/sys-fs/multipath-tools/files/multipath-start.sh
new file mode 100644
index 000000000000..b31e4902487e
--- /dev/null
+++ b/sys-fs/multipath-tools/files/multipath-start.sh
@@ -0,0 +1,28 @@
+# /lib/rcscripts/addons/multipath-start.sh: Setup multipath devices at boot
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/files/multipath-start.sh,v 1.1 2008/06/20 23:57:19 robbat2 Exp $
+
+dm_in_proc() {
+ local retval=0
+ for x in devices misc ; do
+ grep -qs 'device-mapper' /proc/${x}
+ retval=$((${retval} + $?))
+ done
+ return ${retval}
+}
+
+# NOTE: Add needed modules for RAID, Multipath etc
+# to /etc/modules.autoload if needed
+if [ -z "${CDBOOT}" -a -x /sbin/multipath ] ; then
+ if [ -e /proc/modules ] && ! dm_in_proc ; then
+ modprobe dm-mod 2>/dev/null
+ fi
+
+ if dm_in_proc ; then
+ ebegin "Activating Multipath devices"
+ /sbin/multipath -v0 >/dev/null
+ retval=$?
+ eend ${retval} "Failed to activate multipath devices"
+ fi
+fi
+
+# vim:ts=4
diff --git a/sys-fs/multipath-tools/files/multipath-stop.sh b/sys-fs/multipath-tools/files/multipath-stop.sh
new file mode 100755
index 000000000000..03a25d991d96
--- /dev/null
+++ b/sys-fs/multipath-tools/files/multipath-stop.sh
@@ -0,0 +1,21 @@
+# /lib/rcscripts/addons/lvm-stop.sh
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/files/multipath-stop.sh,v 1.1 2008/06/20 23:57:19 robbat2 Exp $
+
+dm_in_proc() {
+ local retval=0
+ for x in devices misc ; do
+ grep -qs 'device-mapper' /proc/${x}
+ retval=$((${retval} + $?))
+ done
+ return ${retval}
+}
+
+# Stop LVM2
+if [ -x /sbin/multipath -a dm_in_proc ]; then
+ ebegin "Shutting down Multipath devices"
+ /sbin/multipath -v0 -F >/dev/null
+ retval=$?
+ eend $retval "Failed to shut down Multipath devices"
+fi
+
+# vim:ts=4
diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.4.8-build.patch b/sys-fs/multipath-tools/files/multipath-tools-0.4.8-build.patch
new file mode 100644
index 000000000000..dece81376ab3
--- /dev/null
+++ b/sys-fs/multipath-tools/files/multipath-tools-0.4.8-build.patch
@@ -0,0 +1,243 @@
+diff -Nuar multipath-tools-0.4.8.orig/devmap_name/Makefile multipath-tools-0.4.8/devmap_name/Makefile
+--- multipath-tools-0.4.8.orig/devmap_name/Makefile 2007-08-02 14:05:37.000000000 -0700
++++ multipath-tools-0.4.8/devmap_name/Makefile 2008-06-20 16:20:19.342920167 -0700
+@@ -10,7 +10,7 @@
+ ifeq ($(strip $(BUILD)),klibc)
+ OBJS += $(libdm)
+ else
+- LDFLAGS = -ldevmapper
++ LDFLAGS += -ldevmapper
+ endif
+
+ EXEC = devmap_name
+@@ -32,11 +32,11 @@
+ install -d $(DESTDIR)$(bindir)
+ install -m 755 $(EXEC) $(DESTDIR)$(bindir)/
+ install -d $(DESTDIR)$(mandir)
+- install -m 644 $(EXEC).8.gz $(DESTDIR)$(mandir)
++ install -m 644 $(EXEC).8 $(DESTDIR)$(mandir)
+
+ uninstall:
+- rm $(DESTDIR)$(bindir)/$(EXEC)
+- rm $(DESTDIR)$(mandir)/$(EXEC).8.gz
++ rm -f $(DESTDIR)$(bindir)/$(EXEC)
++ rm -f $(DESTDIR)$(mandir)/$(EXEC).8
+
+ clean:
+ rm -f core *.o $(EXEC) *.gz
+diff -Nuar multipath-tools-0.4.8.orig/kpartx/Makefile multipath-tools-0.4.8/kpartx/Makefile
+--- multipath-tools-0.4.8.orig/kpartx/Makefile 2007-08-02 14:05:37.000000000 -0700
++++ multipath-tools-0.4.8/kpartx/Makefile 2008-06-20 16:30:07.571748249 -0700
+@@ -13,7 +13,7 @@
+ lopart.o xstrncpy.o devmapper.o dasd.o mac.o sun.o \
+ $(MULTIPATHLIB)-$(BUILD).a $(libdm)
+ else
+- LDFLAGS = -ldevmapper
++ LDFLAGS += -ldevmapper
+ OBJS = bsd.o dos.o kpartx.o solaris.o unixware.o dasd.o sun.o \
+ gpt.o mac.o crc32.o lopart.o xstrncpy.o devmapper.o
+ endif
+@@ -44,11 +44,12 @@
+ install -d $(DESTDIR)/etc/udev/rules.d
+- install -m 644 kpartx.rules $(DESTDIR)/etc/udev/rules.d/
++ install -m 644 kpartx.rules $(DESTDIR)/etc/udev/rules.d/66-kpartx.rules
+ install -d $(DESTDIR)$(mandir)
+- install -m 644 $(EXEC).8.gz $(DESTDIR)$(mandir)
++ install -m 644 $(EXEC).8 $(DESTDIR)$(mandir)
+
+ uninstall:
+ rm -f $(DESTDIR)$(bindir)/$(EXEC)
+- rm -f $(DESTDIR)$(mandir)/$(EXEC).8.gz
++ rm -f $(DESTDIR)$(mandir)/$(EXEC).8
++ rm -f $(DESTDIR)/etc/udev/rules.d/66-kpartx.rules
+
+ clean:
+ rm -f core *.o $(EXEC) *.gz
+diff -Nuar multipath-tools-0.4.8.orig/Makefile.inc multipath-tools-0.4.8/Makefile.inc
+--- multipath-tools-0.4.8.orig/Makefile.inc 2007-08-02 14:05:37.000000000 -0700
++++ multipath-tools-0.4.8/Makefile.inc 2008-06-20 16:18:41.008583279 -0700
+@@ -34,10 +34,10 @@
+ CHECKERSLIB = $(checkersdir)/libcheckers
+ MULTIPATHLIB = $(multipathdir)/libmultipath
+
+-INSTALL_PROGRAM = install -s
++INSTALL_PROGRAM = install
+
+-OPTFLAGS = -pipe -g -Wall -Wunused -Wstrict-prototypes
+-CFLAGS = $(OPTFLAGS)
++OPTFLAGS = -Wall -Wunused -Wstrict-prototypes
++CFLAGS += $(OPTFLAGS)
+
+ %.o: %.c
+ $(CC) $(CFLAGS) -c -o $@ $<
+diff -Nuar multipath-tools-0.4.8.orig/multipath/Makefile multipath-tools-0.4.8/multipath/Makefile
+--- multipath-tools-0.4.8.orig/multipath/Makefile 2007-08-02 14:05:37.000000000 -0700
++++ multipath-tools-0.4.8/multipath/Makefile 2008-06-20 16:21:17.572126979 -0700
+@@ -42,17 +42,17 @@
+ install -d $(DESTDIR)$(bindir)
+ $(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)/
+ install -d $(DESTDIR)/etc/udev/rules.d
+- install -m 644 multipath.rules $(DESTDIR)/etc/udev/rules.d/
++ install -m 644 multipath.rules $(DESTDIR)/etc/udev/rules.d/65-multipath.rules
+ install -d $(DESTDIR)$(mandir)
+- install -m 644 $(EXEC).8.gz $(DESTDIR)$(mandir)
++ install -m 644 $(EXEC).8 $(DESTDIR)$(mandir)
+ install -d $(DESTDIR)$(man5dir)
+- install -m 644 $(EXEC).conf.5.gz $(DESTDIR)$(man5dir)
++ install -m 644 $(EXEC).conf.5 $(DESTDIR)$(man5dir)
+
+ uninstall:
+- rm $(DESTDIR)/etc/udev/rules.d/multipath.rules
+- rm $(DESTDIR)$(bindir)/$(EXEC)
+- rm $(DESTDIR)$(mandir)/$(EXEC).8.gz
+- rm $(DESTDIR)$(man5dir)/$(EXEC).conf.5.gz
++ rm -f $(DESTDIR)/etc/udev/rules.d/65-multipath.rules
++ rm -f $(DESTDIR)$(bindir)/$(EXEC)
++ rm -f $(DESTDIR)$(mandir)/$(EXEC).8
++ rm -f $(DESTDIR)$(man5dir)/$(EXEC).conf.5
+
+ clean:
+ rm -f core *.o $(EXEC) *.gz
+diff -Nuar multipath-tools-0.4.8.orig/multipathd/Makefile multipath-tools-0.4.8/multipathd/Makefile
+--- multipath-tools-0.4.8.orig/multipathd/Makefile 2007-08-02 14:05:37.000000000 -0700
++++ multipath-tools-0.4.8/multipathd/Makefile 2008-06-20 16:21:51.421988986 -0700
+@@ -7,7 +7,7 @@
+ # basic flags setting
+ #
+ CFLAGS += -DDAEMON -I$(multipathdir) -I$(checkersdir)
+-LDFLAGS = -lpthread -ldevmapper -lreadline -lncurses -laio
++LDFLAGS += -lpthread -ldevmapper -lreadline -lncurses -laio
+
+ #
+ # debuging stuff
+@@ -48,12 +48,12 @@
+ $(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)
+ install -d $(DESTDIR)$(rcdir)
+ install -d $(DESTDIR)$(mandir)
+- install -m 644 $(EXEC).8.gz $(DESTDIR)$(mandir)
++ install -m 644 $(EXEC).8 $(DESTDIR)$(mandir)
+
+ uninstall:
+ rm -f $(DESTDIR)$(bindir)/$(EXEC)
+ rm -f $(DESTDIR)$(rcdir)/$(EXEC)
+- rm -f $(DESTDIR)$(mandir)/$(EXEC).8.gz
++ rm -f $(DESTDIR)$(mandir)/$(EXEC).8
+
+ clean:
+ $(MAKE) -C $(multipathdir) prepare DAEMON=1
+diff -Nuar multipath-tools-0.4.8.orig/path_priority/pp_alua/Makefile multipath-tools-0.4.8/path_priority/pp_alua/Makefile
+--- multipath-tools-0.4.8.orig/path_priority/pp_alua/Makefile 2007-08-02 14:05:37.000000000 -0700
++++ multipath-tools-0.4.8/path_priority/pp_alua/Makefile 2008-06-20 16:24:53.596722793 -0700
+@@ -35,13 +35,13 @@
+ klibc: $(OBJS)
+ $(CC) -static -o $(EXEC) $(OBJS)
+
+-install: $(EXEC) $(EXEC).8.gz
+- $(INSTALL) -s -m 755 $(EXEC) $(DESTDIR)$(bindir)/$(EXEC)
+- $(INSTALL) -m 644 $(EXEC).8.gz $(DESTDIR)$(mandir)/$(EXEC).8.gz
++install: $(EXEC) $(EXEC).8
++ $(INSTALL) -m 755 $(EXEC) $(DESTDIR)$(bindir)/$(EXEC)
++ $(INSTALL) -m 644 $(EXEC).8 $(DESTDIR)$(mandir)/$(EXEC).8
+
+ uninstall:
+- rm $(DESTDIR)$(bindir)/$(EXEC)
+- rm $(DESTDIR)$(mandir)/$(EXEC).8.gz
++ rm -f $(DESTDIR)$(bindir)/$(EXEC)
++ rm -f $(DESTDIR)$(mandir)/$(EXEC).8
+
+ clean:
+ rm -f *.o *.gz $(EXEC)
+diff -Nuar multipath-tools-0.4.8.orig/path_priority/pp_balance_units/Makefile multipath-tools-0.4.8/path_priority/pp_balance_units/Makefile
+--- multipath-tools-0.4.8.orig/path_priority/pp_balance_units/Makefile 2007-08-02 14:05:37.000000000 -0700
++++ multipath-tools-0.4.8/path_priority/pp_balance_units/Makefile 2008-06-20 16:29:13.181754556 -0700
+@@ -13,7 +13,7 @@
+ OBJS = pp_balance_units.o $(MULTIPATHLIB)-$(BUILD).a
+ else
+ CFLAGS += -I$(multipathdir) -DDEBUG=$(DEBUG)
+- LDFLAGS = -ldevmapper
++ LDFLAGS += -ldevmapper
+ OBJS = pp_balance_units.o $(MULTIPATHLIB)-$(BUILD).a
+ endif
+
+@@ -38,7 +38,7 @@
+ $(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)/
+
+ uninstall:
+- rm $(DESTDIR)$(bindir)/$(EXEC)
++ rm -f $(DESTDIR)$(bindir)/$(EXEC)
+
+ clean:
+ rm -f core *.o $(EXEC) *.gz
+diff -Nuar multipath-tools-0.4.8.orig/path_priority/pp_emc/Makefile multipath-tools-0.4.8/path_priority/pp_emc/Makefile
+--- multipath-tools-0.4.8.orig/path_priority/pp_emc/Makefile 2007-08-02 14:05:37.000000000 -0700
++++ multipath-tools-0.4.8/path_priority/pp_emc/Makefile 2008-06-20 16:28:57.664254512 -0700
+@@ -17,7 +17,8 @@
+ $(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)/$(EXEC)
+
+ uninstall:
+- rm $(DESTDIR)$(bindir)/$(EXEC)
++ rm -f $(DESTDIR)$(bindir)/$(EXEC)
++
+ clean:
+ rm -f *.o $(EXEC)
+
+diff -Nuar multipath-tools-0.4.8.orig/path_priority/pp_hds_modular/Makefile multipath-tools-0.4.8/path_priority/pp_hds_modular/Makefile
+--- multipath-tools-0.4.8.orig/path_priority/pp_hds_modular/Makefile 2007-08-02 14:05:37.000000000 -0700
++++ multipath-tools-0.4.8/path_priority/pp_hds_modular/Makefile 2008-06-20 16:28:52.897167373 -0700
+@@ -17,6 +17,7 @@
+ $(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)/$(EXEC)
+
+ uninstall:
+- rm $(DESTDIR)$(bindir)/$(EXEC)
++ rm -f $(DESTDIR)$(bindir)/$(EXEC)
++
+ clean:
+ rm -f *.o $(EXEC)
+diff -Nuar multipath-tools-0.4.8.orig/path_priority/pp_hp_sw/Makefile multipath-tools-0.4.8/path_priority/pp_hp_sw/Makefile
+--- multipath-tools-0.4.8.orig/path_priority/pp_hp_sw/Makefile 2007-08-02 14:05:37.000000000 -0700
++++ multipath-tools-0.4.8/path_priority/pp_hp_sw/Makefile 2008-06-20 16:28:48.881865361 -0700
+@@ -17,7 +17,7 @@
+ install -m 755 $(EXEC) $(DESTDIR)$(bindir)/$(EXEC)
+
+ uninstall:
+- rm $(DESTDIR)$(bindir)/$(EXEC)
++ rm -f $(DESTDIR)$(bindir)/$(EXEC)
+ clean:
+ rm -f *.o $(EXEC)
+
+diff -Nuar multipath-tools-0.4.8.orig/path_priority/pp_netapp/Makefile multipath-tools-0.4.8/path_priority/pp_netapp/Makefile
+--- multipath-tools-0.4.8.orig/path_priority/pp_netapp/Makefile 2007-08-02 14:05:37.000000000 -0700
++++ multipath-tools-0.4.8/path_priority/pp_netapp/Makefile 2008-06-20 16:28:45.411765821 -0700
+@@ -17,6 +17,7 @@
+ $(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)/$(EXEC)
+
+ uninstall:
+- rm $(DESTDIR)$(bindir)/$(EXEC)
++ rm -f $(DESTDIR)$(bindir)/$(EXEC)
++
+ clean:
+ rm -f *.o $(EXEC)
+diff -Nuar multipath-tools-0.4.8.orig/path_priority/pp_random/Makefile multipath-tools-0.4.8/path_priority/pp_random/Makefile
+--- multipath-tools-0.4.8.orig/path_priority/pp_random/Makefile 2007-08-02 14:05:37.000000000 -0700
++++ multipath-tools-0.4.8/path_priority/pp_random/Makefile 2008-06-20 16:28:37.139873269 -0700
+@@ -17,6 +17,7 @@
+ $(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)/$(EXEC)
+
+ uninstall:
+- rm $(DESTDIR)$(bindir)/$(EXEC)
++ rm -f $(DESTDIR)$(bindir)/$(EXEC)
++
+ clean:
+ rm -f *.o $(EXEC)
+diff -Nuar multipath-tools-0.4.8.orig/path_priority/pp_rdac/Makefile multipath-tools-0.4.8/path_priority/pp_rdac/Makefile
+--- multipath-tools-0.4.8.orig/path_priority/pp_rdac/Makefile 2007-08-02 14:05:37.000000000 -0700
++++ multipath-tools-0.4.8/path_priority/pp_rdac/Makefile 2008-06-20 16:28:32.708817275 -0700
+@@ -17,6 +17,7 @@
+ $(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)/$(EXEC)
+
+ uninstall:
+- rm $(DESTDIR)$(bindir)/$(EXEC)
++ rm -f $(DESTDIR)$(bindir)/$(EXEC)
++
+ clean:
+ rm -f *.o $(EXEC)
diff --git a/sys-fs/multipath-tools/multipath-tools-0.4.8.ebuild b/sys-fs/multipath-tools/multipath-tools-0.4.8.ebuild
new file mode 100644
index 000000000000..d064b13069cd
--- /dev/null
+++ b/sys-fs/multipath-tools/multipath-tools-0.4.8.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/multipath-tools-0.4.8.ebuild,v 1.1 2008/06/20 23:57:18 robbat2 Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Device mapper target autoconfig"
+HOMEPAGE="http://christophe.varoqui.free.fr/"
+SRC_URI="http://christophe.varoqui.free.fr/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-fs/device-mapper-1.00.19-r1
+ sys-fs/udev
+ sys-fs/sysfsutils"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.4.8-build.patch
+ # Merged together
+ #epatch "${FILESDIR}"/${PN}-0.4.7-udev-rules.patch
+}
+
+src_compile() {
+ emake -j1 CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dodir /sbin /usr/share/man/man8
+ make DESTDIR="${D}" install || die "install failed"
+
+ insinto /etc
+ newins "${S}"/multipath.conf.annotated multipath.conf
+ fperms 644 /etc/udev/rules.d/65-multipath.rules
+ fperms 644 /etc/udev/rules.d/66-kpartx.rules
+ # This is the monitoring daemon
+ newinitd "${FILESDIR}"/rc-multipathd multipathd
+ # This is the init script that fires the multipath addon for baselayout2
+ newinitd "${FILESDIR}"/init.d-multipath multipath
+ # Handle early-boot startup as well as shutdown of multipath devices
+ insinto /lib/rcscripts/addons
+ doins "${FILESDIR}"/multipath-start.sh
+ doins "${FILESDIR}"/multipath-stop.sh
+
+ dodoc multipath.conf.*
+ dodoc AUTHOR ChangeLog FAQ README TODO
+ docinto kpartx; dodoc kpartx/ChangeLog kpartx/README
+}
+
+pkg_preinst() {
+ # The dev.d script was previously wrong and is now removed (the udev rules
+ # file does the job instead), but it won't be removed from live systems due
+ # to cfgprotect.
+ # This should help out a little...
+ if [[ -e ${ROOT}/etc/dev.d/block/multipath.dev ]] ; then
+ mkdir -p "${D}"/etc/dev.d/block
+ echo "# Please delete this file. It is obsoleted by /etc/udev/rules.d/65-multipath.rules" \
+ > "${D}"/etc/dev.d/block/multipath.dev
+ fi
+}
+pkg_postinst() {
+ elog "If you need multipath on your system, you should ensure that a"
+ elog "'multipath' entry is present in your RC_VOLUME_ORDER variable!"
+ elog "If you use baselayout2, you must add 'multipath' into"
+ elog "your boot runlevel!"
+}