summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-06-23 16:12:20 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-06-23 16:12:20 +0000
commite69a3c62b6aa0e656b68d22442a354ad7dc7f2ac (patch)
tree1bb9ac433d38f624d1f550829f687a946a4a9abc /sys-fs/ntfs3g
parentFix headers, thanks to x-drum (diff)
downloadgentoo-2-e69a3c62b6aa0e656b68d22442a354ad7dc7f2ac.tar.gz
gentoo-2-e69a3c62b6aa0e656b68d22442a354ad7dc7f2ac.tar.bz2
gentoo-2-e69a3c62b6aa0e656b68d22442a354ad7dc7f2ac.zip
Fix library presence, the previous commit broke it for those using multilib systems (amd64), as econf was passing --libdir=/usr/lib64 on its own.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'sys-fs/ntfs3g')
-rw-r--r--sys-fs/ntfs3g/ChangeLog9
-rw-r--r--sys-fs/ntfs3g/files/digest-ntfs3g-1.616-r13
-rw-r--r--sys-fs/ntfs3g/ntfs3g-1.616-r1.ebuild51
3 files changed, 62 insertions, 1 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index a7466496faf5..68f12ee95b6a 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.35 2007/06/22 19:29:21 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.36 2007/06/23 16:12:20 flameeyes Exp $
+
+*ntfs3g-1.616-r1 (23 Jun 2007)
+
+ 23 Jun 2007; Diego Pettenò <flameeyes@gentoo.org>
+ +ntfs3g-1.616-r1.ebuild:
+ Fix library presence, the previous commit broke it for those using multilib
+ systems (amd64), as econf was passing --libdir=/usr/lib64 on its own.
22 Jun 2007; Patrick McLean <chutzpah@gentoo.org> ntfs3g-1.616.ebuild:
Move *.a and *.la files to /usr (fixes bug #182922).
diff --git a/sys-fs/ntfs3g/files/digest-ntfs3g-1.616-r1 b/sys-fs/ntfs3g/files/digest-ntfs3g-1.616-r1
new file mode 100644
index 000000000000..fb95dda71c3c
--- /dev/null
+++ b/sys-fs/ntfs3g/files/digest-ntfs3g-1.616-r1
@@ -0,0 +1,3 @@
+MD5 fdb1c55f00263c962a52d0707a6d075e ntfs-3g-1.616.tgz 558052
+RMD160 14ef815a496e0ea7494aa46ba843088239d8c74b ntfs-3g-1.616.tgz 558052
+SHA256 b82e615e5b806a46888de116fc90c52b492ba8c8075f5b15830b803f3e35e822 ntfs-3g-1.616.tgz 558052
diff --git a/sys-fs/ntfs3g/ntfs3g-1.616-r1.ebuild b/sys-fs/ntfs3g/ntfs3g-1.616-r1.ebuild
new file mode 100644
index 000000000000..ae989bef2196
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-1.616-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-1.616-r1.ebuild,v 1.1 2007/06/23 16:12:20 flameeyes Exp $
+
+inherit multilib toolchain-funcs
+
+MY_PN="${PN/3g/-3g}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.ntfs-3g.org"
+SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="suid"
+
+RDEPEND=">=sys-fs/fuse-2.6.3"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf --disable-ldconfig --libdir=/$(get_libdir)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodir /usr/$(get_libdir)/
+ mv "${D}"/$(get_libdir)/*.{,l}a "${D}"/usr/$(get_libdir)/
+
+ dodoc AUTHORS ChangeLog CREDITS NEWS README
+
+ gen_usr_ldscript libntfs-3g.so
+
+ use suid && fperms u+s /usr/bin/${MY_PN}
+}
+
+pkg_postinst() {
+ if use suid; then
+ ewarn
+ ewarn "You have chosen to install ${PN} with the binary setuid root. This"
+ ewarn "means that if there any undetected vulnerabilities in the binary,"
+ ewarn "then local users may be able to gain root access on your machine."
+ ewarn
+ fi
+}