summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-03-30 14:41:43 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-03-30 14:41:43 +0000
commit04f9c74ae3a7634a12f2a448e051a58f5d481b74 (patch)
tree21c8d3944cc924237d32cd4760987a538274751e /sys-fs/ntfsprogs
parentAdd src_compile() phase to override the one from java-pkg-2. (diff)
downloadgentoo-2-04f9c74ae3a7634a12f2a448e051a58f5d481b74.tar.gz
gentoo-2-04f9c74ae3a7634a12f2a448e051a58f5d481b74.tar.bz2
gentoo-2-04f9c74ae3a7634a12f2a448e051a58f5d481b74.zip
Revision bump: fix building with net-libs/gnutls[nettle] (bug #361307); avoid playing with configure to remove cflags mangling on USE=debug; only depend on libconfig when USE=crypt is enabled.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/ntfsprogs')
-rw-r--r--sys-fs/ntfsprogs/ChangeLog13
-rw-r--r--sys-fs/ntfsprogs/files/ntfsprogs-2.0.0-cryptolink.patch37
-rw-r--r--sys-fs/ntfsprogs/ntfsprogs-2.0.0-r3.ebuild (renamed from sys-fs/ntfsprogs/ntfsprogs-2.0.0-r2.ebuild)30
3 files changed, 66 insertions, 14 deletions
diff --git a/sys-fs/ntfsprogs/ChangeLog b/sys-fs/ntfsprogs/ChangeLog
index f2217b929fe9..53107eaf7bb2 100644
--- a/sys-fs/ntfsprogs/ChangeLog
+++ b/sys-fs/ntfsprogs/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-fs/ntfsprogs
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ChangeLog,v 1.72 2010/12/13 08:49:59 xmw Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ChangeLog,v 1.73 2011/03/30 14:41:43 flameeyes Exp $
+
+*ntfsprogs-2.0.0-r3 (30 Mar 2011)
+
+ 30 Mar 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ -ntfsprogs-2.0.0-r2.ebuild, +ntfsprogs-2.0.0-r3.ebuild,
+ +files/ntfsprogs-2.0.0-cryptolink.patch:
+ Revision bump: fix building with net-libs/gnutls[nettle] (bug #361307); avoid
+ playing with configure to remove cflags mangling on USE=debug; only depend on
+ libconfig when USE=crypt is enabled.
13 Dec 2010; Michael Weber <xmw@gentoo.org> ntfsprogs-2.0.0-r1.ebuild:
sparc stable (bug 275704)
diff --git a/sys-fs/ntfsprogs/files/ntfsprogs-2.0.0-cryptolink.patch b/sys-fs/ntfsprogs/files/ntfsprogs-2.0.0-cryptolink.patch
new file mode 100644
index 000000000000..c1d773cbc722
--- /dev/null
+++ b/sys-fs/ntfsprogs/files/ntfsprogs-2.0.0-cryptolink.patch
@@ -0,0 +1,37 @@
+Index: ntfsprogs-2.0.0/ntfsprogs/Makefile.am
+===================================================================
+--- ntfsprogs-2.0.0.orig/ntfsprogs/Makefile.am
++++ ntfsprogs-2.0.0/ntfsprogs/Makefile.am
+@@ -124,9 +124,9 @@ ntfsdump_logfile_LDFLAGS= $(AM_LFLAGS)
+
+ if ENABLE_CRYPTO
+ ntfsdecrypt_SOURCES = ntfsdecrypt.c utils.c utils.h
+-ntfsdecrypt_LDADD = $(AM_LIBS)
+-ntfsdecrypt_LDFLAGS = $(AM_LFLAGS) `libgnutls-config --libs`
+-ntfsdecrypt_CFLAGS = `libgnutls-config --cflags`
++ntfsdecrypt_LDADD = $(AM_LIBS) $(GNUTLS_LIBS) $(LIBGCRYPT_LIBS)
++ntfsdecrypt_LDFLAGS = $(AM_LFLAGS)
++ntfsdecrypt_CFLAGS = $(GNUTLS_CFLAGS) $(LIBGCRYPT_CFLAGS)
+ endif
+
+ # Extra targets
+Index: ntfsprogs-2.0.0/libntfs/Makefile.am
+===================================================================
+--- ntfsprogs-2.0.0.orig/libntfs/Makefile.am
++++ ntfsprogs-2.0.0/libntfs/Makefile.am
+@@ -34,12 +34,13 @@ linux_ntfsincludedir = -I$(top_srcdir)/i
+ lib_LTLIBRARIES = libntfs.la
+
+ libntfs_la_LDFLAGS = -version-info $(LTVERSION_LIBNTFS) -no-undefined
++libntfs_la_LIBADD =
+ libntfs_la_CFLAGS = $(LIBNTFS_CFLAGS) \
+ -DLTVERSION_LIBNTFS=\"$(LTVERSION_LIBNTFS)\"
+
+ if ENABLE_CRYPTO
+-libntfs_la_LDFLAGS += `libgnutls-config --libs` `pkg-config --libs libconfig`
+-libntfs_la_CFLAGS += `libgnutls-config --cflags` `pkg-config --cflags libconfig`
++libntfs_la_LIBADD += $(GNUTLS_LIBS) $(LIBGCRYPT_LIBS) $(libconfig_LIBS)
++libntfs_la_CFLAGS += $(GNUTLS_CFLAGS) $(LIBGCRYPT_CFLAGS) $(libconfig_CFLAGS)
+ endif
+
+ libntfs_la_SOURCES = \
diff --git a/sys-fs/ntfsprogs/ntfsprogs-2.0.0-r2.ebuild b/sys-fs/ntfsprogs/ntfsprogs-2.0.0-r3.ebuild
index 9a3a6fc89e1a..f5f50a3fdacc 100644
--- a/sys-fs/ntfsprogs/ntfsprogs-2.0.0-r2.ebuild
+++ b/sys-fs/ntfsprogs/ntfsprogs-2.0.0-r3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ntfsprogs-2.0.0-r2.ebuild,v 1.1 2010/07/24 06:29:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ntfsprogs-2.0.0-r3.ebuild,v 1.1 2011/03/30 14:41:43 flameeyes Exp $
-inherit eutils
+inherit eutils flag-o-matic autotools
DESCRIPTION="User tools for NTFS filesystems"
HOMEPAGE="http://www.linux-ntfs.org/"
@@ -13,9 +13,13 @@ SLOT="0"
KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="crypt debug fuse gnome minimal"
-RDEPEND="dev-libs/libconfig
+RDEPEND="
fuse? ( >=sys-fs/fuse-2.7.0 )
- crypt? ( >=dev-libs/libgcrypt-1.2.0 >=net-libs/gnutls-1.2.8 )
+ crypt? (
+ >=dev-libs/libgcrypt-1.2.0
+ >=net-libs/gnutls-1.2.8
+ >=dev-libs/libconfig-1.0.1
+ )
gnome? (
>=dev-libs/glib-2.0
>=gnome-base/gnome-vfs-2.0
@@ -28,22 +32,24 @@ src_unpack() {
unpack ${A}
cd "${S}"
#epatch "${FILESDIR}"/${P}-extras.patch #218601
- epatch "${FILESDIR}"/${P}-gnutls-2.8.patch
epatch "${FILESDIR}"/${P}-erange.patch #329445
- use minimal || sed -i 's:^EXTRA_PROGRAMS =:bin_PROGRAMS +=:' ntfsprogs/Makefile.in #218601
- sed -i \
- -e '/CFLAGS/s:-ggdb3\>::' \
- -e '/CFLAGS/s:-O0\>::' \
- configure || die
+ epatch "${FILESDIR}"/${P}-cryptolink.patch #361307
+
+ use minimal || sed -i 's:^EXTRA_PROGRAMS.*+\?=:bin_PROGRAMS +=:' ntfsprogs/Makefile.am #218601
+
+ eautoreconf
}
src_compile() {
+ # Avoid --enable-debug as that will set -O0 -ggdb3
+ use debug && append-flags -DDEBUG
+
econf \
$(use_enable crypt crypto) \
- $(use_enable debug) \
$(use_enable fuse ntfsmount) \
$(use_enable gnome gnome-vfs) \
|| die "Configure failed"
+
emake || die "Make failed"
}