summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-04-20 19:34:57 +0000
committerMike Frysinger <vapier@gentoo.org>2008-04-20 19:34:57 +0000
commit7417e6a80392f01cc87acf12766ed082479eaa64 (patch)
tree55cacfc755aace974e65725f8aeef1c6647c01a6 /sys-fs/ntfsprogs
parentRevision bump for genpatches-7. (diff)
downloadgentoo-2-7417e6a80392f01cc87acf12766ed082479eaa64.tar.gz
gentoo-2-7417e6a80392f01cc87acf12766ed082479eaa64.tar.bz2
gentoo-2-7417e6a80392f01cc87acf12766ed082479eaa64.zip
Install the "extra" binaries #218601 by fdupoux.
(Portage version: 2.2_pre5)
Diffstat (limited to 'sys-fs/ntfsprogs')
-rw-r--r--sys-fs/ntfsprogs/ChangeLog8
-rw-r--r--sys-fs/ntfsprogs/files/ntfsprogs-2.0.0-extras.patch38
-rw-r--r--sys-fs/ntfsprogs/ntfsprogs-2.0.0-r1.ebuild58
3 files changed, 103 insertions, 1 deletions
diff --git a/sys-fs/ntfsprogs/ChangeLog b/sys-fs/ntfsprogs/ChangeLog
index f6ec6e3e5da3..b93075316b82 100644
--- a/sys-fs/ntfsprogs/ChangeLog
+++ b/sys-fs/ntfsprogs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/ntfsprogs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ChangeLog,v 1.59 2008/03/31 21:23:51 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ChangeLog,v 1.60 2008/04/20 19:34:57 vapier Exp $
+
+*ntfsprogs-2.0.0-r1 (20 Apr 2008)
+
+ 20 Apr 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/ntfsprogs-2.0.0-extras.patch, +ntfsprogs-2.0.0-r1.ebuild:
+ Install the "extra" binaries #218601 by fdupoux.
31 Mar 2008; Markus Meier <maekke@gentoo.org> ntfsprogs-2.0.0.ebuild:
amd64 stable, bug #208918
diff --git a/sys-fs/ntfsprogs/files/ntfsprogs-2.0.0-extras.patch b/sys-fs/ntfsprogs/files/ntfsprogs-2.0.0-extras.patch
new file mode 100644
index 000000000000..01527607cabc
--- /dev/null
+++ b/sys-fs/ntfsprogs/files/ntfsprogs-2.0.0-extras.patch
@@ -0,0 +1,38 @@
+--- ntfsprogs-2.0.0/configure.ac
++++ ntfsprogs-2.0.0/configure.ac
+@@ -79,6 +79,10 @@
+ ac_configure_args="$ac_configure_args --prefix $prefix"
+ fi
+
++AC_ARG_ENABLE([extras],[AS_HELP_STRING([--enable-extras],[build/install the extra programs])],,enable_extras=no)
++AM_CONDITIONAL(ENABLE_EXTRAS, test "x$enable_extras" = xyes)
++
++
+ # Command-line options.
+ AC_ARG_ENABLE(debug,
+ AS_HELP_STRING(--enable-debug,enable additional debugging code and
+--- ntfsprogs-2.0.0/ntfsprogs/Makefile.am
++++ ntfsprogs-2.0.0/ntfsprogs/Makefile.am
+@@ -14,7 +14,8 @@
+ bin_PROGRAMS = ntfsfix ntfsinfo ntfscluster ntfsls ntfscat ntfscmp
+ sbin_PROGRAMS = mkntfs ntfslabel ntfsundelete ntfsresize ntfsclone \
+ ntfscp
+-EXTRA_PROGRAMS = ntfsdump_logfile ntfswipe ntfstruncate ntfsmove \
++EXTRA_PROGRAMS =
++extra_progs = ntfsdump_logfile ntfswipe ntfstruncate ntfsmove \
+ ntfsmftalloc ntfsck
+
+ man_MANS = mkntfs.8 ntfsfix.8 ntfslabel.8 ntfsinfo.8 \
+@@ -37,6 +38,12 @@
+ EXTRA_PROGRAMS += ntfsdecrypt
+ endif
+
++if ENABLE_EXTRAS
++bin_PROGRAMS += $(extra_progs)
++else
++EXTRA_PROGRAMS += $(extra_progs)
++endif
++
+ # Set the include path.
+ AM_CPPFLAGS = -I$(top_srcdir)/include/ntfs $(all_includes)
+
diff --git a/sys-fs/ntfsprogs/ntfsprogs-2.0.0-r1.ebuild b/sys-fs/ntfsprogs/ntfsprogs-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..665b5f02e67e
--- /dev/null
+++ b/sys-fs/ntfsprogs/ntfsprogs-2.0.0-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ntfsprogs-2.0.0-r1.ebuild,v 1.1 2008/04/20 19:34:57 vapier Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="User tools for NTFS filesystems"
+HOMEPAGE="http://www.linux-ntfs.org/"
+SRC_URI="mirror://sourceforge/linux-ntfs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt debug fuse gnome minimal"
+
+RDEPEND="dev-libs/libconfig
+ fuse? ( >=sys-fs/fuse-2.7.0 )
+ crypt? ( >=dev-libs/libgcrypt-1.2.0 >=net-libs/gnutls-1.2.8 )
+ gnome? (
+ >=dev-libs/glib-2.0
+ >=gnome-base/gnome-vfs-2.0
+ )"
+DEPEND="${RDEPEND}
+ !=sys-fs/ntfs3g-0.1_beta20070714
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-extras.patch #218601
+ eautoreconf
+ sed -i \
+ -e '/CFLAGS/s:-ggdb3\>::' \
+ -e '/CFLAGS/s:-O0\>::' \
+ configure || die
+}
+
+src_compile() {
+ econf \
+ $(use_enable !minimal extras) \
+ $(use_enable crypt crypto) \
+ $(use_enable debug) \
+ $(use_enable fuse fuse-module) \
+ $(use_enable gnome gnome-vfs) \
+ || die "Configure failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ mv "${D}"/sbin/mkfs.ntfs "${D}"/usr/sbin/ || die
+ mv "${D}"/sbin/mount.{fuse.ntfs,ntfs-fuse} "${D}"/usr/bin/ || die
+ mv "${D}"/usr/bin/ntfsck "${D}"/sbin/ || die
+ dosym ntfsck /sbin/fsck.ntfs
+
+ dodoc AUTHORS CREDITS ChangeLog NEWS README TODO.* \
+ doc/attribute_definitions doc/*.txt doc/tunable_settings
+}