summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-06 22:37:43 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-06 22:37:43 +0000
commit506ad089274f4a22fa0b9bc51332093e9e6da07a (patch)
tree84f2cb672487d51d31b67a4f8525230e4131bb46 /sys-fs/quota/quota-4.01.ebuild
parentRemove net-nntp/sabnzbd mask, fix already released and updated in tree. (diff)
downloadgentoo-2-506ad089274f4a22fa0b9bc51332093e9e6da07a.tar.gz
gentoo-2-506ad089274f4a22fa0b9bc51332093e9e6da07a.tar.bz2
gentoo-2-506ad089274f4a22fa0b9bc51332093e9e6da07a.zip
Version bump #450614 by Agostino Sarubbo.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-fs/quota/quota-4.01.ebuild')
-rw-r--r--sys-fs/quota/quota-4.01.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/sys-fs/quota/quota-4.01.ebuild b/sys-fs/quota/quota-4.01.ebuild
new file mode 100644
index 000000000000..621fbc4171e1
--- /dev/null
+++ b/sys-fs/quota/quota-4.01.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-4.01.ebuild,v 1.1 2013/01/06 22:37:43 vapier Exp $
+
+EAPI="4"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Linux quota tools"
+HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
+SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap netlink nls rpc tcpd"
+
+RDEPEND="ldap? ( >=net-nds/openldap-2.3.35 )
+ netlink? (
+ sys-apps/dbus
+ dev-libs/libnl:1.1
+ )
+ rpc? ( net-nds/rpcbind )
+ tcpd? ( sys-apps/tcp-wrappers )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/quota-tools
+
+src_prepare() {
+ sed -i '1iCC = @CC@' Makefile.in || die #446277
+ epatch "${FILESDIR}"/${PN}-4.01-mnt.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable ldap ldapmail) \
+ $(use_enable netlink) \
+ $(use_enable rpc) \
+ $(use_enable rpc rpcsetquota)
+}
+
+src_install() {
+ emake STRIP="" ROOTDIR="${D}" install
+ dodoc doc/* README.* Changelog
+ rm -r "${D}"/usr/include || die #70938
+
+ insinto /etc
+ insopts -m0644
+ doins warnquota.conf quotatab
+
+ newinitd "${FILESDIR}"/quota.rc7 quota
+ newconfd "${FILESDIR}"/quota.confd quota
+
+ if use rpc ; then
+ newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
+ else
+ rm -f "${D}"/usr/sbin/rpc.rquotad
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ insopts -m0644
+ doins ldap-scripts/quota.schema
+
+ exeinto /usr/share/quota/ldap-scripts
+ doexe ldap-scripts/*.pl
+ doexe ldap-scripts/edquota_editor
+ fi
+}