summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-01-21 20:41:00 +0000
committerMike Gilbert <floppym@gentoo.org>2013-01-21 20:41:00 +0000
commit4fee083bad213279395ea24315d6bff94f7657e1 (patch)
tree1c8bb6b09391d72251f680405b31a4b05e4cedfe /sys-fs/udev
parentVersion bump, now uses the new gtk-3.6 bookmark file location. (diff)
downloadgentoo-2-4fee083bad213279395ea24315d6bff94f7657e1.tar.gz
gentoo-2-4fee083bad213279395ea24315d6bff94f7657e1.tar.bz2
gentoo-2-4fee083bad213279395ea24315d6bff94f7657e1.zip
Another tweak for the fstab check.
(Portage version: 2.2.0_alpha155/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-fs/udev')
-rw-r--r--sys-fs/udev/ChangeLog6
-rw-r--r--sys-fs/udev/udev-197-r3.ebuild16
-rw-r--r--sys-fs/udev/udev-197-r4.ebuild16
-rw-r--r--sys-fs/udev/udev-9999.ebuild16
4 files changed, 32 insertions, 22 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index e07ef25c5863..b1b9c83b2a4d 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.795 2013/01/21 20:20:19 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.796 2013/01/21 20:41:00 floppym Exp $
+
+ 21 Jan 2013; Mike Gilbert <floppym@gentoo.org> udev-197-r3.ebuild,
+ udev-197-r4.ebuild, udev-9999.ebuild:
+ Another tweak for the fstab check.
21 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> udev-197-r3.ebuild,
udev-197-r4.ebuild, udev-9999.ebuild:
diff --git a/sys-fs/udev/udev-197-r3.ebuild b/sys-fs/udev/udev-197-r3.ebuild
index 878bc60dfb23..d4b2e9061bfe 100644
--- a/sys-fs/udev/udev-197-r3.ebuild
+++ b/sys-fs/udev/udev-197-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-197-r3.ebuild,v 1.23 2013/01/21 20:21:28 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-197-r3.ebuild,v 1.24 2013/01/21 20:41:00 floppym Exp $
EAPI=4
@@ -449,12 +449,14 @@ pkg_postinst()
ewarn "information on this feature."
fi
- local fstab="${ROOT}"etc/fstab
- if grep -qs "\/dev" "${fstab}" && ! grep -qs devtmpfs "${fstab}"; then
- ewarn "You need to edit your /dev line in ${fstab} to have devtmpfs"
- ewarn "filesystem. Otherwise udev won't be able to boot."
- ewarn "See, http://bugs.gentoo.org/453186"
- fi
+ local fstab="${ROOT}"etc/fstab dev path fstype rest
+ while read -r dev path fstype rest; do
+ if [[ ${path} == /dev && ${fstype} != devtmpfs ]]; then
+ ewarn "You need to edit your /dev line in ${fstab} to have devtmpfs"
+ ewarn "filesystem. Otherwise udev won't be able to boot."
+ ewarn "See, http://bugs.gentoo.org/453186"
+ fi
+ done < "${fstab}"
if [[ -d ${ROOT}usr/lib/udev ]]
then
diff --git a/sys-fs/udev/udev-197-r4.ebuild b/sys-fs/udev/udev-197-r4.ebuild
index ce399d95d746..2bfd3dd1558b 100644
--- a/sys-fs/udev/udev-197-r4.ebuild
+++ b/sys-fs/udev/udev-197-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-197-r4.ebuild,v 1.12 2013/01/21 20:21:28 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-197-r4.ebuild,v 1.13 2013/01/21 20:41:00 floppym Exp $
EAPI=4
@@ -456,12 +456,14 @@ pkg_postinst()
ewarn "information on this feature."
fi
- local fstab="${ROOT}"etc/fstab
- if grep -qs "\/dev" "${fstab}" && ! grep -qs devtmpfs "${fstab}"; then
- ewarn "You need to edit your /dev line in ${fstab} to have devtmpfs"
- ewarn "filesystem. Otherwise udev won't be able to boot."
- ewarn "See, http://bugs.gentoo.org/453186"
- fi
+ local fstab="${ROOT}"etc/fstab dev path fstype rest
+ while read -r dev path fstype rest; do
+ if [[ ${path} == /dev && ${fstype} != devtmpfs ]]; then
+ ewarn "You need to edit your /dev line in ${fstab} to have devtmpfs"
+ ewarn "filesystem. Otherwise udev won't be able to boot."
+ ewarn "See, http://bugs.gentoo.org/453186"
+ fi
+ done < "${fstab}"
if [[ -d ${ROOT}usr/lib/udev ]]
then
diff --git a/sys-fs/udev/udev-9999.ebuild b/sys-fs/udev/udev-9999.ebuild
index 05b29d602cc3..0e99e6f7cbbb 100644
--- a/sys-fs/udev/udev-9999.ebuild
+++ b/sys-fs/udev/udev-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.154 2013/01/21 20:21:28 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.155 2013/01/21 20:41:00 floppym Exp $
EAPI=4
@@ -456,12 +456,14 @@ pkg_postinst()
ewarn "information on this feature."
fi
- local fstab="${ROOT}"etc/fstab
- if grep -qs "\/dev" "${fstab}" && ! grep -qs devtmpfs "${fstab}"; then
- ewarn "You need to edit your /dev line in ${fstab} to have devtmpfs"
- ewarn "filesystem. Otherwise udev won't be able to boot."
- ewarn "See, http://bugs.gentoo.org/453186"
- fi
+ local fstab="${ROOT}"etc/fstab dev path fstype rest
+ while read -r dev path fstype rest; do
+ if [[ ${path} == /dev && ${fstype} != devtmpfs ]]; then
+ ewarn "You need to edit your /dev line in ${fstab} to have devtmpfs"
+ ewarn "filesystem. Otherwise udev won't be able to boot."
+ ewarn "See, http://bugs.gentoo.org/453186"
+ fi
+ done < "${fstab}"
if [[ -d ${ROOT}usr/lib/udev ]]
then