summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Andreetta <satya@gentoo.org>2005-05-18 10:53:22 +0000
committerChristian Andreetta <satya@gentoo.org>2005-05-18 10:53:22 +0000
commit58fb3ed7a4c97980b30c4f57fa0ce5a658a12b5d (patch)
tree2f09699fe052229d8802e0ca69eaee765df01959 /sys-fs/unionfs
parentold ebuilds cleanup (diff)
downloadgentoo-2-58fb3ed7a4c97980b30c4f57fa0ce5a658a12b5d.tar.gz
gentoo-2-58fb3ed7a4c97980b30c4f57fa0ce5a658a12b5d.tar.bz2
gentoo-2-58fb3ed7a4c97980b30c4f57fa0ce5a658a12b5d.zip
version bump
Diffstat (limited to 'sys-fs/unionfs')
-rw-r--r--sys-fs/unionfs/ChangeLog8
-rw-r--r--sys-fs/unionfs/Manifest3
-rw-r--r--sys-fs/unionfs/files/digest-unionfs-1.0.12a1
-rw-r--r--sys-fs/unionfs/files/unionfs-1.0.12a-amd64.patch20
-rw-r--r--sys-fs/unionfs/unionfs-1.0.12a.ebuild49
5 files changed, 80 insertions, 1 deletions
diff --git a/sys-fs/unionfs/ChangeLog b/sys-fs/unionfs/ChangeLog
index 0db4ad64fb04..305da90cb6bd 100644
--- a/sys-fs/unionfs/ChangeLog
+++ b/sys-fs/unionfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/unionfs
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/ChangeLog,v 1.12 2005/05/18 10:49:18 satya Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/ChangeLog,v 1.13 2005/05/18 10:53:22 satya Exp $
+
+*unionfs-1.0.12a (18 May 2005)
+
+ 18 May 2005; Christian Andreetta <satya@gentoo.org>
+ +files/unionfs-1.0.12a-amd64.patch, +unionfs-1.0.12a.ebuild:
+ version bump
18 May 2005; Christian Andreetta <satya@gentoo.org>
-files/unionfs-1.0.8-vserver.patch,
diff --git a/sys-fs/unionfs/Manifest b/sys-fs/unionfs/Manifest
index 3bf2a8e2dd15..bbe2d15993fe 100644
--- a/sys-fs/unionfs/Manifest
+++ b/sys-fs/unionfs/Manifest
@@ -1,5 +1,8 @@
+MD5 e003d219d266e3505eacd54b0be7c68e unionfs-1.0.12a.ebuild 1347
MD5 376c326368cd6cadf7e6b0ded8e03eb8 unionfs-1.0.11.ebuild 1341
MD5 0f9b91f526a87ce7cd1ac14f6802df91 ChangeLog 2364
MD5 6e89ba8198764bfd079a0cfa18dca593 metadata.xml 264
+MD5 f9a155123bfab53c81cb6c454492b797 files/unionfs-1.0.12a-amd64.patch 586
+MD5 a437f2bf3da231ea3a2a2835949d3a37 files/digest-unionfs-1.0.12a 67
MD5 2410ef6f38ddf9737cbb13bfe0325c9a files/digest-unionfs-1.0.11 66
MD5 f9a155123bfab53c81cb6c454492b797 files/unionfs-1.0.11-amd64.patch 586
diff --git a/sys-fs/unionfs/files/digest-unionfs-1.0.12a b/sys-fs/unionfs/files/digest-unionfs-1.0.12a
new file mode 100644
index 000000000000..9d16d7e5e89d
--- /dev/null
+++ b/sys-fs/unionfs/files/digest-unionfs-1.0.12a
@@ -0,0 +1 @@
+MD5 6d7f0b7e111d40cd8799510c6a9eca92 unionfs-1.0.12a.tar.gz 120853
diff --git a/sys-fs/unionfs/files/unionfs-1.0.12a-amd64.patch b/sys-fs/unionfs/files/unionfs-1.0.12a-amd64.patch
new file mode 100644
index 000000000000..ae1564d546ca
--- /dev/null
+++ b/sys-fs/unionfs/files/unionfs-1.0.12a-amd64.patch
@@ -0,0 +1,20 @@
+--- unionfs-1.0.11/file.c 2005-03-24 03:25:47.000000000 +0000
++++ unionfs-1.0.11_malc/file.c 2005-03-26 21:32:16.000000000 +0000
+@@ -22,6 +22,7 @@
+ #include "fist.h"
+ #include "unionfs.h"
+ #include <linux/dcache.h>
++#include <linux/compat.h>
+
+ /*******************
+ * File Operations *
+--- unionfs-1.0.11/locks.c 2005-03-24 03:25:47.000000000 +0000
++++ unionfs-1.0.11_malc/locks.c 2005-03-26 21:33:10.000000000 +0000
+@@ -22,6 +22,7 @@
+ #endif /* HAVE_CONFIG_H */
+ #include "fist.h"
+ #include "unionfs.h"
++#include <linux/compat.h>
+
+
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
diff --git a/sys-fs/unionfs/unionfs-1.0.12a.ebuild b/sys-fs/unionfs/unionfs-1.0.12a.ebuild
new file mode 100644
index 000000000000..d82722deece1
--- /dev/null
+++ b/sys-fs/unionfs/unionfs-1.0.12a.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.0.12a.ebuild,v 1.1 2005/05/18 10:53:22 satya Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="Stackable unification file system, which can appear to merge the contents of several directories"
+HOMEPAGE="http://www.fsl.cs.sunysb.edu/project-unionfs.html"
+SRC_URI="ftp://ftp.fsl.cs.sunysb.edu/pub/unionfs/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+#IUSE="acl debug" # 2005-03-20: satya: acl has issues that will be fixed upstream
+IUSE="acl debug"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ MODULE_NAMES="unionfs(fs:)"
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="LINUXSRC=${KV_DIR} KERNELVERSION=${KV_MAJOR}.${KV_MINOR}"
+}
+
+src_unpack() {
+ local user_Makefile=fistdev.mk EXTRACFLAGS=""
+
+ unpack ${A}
+ cd ${S}
+
+ useq amd64 && epatch ${FILESDIR}/${P}-amd64.patch
+
+ if ! useq debug; then
+ echo "UNIONFS_DEBUG_CFLAG=" >> ${user_Makefile}
+ EXTRACFLAGS="${EXTRACFLAGS} -DNODEBUG"
+ fi
+
+ useq acl && EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_XATTR" # -DFIST_SETXATTR_CONSTVOID"
+
+ echo "EXTRACFLAGS=${EXTRACFLAGS}" >> ${user_Makefile}
+}
+
+src_install() {
+ dosbin unionctl uniondbg
+ doman man/unionfs.4 man/unionctl.8 man/uniondbg.8
+
+ linux-mod_src_install
+
+ dodoc INSTALL NEWS README ChangeLog
+}
+