summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-01-27 23:05:16 +0000
committerMike Gilbert <floppym@gentoo.org>2012-01-27 23:05:16 +0000
commit0330a37d7d8b63cffb42ba95fed21b1c8b699496 (patch)
treef39a67556308aa64ce1e71a81a924f69a134164a /sys-fs
parentNew snapshot from http://libjpeg-turbo.svn.sourceforge.net/viewvc/libjpeg-tur... (diff)
downloadgentoo-2-0330a37d7d8b63cffb42ba95fed21b1c8b699496.tar.gz
gentoo-2-0330a37d7d8b63cffb42ba95fed21b1c8b699496.tar.bz2
gentoo-2-0330a37d7d8b63cffb42ba95fed21b1c8b699496.zip
Call default phase functions from src_compile and src_install. Drop init script; upstream already ships one.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/zfs/ChangeLog7
-rw-r--r--sys-fs/zfs/files/zfs.initd98
-rw-r--r--sys-fs/zfs/zfs-9999.ebuild6
3 files changed, 9 insertions, 102 deletions
diff --git a/sys-fs/zfs/ChangeLog b/sys-fs/zfs/ChangeLog
index f8ffea886ffb..e4beab980700 100644
--- a/sys-fs/zfs/ChangeLog
+++ b/sys-fs/zfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/zfs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/ChangeLog,v 1.1 2012/01/27 17:06:14 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/ChangeLog,v 1.2 2012/01/27 23:05:16 floppym Exp $
+
+ 27 Jan 2012; Mike Gilbert <floppym@gentoo.org> -files/zfs.initd,
+ zfs-9999.ebuild:
+ Call default phase functions from src_compile and src_install. Drop init
+ script; upstream already ships one.
*zfs-9999 (27 Jan 2012)
diff --git a/sys-fs/zfs/files/zfs.initd b/sys-fs/zfs/files/zfs.initd
deleted file mode 100644
index 4694108900aa..000000000000
--- a/sys-fs/zfs/files/zfs.initd
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/files/zfs.initd,v 1.1 2012/01/27 17:06:14 floppym Exp $
-
-depend()
-{
- before net
- after udev
- keyword -lxc -openvz -prefix -vserver
-}
-
-CACHEFILE=/etc/zfs/zpool.cache
-ZPOOL=/usr/sbin/zpool
-ZFS=/usr/sbin/zfs
-ZFS_MODULE=zfs
-
-checksystem() {
- if [ -c /dev/zfs ]; then
- einfo "ZFS modules already loaded"
- return 0
- else
- einfo "Checking if ZFS modules present"
- if [ "x$(modprobe -l $ZFS_MODULE | grep $ZFS_MODULE)" == "x" ]; then
- eerror "$ZFS_MODULE not found. Is the ZFS package installed?"
- return 1
- fi
- fi
- einfo "Checking if zfs userspace tools present"
- if [ ! -x $ZPOOL ]; then
- eerror "$ZPOOL binary not found."
- return 1
- fi
- if [ ! -x $ZFS ]; then
- eerror "$ZFS binary not found."
- return 1
- fi
- return 0
-}
-
-start() {
- ebegin "Starting ZFS"
- checksystem || return 1
- if [ ! -c /dev/zfs ]; then
- modprobe $ZFS_MODULE
- rv=$?
- if [ $rv -ne 0 ]; then
- eerror "Failed to load the $ZFS_MODULE module, check 'dmesg|tail'."
- eend $rv
- return $rv
- fi
- fi
-
- # Import all pools described by the cache file, and then mount
- # all filesystem based on their properties.
- if [ -f $CACHEFILE ]; then
- einfo "Importing ZFS pools"
- # as per fedora script, import can fail if all pools are already imported
- # The check for $rv makes no sense...but someday, it will work right.
- $ZPOOL import -c $CACHEFILE -aN 2>/dev/null || true
- rv=$?
- if [ $rv -ne 0 ]; then
- eerror "Failed to import not-yet imported pools."
- eend $rv
- return $rv
- fi
- fi
-
- einfo "Mounting ZFS filesystems"
- $ZFS mount -a
- rv=$?
- if [ $rv -ne 0 ]; then
- eerror "Failed to mount ZFS filesystems."
- eend $rv
- return $rv
- fi
-
- eend 0
- return 0
-}
-
-stop()
-{
- ebegin "Unmounting ZFS filesystems"
- $ZFS umount -a
- rv=$?
- if [ $rv -ne 0 ]; then
- eerror "Failed to umount ZFS filesystems."
- fi
-
- eend $rv
-}
-
-status()
-{
- # show pool status and list
- $ZPOOL status && echo && $ZPOOL list
-}
diff --git a/sys-fs/zfs/zfs-9999.ebuild b/sys-fs/zfs/zfs-9999.ebuild
index c6c41bdab46c..9b1babb01ef3 100644
--- a/sys-fs/zfs/zfs-9999.ebuild
+++ b/sys-fs/zfs/zfs-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-9999.ebuild,v 1.1 2012/01/27 17:06:14 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-9999.ebuild,v 1.2 2012/01/27 23:05:16 floppym Exp $
EAPI="4"
@@ -40,9 +40,9 @@ src_configure() {
}
src_compile() {
- emake
+ default
}
src_install() {
- emake DESTDIR="${D}" install
+ default
}