summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-10-02 06:28:41 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-10-02 06:28:41 +0000
commit48b0b71b42037462f59e6aeeacfc8d87f6ab622f (patch)
tree5855cad192536039432601f13f605dbc1306ba2c /sys-fs
parentFix dependencies for modular Xorg, thanks to James Rowe in bug #146586. (diff)
downloadgentoo-2-48b0b71b42037462f59e6aeeacfc8d87f6ab622f.tar.gz
gentoo-2-48b0b71b42037462f59e6aeeacfc8d87f6ab622f.tar.bz2
gentoo-2-48b0b71b42037462f59e6aeeacfc8d87f6ab622f.zip
version bump
(Portage version: 2.1.2_pre2)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/ChangeLog7
-rw-r--r--sys-fs/fuse/files/digest-fuse-2.6.0_rc23
-rw-r--r--sys-fs/fuse/fuse-2.6.0_rc2.ebuild68
3 files changed, 77 insertions, 1 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 3c5cdbac448c..52478cb36c08 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.60 2006/09/29 23:46:32 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.61 2006/10/02 06:28:41 genstef Exp $
+
+*fuse-2.6.0_rc2 (02 Oct 2006)
+
+ 02 Oct 2006; Stefan Schweizer <genstef@gentoo.org> +fuse-2.6.0_rc2.ebuild:
+ version bump
29 Sep 2006; <ticho@gentoo.org> fuse-2.6.0_rc1.ebuild:
Stable on x86, bug #148506.
diff --git a/sys-fs/fuse/files/digest-fuse-2.6.0_rc2 b/sys-fs/fuse/files/digest-fuse-2.6.0_rc2
new file mode 100644
index 000000000000..c3f0e075bf2b
--- /dev/null
+++ b/sys-fs/fuse/files/digest-fuse-2.6.0_rc2
@@ -0,0 +1,3 @@
+MD5 4fa1138c955b9dba32fbf180db5a532a fuse-2.6.0-rc2.tar.gz 459273
+RMD160 fc2b0978d6a1a2697dbc4ed9ba8d1b94194b5049 fuse-2.6.0-rc2.tar.gz 459273
+SHA256 2a5ecfb6c1fd408de205644e1546e2055d5fa7a1cfa4bc6a77eaf35171da37a8 fuse-2.6.0-rc2.tar.gz 459273
diff --git a/sys-fs/fuse/fuse-2.6.0_rc2.ebuild b/sys-fs/fuse/fuse-2.6.0_rc2.ebuild
new file mode 100644
index 000000000000..642e7551da0b
--- /dev/null
+++ b/sys-fs/fuse/fuse-2.6.0_rc2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.0_rc2.ebuild,v 1.1 2006/10/02 06:28:41 genstef Exp $
+
+inherit linux-mod eutils libtool
+
+MY_P=${P/_/-}
+DESCRIPTION="An interface for filesystems implemented in userspace."
+HOMEPAGE="http://fuse.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kernel_linux kernel_FreeBSD"
+S=${WORKDIR}/${MY_P}
+PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
+
+MODULE_NAMES="fuse(fs:${S}/kernel)"
+CONFIG_CHECK="@FUSE_FS:fuse"
+BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
+ fusemoduledir=${ROOT}/lib/modules/${KV_FULL}/fs"
+BUILD_TARGETS="all"
+ECONF_PARAMS="--with-kernel=${KV_OUT_DIR}"
+FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
+We will continue, but we wont build the module this time."
+
+pkg_setup() {
+ use kernel_linux && linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/fuse-fix-lazy-binding.patch
+ elibtoolize
+}
+
+src_compile() {
+ einfo "Preparing fuse userland"
+ econf --disable-kernel-module --disable-example || \
+ die "econf failed for fuse userland"
+ emake || die "emake failed"
+
+ if use kernel_linux; then
+ sed -i -e 's/.*depmod.*//g' ${S}/kernel/Makefile.in
+ convert_to_m ${S}/kernel/Makefile.in
+ linux-mod_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog Filesystems README README-2.4 \
+ README.NFS NEWS doc/how-fuse-works
+ docinto example
+ dodoc example/*
+
+ if use kernel_linux; then
+ linux-mod_src_install
+ else
+ insinto /usr/include/fuse
+ doins include/fuse_kernel.h
+ fi
+}
+
+pkg_postinst() {
+ use kernel_linux && linux-mod_pkg_postinst
+}