summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-06 04:50:58 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-06 04:50:58 +0000
commit4ba742072d4acac0b9961fa7df6954774c6f34ad (patch)
tree38cd2538a603493b87cad31a690fc3ae4dc0e236 /sys-fs
parentBump to 3.2.1 from the gnome overlay, drop old. Minor fixes. (diff)
downloadgentoo-2-4ba742072d4acac0b9961fa7df6954774c6f34ad.tar.gz
gentoo-2-4ba742072d4acac0b9961fa7df6954774c6f34ad.tar.bz2
gentoo-2-4ba742072d4acac0b9961fa7df6954774c6f34ad.zip
Version bump, and fix fortify overflows #370949 by Diego Elio Pettenò.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xfsdump/ChangeLog8
-rw-r--r--sys-fs/xfsdump/files/xfsdump-3.0.6-path-overflow.patch31
-rw-r--r--sys-fs/xfsdump/xfsdump-3.0.6.ebuild50
3 files changed, 88 insertions, 1 deletions
diff --git a/sys-fs/xfsdump/ChangeLog b/sys-fs/xfsdump/ChangeLog
index 0f8bf9490508..68dd1a28514b 100644
--- a/sys-fs/xfsdump/ChangeLog
+++ b/sys-fs/xfsdump/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/xfsdump
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.79 2011/04/12 17:56:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.80 2011/11/06 04:50:58 vapier Exp $
+
+*xfsdump-3.0.6 (06 Nov 2011)
+
+ 06 Nov 2011; Mike Frysinger <vapier@gentoo.org> +xfsdump-3.0.6.ebuild,
+ +files/xfsdump-3.0.6-path-overflow.patch:
+ Version bump, and fix fortify overflows #370949 by Diego Elio Pettenò.
*xfsdump-3.0.5 (12 Apr 2011)
diff --git a/sys-fs/xfsdump/files/xfsdump-3.0.6-path-overflow.patch b/sys-fs/xfsdump/files/xfsdump-3.0.6-path-overflow.patch
new file mode 100644
index 000000000000..a6d9f6b82233
--- /dev/null
+++ b/sys-fs/xfsdump/files/xfsdump-3.0.6-path-overflow.patch
@@ -0,0 +1,31 @@
+https://bugs.gentoo.org/370949
+
+From 435bad87388821684bb3cd2a33c42787cf970017 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sun, 6 Nov 2011 00:44:57 -0400
+Subject: [PATCH] path: fix 1 byte overflow with empty lists
+
+If pap->pa_cnt is 0, then the local buffer is allocated as 1 byte,
+but the code then writes two bytes to it '/' and '\0'.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ common/path.c | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/common/path.c b/common/path.c
+index 66320de..ca24f6a 100644
+--- a/common/path.c
++++ b/common/path.c
+@@ -285,6 +285,8 @@ pa_gen( pa_t *pap )
+ for ( i = 0 ; i < pap->pa_cnt ; i++ ) {
+ sz += strlen( pap->pa_array[ i ] ) + 1;
+ }
++ if ( i == 0 )
++ sz++;
+ sz++;
+
+ retp = ( char * )malloc( sz );
+--
+1.7.6.1
+
diff --git a/sys-fs/xfsdump/xfsdump-3.0.6.ebuild b/sys-fs/xfsdump/xfsdump-3.0.6.ebuild
new file mode 100644
index 000000000000..7e4315384a90
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-3.0.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-3.0.6.ebuild,v 1.1 2011/11/06 04:50:58 vapier Exp $
+
+EAPI="2"
+
+inherit multilib eutils
+
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
+ ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/e2fsprogs
+ !<sys-fs/xfsprogs-3
+ sys-apps/dmapi
+ >=sys-apps/attr-2.4.19"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die
+ epatch "${FILESDIR}"/${PN}-3.0.5-prompt-overflow.patch #335115
+ epatch "${FILESDIR}"/${PN}-3.0.4-no-symlink.patch #311881
+ epatch "${FILESDIR}"/${PN}-3.0.6-path-overflow.patch #370949
+}
+
+src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --sbindir=/sbin
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install || die
+ prepalldocs
+}