summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-08-28 18:43:35 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-08-28 18:43:35 +0000
commit902717fa4a054e96d9e057158fdc4daa649482da (patch)
tree16acdb842df96dc0de521f14d862b03d8bfb419c /sys-fs
parentfix mistake introduced in 2.4.3-r2 where system zlib was used that caused pro... (diff)
downloadgentoo-2-902717fa4a054e96d9e057158fdc4daa649482da.tar.gz
gentoo-2-902717fa4a054e96d9e057158fdc4daa649482da.tar.bz2
gentoo-2-902717fa4a054e96d9e057158fdc4daa649482da.zip
Version bump. Closing bug #145369.
(Portage version: 2.1.1_rc1-r1)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/squashfs-tools/ChangeLog8
-rw-r--r--sys-fs/squashfs-tools/files/digest-squashfs-tools-3.13
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.1.ebuild35
3 files changed, 45 insertions, 1 deletions
diff --git a/sys-fs/squashfs-tools/ChangeLog b/sys-fs/squashfs-tools/ChangeLog
index e690328e37b3..c7953d2a1635 100644
--- a/sys-fs/squashfs-tools/ChangeLog
+++ b/sys-fs/squashfs-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/squashfs-tools
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.37 2006/08/28 16:44:58 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.38 2006/08/28 18:43:35 wolf31o2 Exp $
+
+*squashfs-tools-3.1 (28 Aug 2006)
+
+ 28 Aug 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +squashfs-tools-3.1.ebuild:
+ Version bump. Closing bug #145369.
28 Aug 2006; Gustavo Zacarias <gustavoz@gentoo.org>
squashfs-tools-3.0.ebuild:
diff --git a/sys-fs/squashfs-tools/files/digest-squashfs-tools-3.1 b/sys-fs/squashfs-tools/files/digest-squashfs-tools-3.1
new file mode 100644
index 000000000000..6e58fff36348
--- /dev/null
+++ b/sys-fs/squashfs-tools/files/digest-squashfs-tools-3.1
@@ -0,0 +1,3 @@
+MD5 60df8e106de8c6310e7aae871d481588 squashfs3.1.tar.gz 477979
+RMD160 9682412acc0a7f841d50a0b7fe42f6ff8f1aef28 squashfs3.1.tar.gz 477979
+SHA256 8233a6f98b63de38500f9d3403d0a4c5b50277c695e29da765043cc3638f6f96 squashfs3.1.tar.gz 477979
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.1.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.1.ebuild
new file mode 100644
index 000000000000..4bb3e133b43a
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.1.ebuild,v 1.1 2006/08/28 18:43:35 wolf31o2 Exp $
+
+inherit toolchain-funcs
+
+MY_PV=${PV/_p/r}
+DESCRIPTION="Tool for creating compressed filesystem type squashfs"
+HOMEPAGE="http://squashfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+
+S=${WORKDIR}/squashfs${PV/_p/-r}/squashfs-tools
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "s:-O2:${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin mksquashfs unsquashfs || die
+ cd ..
+ dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README README-3.1
+}