summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-02-27 05:46:10 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-02-27 05:46:10 +0000
commitba7d6a3656a3a3a0158723777a3a64e795ce052a (patch)
tree5050754f6aed5acabf734cb1421397e761837b2b /sys-fs
parentVersion bump. Removed old (diff)
downloadgentoo-2-ba7d6a3656a3a3a0158723777a3a64e795ce052a.tar.gz
gentoo-2-ba7d6a3656a3a3a0158723777a3a64e795ce052a.tar.bz2
gentoo-2-ba7d6a3656a3a3a0158723777a3a64e795ce052a.zip
Use unpacker.eclass for lzip compressed releases. Removed old. Readded ia64 KEYWORD
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ddrescue/ChangeLog7
-rw-r--r--sys-fs/ddrescue/ddrescue-1.17-r1.ebuild13
-rw-r--r--sys-fs/ddrescue/ddrescue-1.17.ebuild45
3 files changed, 10 insertions, 55 deletions
diff --git a/sys-fs/ddrescue/ChangeLog b/sys-fs/ddrescue/ChangeLog
index 81176434a591..73a5babc17a4 100644
--- a/sys-fs/ddrescue/ChangeLog
+++ b/sys-fs/ddrescue/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/ddrescue
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ChangeLog,v 1.44 2014/01/05 21:22:56 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ChangeLog,v 1.45 2014/02/27 05:46:10 polynomial-c Exp $
+
+ 27 Feb 2014; Lars Wendler <polynomial-c@gentoo.org> -ddrescue-1.17.ebuild,
+ ddrescue-1.17-r1.ebuild:
+ Use unpacker.eclass for lzip compressed releases. Removed old. Readded ia64
+ KEYWORD.
*ddrescue-1.17-r1 (05 Jan 2014)
diff --git a/sys-fs/ddrescue/ddrescue-1.17-r1.ebuild b/sys-fs/ddrescue/ddrescue-1.17-r1.ebuild
index a7def4deec0b..64f02a5938db 100644
--- a/sys-fs/ddrescue/ddrescue-1.17-r1.ebuild
+++ b/sys-fs/ddrescue/ddrescue-1.17-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ddrescue-1.17-r1.ebuild,v 1.1 2014/01/05 21:22:56 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ddrescue-1.17-r1.ebuild,v 1.2 2014/02/27 05:46:10 polynomial-c Exp $
EAPI=5
-inherit toolchain-funcs flag-o-matic
+inherit toolchain-funcs flag-o-matic unpacker
DESCRIPTION="Copy data from one file or block device to another with read-error recovery"
HOMEPAGE="http://www.gnu.org/software/ddrescue/ddrescue.html"
@@ -12,17 +12,12 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86 ~amd64-linux"
IUSE="static"
-DEPEND="app-arch/lzip"
+DEPEND=""
RDEPEND=""
-src_unpack() {
- # Upstream only provides an lzip compressed tarball for this version
- tar --lzip -xf "${DISTDIR}"/${P}.tar.lz || die
-}
-
src_configure() {
use static && append-ldflags -static
diff --git a/sys-fs/ddrescue/ddrescue-1.17.ebuild b/sys-fs/ddrescue/ddrescue-1.17.ebuild
deleted file mode 100644
index 4ef214c5bac3..000000000000
--- a/sys-fs/ddrescue/ddrescue-1.17.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ddrescue-1.17.ebuild,v 1.2 2013/09/19 12:37:47 jlec Exp $
-
-EAPI=5
-
-inherit toolchain-funcs
-
-DESCRIPTION="Copy data from one file or block device to another with read-error recovery"
-HOMEPAGE="http://www.gnu.org/software/ddrescue/ddrescue.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux"
-IUSE=""
-
-DEPEND="app-arch/lzip"
-RDEPEND=""
-
-src_unpack() {
- # Upstream only provides an lzip compressed tarball for this version
- tar --lzip -xf "${DISTDIR}"/${P}.tar.lz || die
-}
-
-src_configure() {
- # not a normal configure script
- econf \
- --prefix="${EPREFIX}"/usr \
- CC="$(tc-getCC)" \
- CXX="$(tc-getCXX)" \
- CPPFLAGS="${CPPFLAGS}" \
- CFLAGS="${CFLAGS}" \
- CXXFLAGS="${CXXFLAGS}" \
- LDFLAGS="${LDFLAGS}"
-}
-
-src_test() {
- ./testsuite/check.sh "${S}"/testsuite || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install install-man
- dodoc ChangeLog README NEWS AUTHORS
-}