summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-07-21 10:28:49 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-07-21 10:28:49 +0000
commitf64a7e8ee7e768fe5b79a7417006d01b07c221a4 (patch)
tree7d1964d07e5d32a39cf1fee86029251a0b9fcef6 /sys-kernel/ck-sources
parentAdded a patch for the CAN-2004-0596 issue; bug #57826. (Manifest recommit) (diff)
downloadgentoo-2-f64a7e8ee7e768fe5b79a7417006d01b07c221a4.tar.gz
gentoo-2-f64a7e8ee7e768fe5b79a7417006d01b07c221a4.tar.bz2
gentoo-2-f64a7e8ee7e768fe5b79a7417006d01b07c221a4.zip
Added a patch for the CAN-2004-0596 issue; bug #57826.
Diffstat (limited to 'sys-kernel/ck-sources')
-rw-r--r--sys-kernel/ck-sources/ChangeLog6
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.7-r5.ebuild4
-rw-r--r--sys-kernel/ck-sources/files/ck-sources-2.6.7.CAN-2004-0596.patch46
3 files changed, 53 insertions, 3 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index c79d7823918d..8233129e844d 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.43 2004/07/09 13:39:01 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.44 2004/07/21 10:28:49 plasmaroo Exp $
+
+ 21 Jul 2004; <plasmaroo@gentoo.org> ck-sources-2.6.7-r5.ebuild,
+ +files/ck-sources-2.6.7.CAN-2004-0596.patch:
+ Added a patch for the CAN-2004-0596 issue; bug #57826.
*ck-sources-2.6.7-r5 (09 Jul 2004)
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.7-r5.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.7-r5.ebuild
index c674b53873cc..6ff23b4e2a19 100644
--- a/sys-kernel/ck-sources/ck-sources-2.6.7-r5.ebuild
+++ b/sys-kernel/ck-sources/ck-sources-2.6.7-r5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.7-r5.ebuild,v 1.1 2004/07/09 13:39:01 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.7-r5.ebuild,v 1.2 2004/07/21 10:28:49 plasmaroo Exp $
-UNIPATCH_LIST="${DISTDIR}/patch-${KV}.bz2"
+UNIPATCH_LIST="${DISTDIR}/patch-${KV}.bz2 ${FILESDIR}/${P}.CAN-2004-0596.patch"
K_PREPATCHED="yes"
UNIPATCH_STRICTORDER="yes"
diff --git a/sys-kernel/ck-sources/files/ck-sources-2.6.7.CAN-2004-0596.patch b/sys-kernel/ck-sources/files/ck-sources-2.6.7.CAN-2004-0596.patch
new file mode 100644
index 000000000000..3e20a2e41372
--- /dev/null
+++ b/sys-kernel/ck-sources/files/ck-sources-2.6.7.CAN-2004-0596.patch
@@ -0,0 +1,46 @@
+--- 1.13/drivers/net/eql.c 2004-07-21 03:13:40 -07:00
++++ 1.14/drivers/net/eql.c 2004-07-21 03:13:40 -07:00
+@@ -495,6 +495,8 @@
+ return -EFAULT;
+
+ slave_dev = dev_get_by_name(sc.slave_name);
++ if (!slave_dev)
++ return -ENODEV;
+
+ ret = -EINVAL;
+
+@@ -527,11 +529,13 @@
+ if (copy_from_user(&sc, scp, sizeof (slave_config_t)))
+ return -EFAULT;
+
+- eql = dev->priv;
+ slave_dev = dev_get_by_name(sc.slave_name);
++ if (!slave_dev)
++ return -ENODEV;
+
+ ret = -EINVAL;
+
++ eql = dev->priv;
+ spin_lock_bh(&eql->queue.lock);
+ if (eql_is_slave(slave_dev)) {
+ slave = __eql_find_slave_dev(&eql->queue, slave_dev);
+--- 1.14/drivers/net/eql.c 2004-07-21 03:13:33 -07:00
++++ 1.15/drivers/net/eql.c 2004-07-21 03:13:33 -07:00
+@@ -499,6 +499,8 @@
+ return -ENODEV;
+
+ ret = -EINVAL;
++ if (!slave_dev)
++ return ret;
+
+ spin_lock_bh(&eql->queue.lock);
+ if (eql_is_slave(slave_dev)) {
+@@ -534,6 +536,8 @@
+ return -ENODEV;
+
+ ret = -EINVAL;
++ if (!slave_dev)
++ return ret;
+
+ eql = dev->priv;
+ spin_lock_bh(&eql->queue.lock);