summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-08-20 21:37:10 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-08-20 21:37:10 +0000
commite4ee3e6f68bbe4d599856a5a5b63e51d89de1307 (patch)
tree8f6e24cec1b11c64b22274b30d6654a5c6a2f9c3 /sys-kernel/dracut
parentStable for x86, wrt bug #422157 (diff)
downloadgentoo-2-e4ee3e6f68bbe4d599856a5a5b63e51d89de1307.tar.gz
gentoo-2-e4ee3e6f68bbe4d599856a5a5b63e51d89de1307.tar.bz2
gentoo-2-e4ee3e6f68bbe4d599856a5a5b63e51d89de1307.zip
Version bump. This version allows to install systemd module which has been
disabled in previous ebuilds. NEWS ~~~~ - resume from hibernate fixes - -N option for --no-hostonly - support for systemd crypto handling - new dracut module "crypt-loop" - deprecate the old kernel command line options - more documentation - multipath fixes - i18n: fixed inclusion of "include" keymaps - root on cifs support - support for xfs / reiserfs separate journal device Following changes has been backported to Gentoo's 022-r5 and are included by upstream in 023: - honor CFLAGS for dracut-install build - / is mounted according to rootflags parameter but forced ro at first. Later it is remounted according to /etc/fstab + rootflags parameter and "ro"/"rw". - new "ro_mnt" option to force ro mount of / and /usr - dracut-install: fixed issue for /var/tmp containing a symlink - only lazy resolve with ldd, if the /var/tmp partition is not mounted with "noexec" (Portage version: 2.1.11.10/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/dracut')
-rw-r--r--sys-kernel/dracut/ChangeLog33
-rw-r--r--sys-kernel/dracut/dracut-023.ebuild270
2 files changed, 302 insertions, 1 deletions
diff --git a/sys-kernel/dracut/ChangeLog b/sys-kernel/dracut/ChangeLog
index 7354b6212421..a48c55880e66 100644
--- a/sys-kernel/dracut/ChangeLog
+++ b/sys-kernel/dracut/ChangeLog
@@ -1,6 +1,37 @@
# ChangeLog for sys-kernel/dracut
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/ChangeLog,v 1.84 2012/08/17 08:53:29 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/ChangeLog,v 1.85 2012/08/20 21:37:10 aidecoe Exp $
+
+*dracut-023 (20 Aug 2012)
+
+ 20 Aug 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> +dracut-023.ebuild:
+ Version bump. This version allows to install systemd module which has been
+ disabled in previous ebuilds.
+
+ NEWS
+ ~~~~
+ - resume from hibernate fixes
+ - -N option for --no-hostonly
+ - support for systemd crypto handling
+ - new dracut module "crypt-loop"
+ - deprecate the old kernel command line options
+ - more documentation
+ - multipath fixes
+ - i18n: fixed inclusion of "include" keymaps
+ - root on cifs support
+ - support for xfs / reiserfs separate journal device
+
+ Following changes has been backported to Gentoo's 022-r5 and are included by
+ upstream in 023:
+
+ - honor CFLAGS for dracut-install build
+ - / is mounted according to rootflags parameter but forced ro at first.
+ Later it is remounted according to /etc/fstab + rootflags parameter
+ and "ro"/"rw".
+ - new "ro_mnt" option to force ro mount of / and /usr
+ - dracut-install: fixed issue for /var/tmp containing a symlink
+ - only lazy resolve with ldd, if the /var/tmp partition is not mounted with
+ "noexec"
17 Aug 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> dracut-022-r5.ebuild:
Move udev to common dependencies, because its configuration is being checked
diff --git a/sys-kernel/dracut/dracut-023.ebuild b/sys-kernel/dracut/dracut-023.ebuild
new file mode 100644
index 000000000000..abc23cb8ac23
--- /dev/null
+++ b/sys-kernel/dracut/dracut-023.ebuild
@@ -0,0 +1,270 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/dracut-023.ebuild,v 1.1 2012/08/20 21:37:10 aidecoe Exp $
+
+EAPI=4
+
+inherit eutils linux-info toolchain-funcs
+
+add_req_use_for() {
+ local dep="$1"; shift
+ local f
+
+ for f in "$@"; do
+ REQUIRED_USE+="${f}? ( ${dep} )
+"
+ done
+}
+
+DESCRIPTION="Generic initramfs generation tool"
+HOMEPAGE="http://dracut.wiki.kernel.org"
+SRC_URI="mirror://kernel/linux/utils/boot/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="dracut_modules_crypt-gpg? ( dracut_modules_crypt )
+ dracut_modules_crypt-loop? ( dracut_modules_crypt )
+ dracut_modules_livenet? ( dracut_modules_dmsquash-live )
+ "
+COMMON_MODULES="
+ dracut_modules_biosdevname
+ dracut_modules_bootchart
+ dracut_modules_btrfs
+ dracut_modules_caps
+ dracut_modules_crypt-gpg
+ dracut_modules_crypt-loop
+ dracut_modules_gensplash
+ dracut_modules_mdraid
+ dracut_modules_multipath
+ dracut_modules_plymouth
+ dracut_modules_syslog
+ dracut_modules_systemd
+ "
+DM_MODULES="
+ dracut_modules_crypt
+ dracut_modules_dmraid
+ dracut_modules_dmsquash-live
+ dracut_modules_livenet
+ dracut_modules_lvm
+ "
+NETWORK_MODULES="
+ dracut_modules_cifs
+ dracut_modules_iscsi
+ dracut_modules_livenet
+ dracut_modules_nbd
+ dracut_modules_nfs
+ dracut_modules_ssh-client
+ "
+add_req_use_for device-mapper ${DM_MODULES}
+add_req_use_for net ${NETWORK_MODULES}
+IUSE_DRACUT_MODULES="${COMMON_MODULES} ${DM_MODULES} ${NETWORK_MODULES}"
+IUSE="debug device-mapper optimization net selinux ${IUSE_DRACUT_MODULES}"
+
+RESTRICT="test"
+
+CDEPEND=">sys-fs/udev-166
+ dracut_modules_systemd? ( sys-apps/systemd )
+ "
+RDEPEND="${CDEPEND}
+ app-arch/cpio
+ >=app-shells/bash-4.0
+ >=app-shells/dash-0.5.4.11
+ >=sys-apps/baselayout-1.12.14-r1
+ || ( >=sys-apps/module-init-tools-3.8 >sys-apps/kmod-5[tools] )
+ >=sys-apps/sysvinit-2.87-r3
+ >=sys-apps/util-linux-2.21
+
+ debug? ( dev-util/strace )
+ device-mapper? ( || ( sys-fs/device-mapper >=sys-fs/lvm2-2.02.33 ) )
+ net? ( net-misc/curl >=net-misc/dhcp-4.2.1-r1 sys-apps/iproute2 )
+ selinux? ( sys-libs/libselinux sys-libs/libsepol )
+ dracut_modules_biosdevname? ( sys-apps/biosdevname )
+ dracut_modules_bootchart? ( app-benchmarks/bootchart2 )
+ dracut_modules_btrfs? ( sys-fs/btrfs-progs )
+ dracut_modules_caps? ( sys-libs/libcap )
+ dracut_modules_cifs? ( net-fs/cifs-utils )
+ dracut_modules_crypt? ( sys-fs/cryptsetup )
+ dracut_modules_crypt-gpg? ( app-crypt/gnupg )
+ dracut_modules_dmraid? ( sys-fs/dmraid sys-fs/multipath-tools )
+ dracut_modules_gensplash? ( media-gfx/splashutils )
+ dracut_modules_iscsi? ( >=sys-block/open-iscsi-2.0.871.3 )
+ dracut_modules_lvm? ( >=sys-fs/lvm2-2.02.33 )
+ dracut_modules_mdraid? ( sys-fs/mdadm )
+ dracut_modules_multipath? ( sys-fs/multipath-tools )
+ dracut_modules_nbd? ( sys-block/nbd )
+ dracut_modules_nfs? ( net-fs/nfs-utils net-nds/rpcbind )
+ dracut_modules_plymouth? ( >=sys-boot/plymouth-0.8.3-r1 )
+ dracut_modules_ssh-client? ( dev-libs/openssl )
+ dracut_modules_syslog? ( || ( app-admin/syslog-ng app-admin/rsyslog ) )
+ "
+DEPEND="${CDEPEND}
+ app-text/asciidoc
+ >=dev-libs/libxslt-1.1.26
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75.2
+ virtual/pkgconfig
+ "
+
+#
+# Helper functions
+#
+
+# Returns true if any of specified modules is enabled by USE flag and false
+# otherwise.
+# $1 = list of modules (which have corresponding USE flags of the same name)
+any_module() {
+ local m modules=" $@ "
+
+ for m in ${modules}; do
+ ! use $m && modules=${modules/ $m / }
+ done
+
+ shopt -s extglob
+ modules=${modules%%+( )}
+ shopt -u extglob
+
+ [[ ${modules} ]]
+}
+
+# Removes module from modules.d.
+# $1 = module name
+# Module name can be specified without number prefix.
+rm_module() {
+ local force m
+ [[ $1 = -f ]] && force=-f
+
+ for m in $@; do
+ if [[ $m =~ ^[0-9][0-9][^\ ]*$ ]]; then
+ rm ${force} --interactive=never -r "${modules_dir}"/$m
+ else
+ rm ${force} --interactive=never -r "${modules_dir}"/[0-9][0-9]$m
+ fi
+ done
+}
+
+#
+# ebuild functions
+#
+
+src_prepare() {
+ local udevdir="$($(tc-getPKG_CONFIG) udev --variable=udevdir)"
+ [[ ${udevdir} ]] || die "Couldn't detect udevdir"
+ einfo "Setting udevdir to ${udevdir}..."
+ sed -e "s@udevdir=.*@udevdir=\"${udevdir}\"@" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+
+ if use dracut_modules_systemd; then
+ local systemdutildir="$($(tc-getPKG_CONFIG) systemd \
+ --variable=systemdutildir)"
+ local systemdsystemunitdir="$($(tc-getPKG_CONFIG) systemd \
+ --variable=systemdsystemunitdir)"
+ [[ ${systemdutildir} ]] || die "Couldn't detect systemdutildir"
+ [[ ${systemdsystemunitdir} ]] \
+ || die "Couldn't detect systemdsystemunitdir"
+ einfo "Setting systemdutildir to ${systemdutildir} and ..."
+ sed -e "4asystemdutildir=\"${systemdutildir}\"" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+ einfo "Setting systemdsystemunitdir to ${systemdsystemunitdir}..."
+ sed -e "5asystemdsystemunitdir=\"${systemdsystemunitdir}\"" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+ fi
+}
+
+src_compile() {
+ emake prefix=/usr sysconfdir=/etc DESTDIR="${D}" doc
+ if use optimization; then
+ ewarn "Enabling experimental optimization!"
+ tc-export CC
+ emake prefix=/usr sysconfdir=/etc DESTDIR="${D}" install/dracut-install
+ fi
+}
+
+src_install() {
+ emake prefix=/usr libdir="/usr/$(get_libdir)" sysconfdir=/etc \
+ DESTDIR="${D}" install
+
+ dodir /var/lib/dracut/overlay
+ dodoc HACKING TODO AUTHORS NEWS README*
+
+ insinto /etc/dracut.conf.d
+ newins dracut.conf.d/gentoo.conf.example gentoo.conf
+
+ insinto /etc/logrotate.d
+ newins dracut.logrotate dracut
+
+ dohtml dracut.html
+
+ #
+ # Modules
+ #
+ local module
+ modules_dir="${D}/usr/$(get_libdir)/dracut/modules.d"
+
+ # Remove modules not enabled by USE flags
+ for module in ${IUSE_DRACUT_MODULES} ; do
+ ! use ${module} && rm_module -f ${module#dracut_modules_}
+ done
+
+ # Those flags are specific, and even are corresponding to modules, they need
+ # to be declared as regular USE flags.
+ use debug || rm_module 95debug
+ use selinux || rm_module 98selinux
+
+ # Following flags define set of helper modules which are base dependencies
+ # for others and as so have no practical use, so remove these modules.
+ use device-mapper || rm_module 90dm
+ use net || rm_module 40network 45ifcfg 45url-lib
+
+ # Remove S/390 modules which are not tested at all
+ rm_module 80cms 95dasd 95dasd_mod 95zfcp 95znet
+
+ # Remove modules which won't work for sure
+ rm_module 95fcoe # no tools
+ # fips module depends on masked app-crypt/hmaccalc
+ rm_module 01fips 02fips-aesni
+
+ # Remove extra modules which go to future dracut-extras
+ rm_module 05busybox 97masterkey 98ecryptfs 98integrity
+}
+
+pkg_postinst() {
+ if linux-info_get_any_version && linux_config_src_exists; then
+ ewarn ""
+ ewarn "If the following test report contains a missing kernel"
+ ewarn "configuration option, you should reconfigure and rebuild your"
+ ewarn "kernel before booting image generated with this Dracut version."
+ ewarn ""
+
+ local CONFIG_CHECK="~BLK_DEV_INITRD ~DEVTMPFS ~MODULES"
+
+ # Kernel configuration options descriptions:
+ local desc_DEVTMPFS="Maintain a devtmpfs filesystem to mount at /dev"
+ local desc_BLK_DEV_INITRD="Initial RAM filesystem and RAM disk "\
+"(initramfs/initrd) support"
+ local desc_MODULES="Enable loadable module support"
+
+ local opt desc
+
+ # Generate ERROR_* variables for check_extra_config.
+ for opt in ${CONFIG_CHECK}; do
+ opt=${opt#\~}
+ desc=desc_${opt}
+ eval "local ERROR_${opt}='CONFIG_${opt}: \"${!desc}\"" \
+ "is missing and REQUIRED'"
+ done
+
+ check_extra_config
+ echo
+ else
+ ewarn ""
+ ewarn "Your kernel configuration couldn't be checked. Do you have"
+ ewarn "/usr/src/linux/.config file there? Please check manually if"
+ ewarn "following options are enabled:"
+ ewarn ""
+ ewarn " CONFIG_BLK_DEV_INITRD"
+ ewarn " CONFIG_DEVTMPFS"
+ ewarn " CONFIG_MODULES"
+ ewarn ""
+ fi
+}