summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-10-23 11:16:16 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-10-23 11:16:16 +0000
commit120360dace9c7b395b2e596937f194755674fa16 (patch)
tree6dc527bc2c7ad19b9e3a03398effefc16fa8ac5e /sys-kernel/hardened-sources/hardened-sources-2.6.32-r71.ebuild
parentRemoved, bug #387877 (diff)
downloadgentoo-2-120360dace9c7b395b2e596937f194755674fa16.tar.gz
gentoo-2-120360dace9c7b395b2e596937f194755674fa16.tar.bz2
gentoo-2-120360dace9c7b395b2e596937f194755674fa16.zip
Based on 2.6.32.46 + genpatches-2.6.32-43 + grsecurity-2.2.2-2.6.32.46-201110200052
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-2.6.32-r71.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.32-r71.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.32-r71.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r71.ebuild
new file mode 100644
index 000000000000..7423f335a150
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r71.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.32-r71.ebuild,v 1.1 2011/10/23 11:16:16 blueness Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="43"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-74"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="2000_fix-broken-backport-for-ipv6-tunnels.patch 4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.2*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides three different predefined grsecurity level:"
+ ewarn "[server], [workstation], and [virtualization]."
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}