summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-12-04 22:57:08 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-12-04 22:57:08 +0000
commitab361b3df21fe87778b7f777dbb9cc872d575cf3 (patch)
treef05682e2daa56d5429f56ba4c076676e48c37a81 /sys-kernel/hardened-sources
parentRemove old. (diff)
downloadgentoo-2-ab361b3df21fe87778b7f777dbb9cc872d575cf3.tar.gz
gentoo-2-ab361b3df21fe87778b7f777dbb9cc872d575cf3.tar.bz2
gentoo-2-ab361b3df21fe87778b7f777dbb9cc872d575cf3.zip
Based on 2.6.32.49 + genpatches-2.6.32-45 + grsecurity-2.2.2-2.6.32.49-201111292107
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/hardened-sources')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog9
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.32-r79.ebuild49
2 files changed, 57 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 0e58c7397e4f..d1bfbd50299e 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.507 2011/12/01 15:32:58 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.508 2011/12/04 22:57:08 blueness Exp $
+
+*hardened-sources-2.6.32-r79 (04 Dec 2011)
+
+ 04 Dec 2011; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.32-r79.ebuild:
+ Based on 2.6.32.49 + genpatches-2.6.32-45 +
+ grsecurity-2.2.2-2.6.32.49-201111292107
01 Dec 2011; Anthony G. Basile <blueness@gentoo.org>
hardened-sources-3.0.4-r5.ebuild:
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.32-r79.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r79.ebuild
new file mode 100644
index 000000000000..74f5e2e42a5a
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r79.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.32-r79.ebuild,v 1.1 2011/12/04 22:57:08 blueness Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="45"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-81"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="2901_kbuild-fix-passing-wno-options-to-gcc-4.4.patch 4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.2*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides three different predefined grsecurity level:"
+ ewarn "[server], [workstation], and [virtualization]."
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}