summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-04-30 15:00:19 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-04-30 15:00:19 +0000
commite7b6449f78296c8256597749a735e8d05c71adf9 (patch)
tree40396c2d8e94f6a2ba62580d6730aa29e6b4280a /sys-kernel/ksymoops
parentremoving libiberty.a and closing bug #2266 (diff)
downloadgentoo-2-e7b6449f78296c8256597749a735e8d05c71adf9.tar.gz
gentoo-2-e7b6449f78296c8256597749a735e8d05c71adf9.tar.bz2
gentoo-2-e7b6449f78296c8256597749a735e8d05c71adf9.zip
new ksymoops ebuild
Diffstat (limited to 'sys-kernel/ksymoops')
-rw-r--r--sys-kernel/ksymoops/ksymoops-2.4.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-kernel/ksymoops/ksymoops-2.4.5.ebuild b/sys-kernel/ksymoops/ksymoops-2.4.5.ebuild
new file mode 100644
index 000000000000..68f07be70e14
--- /dev/null
+++ b/sys-kernel/ksymoops/ksymoops-2.4.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Paul Thompson <set@pobox.com>
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ksymoops/ksymoops-2.4.5.ebuild,v 1.1 2002/04/30 15:00:19 drobbins Exp $
+
+DESCRIPTION="Utility to decode a kernel oops, or other kernel call traces."
+SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/kernel/ksymoops/v2.4/${P}.tar.gz"
+DEPEND="virtual/glibc >=sys-devel/binutils-2.9.1.0.25"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mv Makefile Makefile.orig
+ # static/dynamic hack
+ # unfortunately, binutils and gcc ebuilds both install a libiberty.a
+ # and gcc's is not compatible with binutils libbfd.a
+ # linking against a bad mixuture results in missing symbols.
+ # linking against the shared (dynamic) objects seems to work.
+ sed -e "/^STATIC/s/-Bstatic/-Bdynamic/" -e "s/-O2/${CFLAGS}/" < \
+ Makefile.orig > Makefile
+ # Note: this problem is fixed as of gcc-2.95.3-r6, so we can remove this
+ # fix eventually
+}
+
+src_compile() {
+ emake all || die
+}
+
+src_install() {
+ into /
+ dosbin ksymoops
+ doman ksymoops.8
+ dodoc Changelog README README.XFree86
+}