summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-27 00:29:42 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-27 00:29:42 +0000
commitc53cdcf5f47216544656935fdfa2e90e8d8385a1 (patch)
tree28ec3ff453377a26ee77241cb03c56d499dcea63 /sys-kernel/linux-headers
parentAdded patch from kumba to use mips-headers for mips and nptl. (diff)
downloadgentoo-2-c53cdcf5f47216544656935fdfa2e90e8d8385a1.tar.gz
gentoo-2-c53cdcf5f47216544656935fdfa2e90e8d8385a1.tar.bz2
gentoo-2-c53cdcf5f47216544656935fdfa2e90e8d8385a1.zip
add support for cris
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-kernel/linux-headers')
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.6.11-r2.ebuild10
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.6.11-r3.ebuild10
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild10
3 files changed, 24 insertions, 6 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-2.6.11-r2.ebuild b/sys-kernel/linux-headers/linux-headers-2.6.11-r2.ebuild
index 070383c6f306..fd466b73e8fb 100644
--- a/sys-kernel/linux-headers/linux-headers-2.6.11-r2.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.6.11-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.11-r2.ebuild,v 1.23 2006/01/15 20:54:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.11-r2.ebuild,v 1.24 2006/01/27 00:29:42 vapier Exp $
ETYPE="headers"
-H_SUPPORTEDARCH="alpha amd64 arm bfin hppa m68k ia64 ppc ppc64 s390 sh sparc x86"
+H_SUPPORTEDARCH="alpha amd64 arm bfin cris hppa m68k ia64 ppc ppc64 s390 sh sparc x86"
inherit eutils kernel-2
detect_version
@@ -20,6 +20,12 @@ DEPEND="ppc? ( gcc64? ( sys-devel/gcc-powerpc64 ) )
UNIPATCH_LIST="${DISTDIR}/gentoo-headers-${PV}-${PATCHES_V}.tar.bz2
${DISTDIR}/linux-2.6.12.1-blackfin.patch.bz2"
+kernel-2_hook_premake() {
+ # cris is slightly incomplete so lets fake it enough to get headers
+ mkdir -p arch/cris/boot
+ touch arch/cris/boot/Makefile
+}
+
src_unpack() {
kernel-2_src_unpack
epatch "${FILESDIR}"/2.6.11-s390-cflags-update.patch
diff --git a/sys-kernel/linux-headers/linux-headers-2.6.11-r3.ebuild b/sys-kernel/linux-headers/linux-headers-2.6.11-r3.ebuild
index 9119dd70b545..f750e3bcd97e 100644
--- a/sys-kernel/linux-headers/linux-headers-2.6.11-r3.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.6.11-r3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.11-r3.ebuild,v 1.4 2006/01/15 20:54:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.11-r3.ebuild,v 1.5 2006/01/27 00:29:42 vapier Exp $
ETYPE="headers"
-H_SUPPORTEDARCH="alpha amd64 arm bfin hppa m68k ia64 ppc ppc64 s390 sh sparc x86"
+H_SUPPORTEDARCH="alpha amd64 arm bfin cris hppa m68k ia64 ppc ppc64 s390 sh sparc x86"
inherit eutils kernel-2
detect_version
@@ -20,6 +20,12 @@ DEPEND="ppc? ( gcc64? ( sys-devel/gcc-powerpc64 ) )
UNIPATCH_LIST="${DISTDIR}/gentoo-headers-${PV}-${PATCHES_V}.tar.bz2
${DISTDIR}/linux-2.6.12.1-blackfin.patch.bz2"
+kernel-2_hook_premake() {
+ # cris is slightly incomplete so lets fake it enough to get headers
+ mkdir -p arch/cris/boot
+ touch arch/cris/boot/Makefile
+}
+
src_unpack() {
kernel-2_src_unpack
epatch "${FILESDIR}"/2.6.11-s390-cflags-update.patch
diff --git a/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild b/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild
index a382c48bef28..cc54ed054df7 100644
--- a/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild,v 1.7 2006/01/15 20:54:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild,v 1.8 2006/01/27 00:29:42 vapier Exp $
ETYPE="headers"
-H_SUPPORTEDARCH="alpha amd64 arm bfin hppa m68k ia64 ppc ppc64 s390 sh sparc x86"
+H_SUPPORTEDARCH="alpha amd64 arm bfin cris hppa m68k ia64 ppc ppc64 s390 sh sparc x86"
inherit eutils kernel-2
detect_version
@@ -20,6 +20,12 @@ DEPEND="ppc? ( gcc64? ( sys-devel/gcc-powerpc64 ) )
UNIPATCH_LIST="${DISTDIR}/gentoo-headers-${PV}-${PATCHES_V}.tar.bz2
${DISTDIR}/linux-2.6.12.1-blackfin.patch.bz2"
+kernel-2_hook_premake() {
+ # cris is slightly incomplete so lets fake it enough to get headers
+ mkdir -p arch/cris/boot
+ touch arch/cris/boot/Makefile
+}
+
src_unpack() {
kernel-2_src_unpack