summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2013-01-13 03:14:33 +0000
committerAlex Alexander <wired@gentoo.org>2013-01-13 03:14:33 +0000
commitfe160ca6cbbfb95b8bdfd5a9cb7091596722938f (patch)
treeccc0b93d5deffdef6773736f7810703e7aca3c5f /sys-kernel/pf-sources
parentRebase backport patchset to fix a glaringly obvious mistake I made when backp... (diff)
downloadgentoo-2-fe160ca6cbbfb95b8bdfd5a9cb7091596722938f.tar.gz
gentoo-2-fe160ca6cbbfb95b8bdfd5a9cb7091596722938f.tar.bz2
gentoo-2-fe160ca6cbbfb95b8bdfd5a9cb7091596722938f.zip
version bump
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, signed Manifest commit with key EB9B4AFA)
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/ChangeLog9
-rw-r--r--sys-kernel/pf-sources/pf-sources-3.7.2.ebuild70
2 files changed, 77 insertions, 2 deletions
diff --git a/sys-kernel/pf-sources/ChangeLog b/sys-kernel/pf-sources/ChangeLog
index 6ad8c77d77d2..8283db43a626 100644
--- a/sys-kernel/pf-sources/ChangeLog
+++ b/sys-kernel/pf-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/pf-sources
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.85 2012/12/22 00:27:19 hwoarang Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.86 2013/01/13 03:14:33 wired Exp $
+
+*pf-sources-3.7.2 (13 Jan 2013)
+
+ 13 Jan 2013; Alex Alexander <wired@gentoo.org> +pf-sources-3.7.2.ebuild:
+ version bump
*pf-sources-3.6.12 (22 Dec 2012)
*pf-sources-3.7.1 (22 Dec 2012)
diff --git a/sys-kernel/pf-sources/pf-sources-3.7.2.ebuild b/sys-kernel/pf-sources/pf-sources-3.7.2.ebuild
new file mode 100644
index 000000000000..a5b3b2344209
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-3.7.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-3.7.2.ebuild,v 1.1 2013/01/13 03:14:33 wired Exp $
+
+EAPI="2"
+
+inherit versionator
+
+COMPRESSTYPE=".bz2"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="$(get_version_component_range 1-2)"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new features, including the -ck patchset (BFS), BFQ, TuxOnIce and UKSM"
+HOMEPAGE="http://pf.natalenko.name/"
+
+PF_FILE="patch-${PV}-pf${COMPRESSTYPE}"
+PF_URI="http://pf.natalenko.name/sources/$(get_version_component_range 1-2)/${PF_FILE}"
+EXPERIMENTAL_PATCHES=(
+ # http://ck-hack.blogspot.com/2010/11/create-task-groups-by-tty-comment.html
+ # http://ck.kolivas.org/patches/bfs/bfs357-penalise_fork_depth_account_threads.patch
+)
+EXPERIMENTAL_URI="
+ experimental? (
+ ${EXPERIMENTAL_PATCHES[@]}
+ )
+"
+SRC_URI="${KERNEL_URI} ${PF_URI}" # \${EXPERIMENTAL_URI}
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="" # experimental
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ elog
+ elog "${P} has the following optional runtime dependencies:"
+ elog " sys-apps/tuxonice-userui"
+ elog " provides minimal userspace progress information related to"
+ elog " suspending and resuming process"
+ elog " sys-power/hibernate-script or sys-power/pm-utils"
+ elog " runtime utilites for hibernating and suspending your computer"
+ elog
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+see: ${HOMEPAGE}."