summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2012-06-16 18:57:43 +0000
committerRichard Yao <ryao@gentoo.org>2012-06-16 18:57:43 +0000
commit4994aceccecb879f05ead4b5f5c692e21ae16c7a (patch)
tree33e75dd4b19b7bd6883a8879f0b9a8cda2559720 /sys-kernel/spl
parentIntroduce ZFS 0.6.0-rc9 without keywords (diff)
downloadgentoo-2-4994aceccecb879f05ead4b5f5c692e21ae16c7a.tar.gz
gentoo-2-4994aceccecb879f05ead4b5f5c692e21ae16c7a.tar.bz2
gentoo-2-4994aceccecb879f05ead4b5f5c692e21ae16c7a.zip
Introduce SPL 0.6.0-rc9 without keywords
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/spl')
-rw-r--r--sys-kernel/spl/ChangeLog8
-rw-r--r--sys-kernel/spl/spl-0.6.0_rc9.ebuild82
-rw-r--r--sys-kernel/spl/spl-9999.ebuild18
3 files changed, 102 insertions, 6 deletions
diff --git a/sys-kernel/spl/ChangeLog b/sys-kernel/spl/ChangeLog
index 71e2194e13f7..47406f6bda2e 100644
--- a/sys-kernel/spl/ChangeLog
+++ b/sys-kernel/spl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/spl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/ChangeLog,v 1.15 2012/05/17 18:41:28 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/ChangeLog,v 1.16 2012/06/16 18:57:43 ryao Exp $
+
+*spl-0.6.0_rc9 (16 Jun 2012)
+
+ 16 Jun 2012; Richard Yao <ryao@gentoo.org> +spl-0.6.0_rc9.ebuild,
+ spl-9999.ebuild:
+ Introduce SPL 0.6.0-rc9 without keywords
17 May 2012; <richard@gentoo.org> metadata.xml:
Changed maintainer from floppym to ryao to reflect change in ryao's dev status
diff --git a/sys-kernel/spl/spl-0.6.0_rc9.ebuild b/sys-kernel/spl/spl-0.6.0_rc9.ebuild
new file mode 100644
index 000000000000..d6efe8bb2d14
--- /dev/null
+++ b/sys-kernel/spl/spl-0.6.0_rc9.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/spl-0.6.0_rc9.ebuild,v 1.1 2012/06/16 18:57:43 ryao Exp $
+
+EAPI="4"
+AUTOTOOLS_AUTORECONF="1"
+
+inherit flag-o-matic linux-mod autotools-utils
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/zfsonlinux/${PN}.git"
+else
+ inherit versionator
+ MY_PV=$(replace_version_separator 3 '-')
+ SRC_URI="https://github.com/downloads/zfsonlinux/${PN}/${PN}-${MY_PV}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="The Solaris Porting Layer is a Linux kernel module which provides many of the Solaris kernel APIs"
+HOMEPAGE="http://zfsonlinux.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+IUSE="custom-cflags debug"
+
+RDEPEND="!sys-devel/spl"
+
+AT_M4DIR="config"
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+
+pkg_setup() {
+ CONFIG_CHECK="
+ !DEBUG_LOCK_ALLOC
+ !PREEMPT
+ !PREEMPT_VOLUNTARY
+ MODULES
+ KALLSYMS
+ ZLIB_DEFLATE
+ ZLIB_INFLATE
+ "
+ kernel_is ge 2 6 26 || die "Linux 2.6.26 or newer required"
+ check_extra_config
+}
+
+src_prepare() {
+ # Workaround for hard coded path
+ sed -i "s|/sbin/lsmod|/bin/lsmod|" scripts/check.sh || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ use custom-cflags || strip-flags
+ set_arch_to_kernel
+ local myeconfargs=(
+ --bindir="${EPREFIX}/bin"
+ --sbindir="${EPREFIX}/sbin"
+ --with-config=all
+ --with-linux="${KV_DIR}"
+ --with-linux-obj="${KV_OUT_DIR}"
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ if [[ ! -e /proc/modules ]]
+ then
+ die "Missing /proc/modules"
+ elif [[ $UID -ne 0 ]]
+ then
+ ewarn "Cannot run make check tests with FEATURES=userpriv."
+ ewarn "Skipping make check tests."
+ elif grep -q '^spl ' /proc/modules
+ then
+ ewarn "Cannot run make check tests with module spl loaded."
+ ewarn "Skipping make check tests."
+ else
+ autotools-utils_src_test
+ fi
+}
diff --git a/sys-kernel/spl/spl-9999.ebuild b/sys-kernel/spl/spl-9999.ebuild
index 5af8c264f0b6..e050eeee3bf0 100644
--- a/sys-kernel/spl/spl-9999.ebuild
+++ b/sys-kernel/spl/spl-9999.ebuild
@@ -1,20 +1,28 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/spl-9999.ebuild,v 1.14 2012/04/21 17:53:38 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/spl-9999.ebuild,v 1.15 2012/06/16 18:57:43 ryao Exp $
EAPI="4"
AUTOTOOLS_AUTORECONF="1"
-inherit flag-o-matic git-2 linux-mod autotools-utils
+inherit flag-o-matic linux-mod autotools-utils
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/zfsonlinux/${PN}.git"
+else
+ inherit versionator
+ MY_PV=$(replace_version_separator 3 '-')
+ SRC_URI="https://github.com/downloads/zfsonlinux/${PN}/${PN}-${MY_PV}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+ KEYWORDS=""
+fi
DESCRIPTION="The Solaris Porting Layer is a Linux kernel module which provides many of the Solaris kernel APIs"
HOMEPAGE="http://zfsonlinux.org/"
-SRC_URI=""
-EGIT_REPO_URI="git://github.com/zfsonlinux/spl.git"
LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="0"
-KEYWORDS=""
IUSE="custom-cflags debug"
RDEPEND="!sys-devel/spl"