summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Eichert <viz@gentoo.org>2002-12-24 02:13:32 +0000
committerTobias Eichert <viz@gentoo.org>2002-12-24 02:13:32 +0000
commitda52535cce108ed0aef2edfcb111bbcf2d3800e6 (patch)
treee33a9feb550e04bdb41f65036ded404647afbaef /sys-kernel/xfs-sources
parentVersion bump (diff)
downloadgentoo-2-da52535cce108ed0aef2edfcb111bbcf2d3800e6.tar.gz
gentoo-2-da52535cce108ed0aef2edfcb111bbcf2d3800e6.tar.bz2
gentoo-2-da52535cce108ed0aef2edfcb111bbcf2d3800e6.zip
new version, minor bugfixes
Diffstat (limited to 'sys-kernel/xfs-sources')
-rw-r--r--sys-kernel/xfs-sources/ChangeLog20
-rw-r--r--sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre22
-rw-r--r--sys-kernel/xfs-sources/xfs-sources-2.4.20_pre2.ebuild51
3 files changed, 72 insertions, 1 deletions
diff --git a/sys-kernel/xfs-sources/ChangeLog b/sys-kernel/xfs-sources/ChangeLog
index d9ce3126b2f4..a0fb064bfeb2 100644
--- a/sys-kernel/xfs-sources/ChangeLog
+++ b/sys-kernel/xfs-sources/ChangeLog
@@ -1,7 +1,25 @@
# ChangeLog for sys-kernel/xfs-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.10 2002/12/23 00:42:06 viz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.11 2002/12/24 02:13:30 viz Exp $
+*xfs-sources-2.4.29_pre2 (24 Dec 2002)
+
+ 24 Dec 2002; Tobias Eichert <viz@gentoo.org> xfs-sources-2.4.20_pre2.ebuild:
+
+ New version.
+
+ Since my first version broke some stuff I made a new
+ one containing minor bugfixes. Now it should compile
+ all the way through..
+
+ New from xfs-sources-2.4.20_pre1:
+
+ - Update imon to recent version
+ - Removed openwall for further testing
+ - I tried several configs this time ;)
+
+ Please test and send bugreports.
+
*xfs-sources-2.4.20_pre1 (22 Dec 2002)
22 Dec 2002; Tobias Eichert <viz@gentoo.org> xfs-sources-2.4.20_pre1.ebuild:
diff --git a/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre2 b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre2
new file mode 100644
index 000000000000..f02306b143fd
--- /dev/null
+++ b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre2
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 c7ff8f35f6c37dbb0e5bbccca2d19b54 patches-2.4.20-xfs_pre2.tar.bz2 1789522
diff --git a/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre2.ebuild b/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre2.ebuild
new file mode 100644
index 000000000000..b27bacd169ff
--- /dev/null
+++ b/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre2.ebuild,v 1.1 2002/12/24 02:13:30 viz Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+# This kernel also has support for the local USE flag acpi4linux which
+# activates the latest code from acpi.sourceforge.net instead of the
+# very out of date vanilla version
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV=2.4.20
+EXTRAVERSION=-xfs_pre2
+KV=${OKV}${EXTRAVERSION}
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/xfs-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the XFS Specialized Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.databoogie.net/kernel/patches-${KV}.tar.bz2"
+KEYWORDS="~x86 -ppc -sparc "
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ [ `use crypt` ] || rm 8*
+
+ kernel_src_unpack
+}