summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2010-10-24 17:17:18 +0000
committerAnthony G. Basile <blueness@gentoo.org>2010-10-24 17:17:18 +0000
commit19593976752309bacfebbc8831a050a47d887d4f (patch)
tree1eb0685d88afc7e16a5be2ab1d109053d18a2f56 /sys-kernel
parentRemove old versions. (diff)
downloadgentoo-2-19593976752309bacfebbc8831a050a47d887d4f.tar.gz
gentoo-2-19593976752309bacfebbc8831a050a47d887d4f.tar.bz2
gentoo-2-19593976752309bacfebbc8831a050a47d887d4f.zip
hardened-sources-2.6.32-r23 based on 2.6.32.24 + genpatches + grsec-2.2.0-2.6.32.24-201010232009
hardened-sources-2.6.35-r5 based on 2.6.35.7 + genpatches + grsec-2.2.0-2.6.35.7-201010232009 (Portage version: 2.1.9.16/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog12
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.32-r23.ebuild46
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.35-r5.ebuild46
3 files changed, 103 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 6a9f044a0a27..5b3ca78247d4 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.349 2010/10/24 10:24:23 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.350 2010/10/24 17:17:18 blueness Exp $
+
+*hardened-sources-2.6.35-r5 (24 Oct 2010)
+*hardened-sources-2.6.32-r23 (24 Oct 2010)
+
+ 24 Oct 2010; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.32-r23.ebuild, +hardened-sources-2.6.35-r5.ebuild:
+ hardened-sources-2.6.32-r23 based on 2.6.32.24 + genpatches +
+ grsec-2.2.0-2.6.32.24-201010232009
+ hardened-sources-2.6.35-r5 based on 2.6.35.7 + genpatches +
+ grsec-2.2.0-2.6.35.7-201010232009
24 Oct 2010; Anthony G. Basile <blueness@gentoo.org>
hardened-sources-2.6.32-r22.ebuild:
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.32-r23.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r23.ebuild
new file mode 100644
index 000000000000..1f6907387288
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r23.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.32-r23.ebuild,v 1.1 2010/10/24 17:17:18 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="24"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-26"
+HGPV_URI="mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.0*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides four different predefined grsecurity level:"
+ ewarn "[server], [server no rbac] [workstation] [workstation no rbac]"
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.35-r5.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.35-r5.ebuild
new file mode 100644
index 000000000000..52f815dd99d2
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.35-r5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.35-r5.ebuild,v 1.1 2010/10/24 17:17:18 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="11"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-6"
+HGPV_URI="mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.0*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides four different predefined grsecurity level:"
+ ewarn "[server], [server no rbac] [workstation] [workstation no rbac]"
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}