summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-03-09 22:16:29 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-03-09 22:16:29 +0000
commit1bf961808aec25580a627937515e62e5f3e4e380 (patch)
treed7bf917df37cd6d1f0d3215c2aaf37dcce8990d1 /sys-kernel
parentversion bump. see a list of changes here: http://symfony.com/blog/symfony-1-4... (diff)
downloadgentoo-2-1bf961808aec25580a627937515e62e5f3e4e380.tar.gz
gentoo-2-1bf961808aec25580a627937515e62e5f3e4e380.tar.bz2
gentoo-2-1bf961808aec25580a627937515e62e5f3e4e380.zip
Based on 3.2.9 + genpatches-3.2-10 + grsecurity-2.9-3.2.9-201203062051
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog8
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-3.2.9-r1.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index cfa0118be9b0..a680558eb07e 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.548 2012/03/09 22:13:21 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.549 2012/03/09 22:16:29 blueness Exp $
+
+*hardened-sources-3.2.9-r1 (09 Mar 2012)
+
+ 09 Mar 2012; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-3.2.9-r1.ebuild:
+ Based on 3.2.9 + genpatches-3.2-10 + grsecurity-2.9-3.2.9-201203062051
*hardened-sources-2.6.32-r94 (09 Mar 2012)
diff --git a/sys-kernel/hardened-sources/hardened-sources-3.2.9-r1.ebuild b/sys-kernel/hardened-sources/hardened-sources-3.2.9-r1.ebuild
new file mode 100644
index 000000000000..8685b8e4e80c
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-3.2.9-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.9-r1.ebuild,v 1.1 2012/03/09 22:16:29 blueness Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="10"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-2"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+! use xtpax && UNIPATCH_EXCLUDE+=" 4425_grsec_enable_xtpax.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob -xtpax"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.9"
+
+ ewarn
+ ewarn "Hardened Gentoo provides three different predefined grsecurity level:"
+ ewarn "[server], [workstation], and [virtualization]. Those who intend to"
+ ewarn "use one of these predefined grsecurity levels should read the help"
+ ewarn "associated with the level. Because some options require >=gcc-4.5,"
+ ewarn "users with more, than one version of gcc installed should use gcc-config"
+ ewarn "to select a compatible version."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}*"
+ ewarn
+}