summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2008-06-17 18:29:37 +0000
committerNed Ludd <solar@gentoo.org>2008-06-17 18:29:37 +0000
commit4fab36960b441af0b2bbb5ce1b24c5a5b1319e0e (patch)
tree57c047f9c4f16c2a2dcb4b49d7503b6f94021e06 /sys-kernel
parentRemove redundant variables (diff)
downloadgentoo-2-4fab36960b441af0b2bbb5ce1b24c5a5b1319e0e.tar.gz
gentoo-2-4fab36960b441af0b2bbb5ce1b24c5a5b1319e0e.tar.bz2
gentoo-2-4fab36960b441af0b2bbb5ce1b24c5a5b1319e0e.zip
2.6.23-r13: Fixes security bugs #198997, #212136, #222331, #222635, #224647, #225461, other fixes.
2.6.24-r3: Fixes security bugs #212136, #222331, #222635, #224647, #225461, grsec/PaX updates/fixes, other fixes. 2.6.25: Initial 2.6.25 release. (Portage version: 2.1.3.19)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog13
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.23-r13.ebuild35
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.24-r3.ebuild37
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.25.ebuild42
4 files changed, 126 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 9ff2ec8e4f12..0a1319637cb4 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.225 2008/05/15 15:35:54 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.226 2008/06/17 18:29:37 solar Exp $
+
+*hardened-sources-2.6.25 (17 Jun 2008)
+*hardened-sources-2.6.24-r3 (17 Jun 2008)
+*hardened-sources-2.6.23-r13 (17 Jun 2008)
+
+ 17 Jun 2008; <solar@gentoo.org> +hardened-sources-2.6.23-r13.ebuild,
+ +hardened-sources-2.6.24-r3.ebuild, +hardened-sources-2.6.25.ebuild:
+ * 2.6.23-r13: Fixes security bugs #198997, #212136, #222331, #222635,
+ #224647, #225461, other fixes. * 2.6.24-r3: Fixes security bugs #212136,
+ #222331, #222635, #224647, #225461, grsec/PaX updates/fixes, other fixes. *
+ 2.6.25: Initial 2.6.25 release.
15 May 2008; <solar@gentoo.org> hardened-sources-2.6.23-r12.ebuild:
- fasttrack to stable x86/amd64
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.23-r13.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.23-r13.ebuild
new file mode 100644
index 000000000000..e6e5bf53d0f5
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.23-r13.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.23-r13.ebuild,v 1.1 2008/06/17 18:29:37 solar Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="10"
+
+inherit kernel-2
+detect_version
+
+HGPV=${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-11
+HGPV_URI="http://confucius.dh.bytemark.co.uk/~kerin.millar/distfiles/hardened-patches-${HGPV}.extras.tar.bz2
+ mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.4-2.6.23-rc7.patch 4205_uvesafb-0.1-rc3-2.6.23-rc3.patch 4405_alpha-sysctl-uac.patch"
+DESCRIPTION="Hardened kernel sources ${OKV}"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ ewarn
+ ewarn "The options selected by the \"Hardened [Gentoo]\" security level"
+ ewarn "(GRKERNSEC_HARDENED) have been revised for this release. If you intend"
+ ewarn "to import a previous kernel configuration which uses this level then"
+ ewarn "please remember to review these changes before you build the kernel. In"
+ ewarn "particular, x86 users should note that PAX_MEMORY_UDEREF is now enabled"
+ ewarn "which is known not to work well in some virtualised environments. If this"
+ ewarn "affects you then you should switch to the \"Custom\" security level and"
+ ewarn "disable the option."
+ ewarn
+}
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.24-r3.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.24-r3.ebuild
new file mode 100644
index 000000000000..f2a423638b90
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.24-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.24-r3.ebuild,v 1.1 2008/06/17 18:29:37 solar Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="8"
+
+inherit kernel-2
+detect_version
+
+HGPV=${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-4
+HGPV_URI="http://confucius.dh.bytemark.co.uk/~kerin.millar/distfiles/hardened-patches-${HGPV}.extras.tar.bz2
+ mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.4.patch"
+DESCRIPTION="Hardened kernel sources ${OKV}"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ ewarn
+ ewarn "As of ${CATEGORY}/${PN}-2.6.24 the predefined"
+ ewarn "\"Hardened [Gentoo]\" grsecurity level has been removed."
+ ewarn "Two improved predefined security levels replace it:"
+ ewarn "\"Hardened Gentoo [server]\" and \"Hardened Gentoo [workstation]\""
+ ewarn
+ ewarn "If you intend to use one of these predefined grsecurity levels,"
+ ewarn "please read the help associated with the level. If you intend to"
+ ewarn "import a previous kernel configuration, please review your selected"
+ ewarn "grsecurity/PaX options carefully before building the kernel."
+ ewarn
+}
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.25.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.25.ebuild
new file mode 100644
index 000000000000..99f022b2b2b2
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.25.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.25.ebuild,v 1.1 2008/06/17 18:29:37 solar Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="5"
+
+inherit kernel-2
+detect_version
+
+HGPV=${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-1
+HGPV_URI="http://confucius.dh.bytemark.co.uk/~kerin.millar/distfiles/hardened-patches-${HGPV}.extras.tar.bz2
+ mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="2600_apple-numlock-emulation.patch 4200_fbcondecor-0.9.4.patch"
+DESCRIPTION="Hardened kernel sources ${OKV}"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ ewarn
+ ewarn "As of ${CATEGORY}/${PN}-2.6.24 the predefined \"Hardened"
+ ewarn "[Gentoo]\" grsecurity level has been removed. Two improved predefined"
+ ewarn "security levels replace it: \"Hardened Gentoo [server]\" and \"Hardened"
+ ewarn "Gentoo [workstation]\". If you intend to use one of these predefined"
+ ewarn "grsecurity levels, please read the help associated with the level. If"
+ ewarn "you intend to import a previous kernel configuration, please review your"
+ ewarn "selected grsecurity/PaX options carefully before building the kernel."
+ ewarn
+ ewarn "If you intend to use grsecurity's RBAC system then you must ensure that"
+ ewarn "you are using a recent version of gradm (2.1.12 or higher). As such, it"
+ ewarn "is strongly recommended that you run the following command before"
+ ewarn "booting with a 2.6.25 kernel for the first time:"
+ ewarn
+ ewarn "emerge -na '>=sys-apps/gradm-2.1.12'"
+ ewarn
+}