summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-10-17 17:58:29 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-10-17 17:58:29 +0000
commitb06eeae6302ca1fa56f283799d94d6cfe3d0d921 (patch)
tree92551e3beaaefd387ecfc978a36cace164572af1 /sys-kernel
parentemake->make (diff)
downloadgentoo-2-b06eeae6302ca1fa56f283799d94d6cfe3d0d921.tar.gz
gentoo-2-b06eeae6302ca1fa56f283799d94d6cfe3d0d921.tar.bz2
gentoo-2-b06eeae6302ca1fa56f283799d94d6cfe3d0d921.zip
finally ready to play with
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/lolo-sources/ChangeLog46
-rw-r--r--sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre12
-rw-r--r--sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre1.ebuild53
3 files changed, 100 insertions, 1 deletions
diff --git a/sys-kernel/lolo-sources/ChangeLog b/sys-kernel/lolo-sources/ChangeLog
index 624cb26649fe..8f50664269c3 100644
--- a/sys-kernel/lolo-sources/ChangeLog
+++ b/sys-kernel/lolo-sources/ChangeLog
@@ -1,6 +1,50 @@
# ChangeLog for sys-kernel/lolo-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.13 2002/10/03 18:21:47 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.14 2002/10/17 17:58:29 lostlogic Exp $
+
+*lolo-sources-2.4.20.1_pre1 (16 Oct 2002)
+
+ 16 Oct 2002; Brandon Low <lostlogic@gentoo.org> lolo-sources-2.4.20.11_pre1.ebuild:
+
+ The long awaited of the 2.4.20 series of stuff, this one is still missing stuff.
+
+ Changes from gentoo-sources-2.4.19-r10:
+ - Switch to a base of linux-2.4.20-pre10-ac2
+ - Update grsecurity, preempt, jiffies, acpi, etc.
+
+ Random known todo:
+ - Fix grsecurity VM_STACK_FLAGS stuff (per-arch VM_DATA_DEFAULT,
+ possibly upstreamable)
+
+ Patches added:
+ - 06_O_STREAMING-2.4.20-pre9-1
+ - 32_v4l2-api-2.4.20-pre2
+
+ Patches dropped, merged in mainline:
+ - 17_htb3.6_2.4.17
+ - 31_p4-xeon-detection
+
+ Patches dropped, merged in -ac:
+ - 06-vm-strict-overcommit-2.4.19-pre7-rmap-1
+ - 15_sis-740-961
+ - 27_jfs-1.0.23-xattr
+ - 28_jfs-1.0.23-acl
+ - 33_nfs-update
+ - 34_nfs-over-tcp
+ - 35_iptables-patch-o-matic
+ - 97_ide_taskfile_config
+
+ Patches waiting for merging:
+ - 03_xattr+acl-0.8.51
+ - 08_scheduler-hints
+ - 12_cdda-dma
+ - 24_smptimers
+ - 43_VIA-fixes
+ - 44_VIA-northbridge-fixup
+ - XFS
+ - 80_loop-jari
+ - 81_freeswan-1.98b
+ - 82_patch-int
*lolo-sources-2.4.19.10_pre6 (03 Oct 2002)
diff --git a/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre1 b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre1
new file mode 100644
index 000000000000..952f5ab78a8b
--- /dev/null
+++ b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre1
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 36979592bde9efc4627f614f10c4c6d0 patches-2.4.20-lolo-r1_pre1.tar.bz2 6150929
diff --git a/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre1.ebuild b/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre1.ebuild
new file mode 100644
index 000000000000..092260a1b407
--- /dev/null
+++ b/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre1.ebuild,v 1.1 2002/10/17 17:58:29 lostlogic Exp $
+
+IUSE="crypt xfs build acpi4linux"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+# This kernel also has support for the local USE flag acpi4linux which
+# activates the latest code from acpi.sourceforge.net instead of the
+# very out of date vanilla version
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV="2.4.19"
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/lolo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for lostlogic's Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ [ `use crypt` ] || rm 8*
+
+ # This is the XFS filesystem from SGI, use at your own risk ;)
+ [ `use xfs` ] || rm *xfs*
+
+ # This is the latest release of ACPI from
+ # http://www.sourceforge.net/projects/acpi
+ [ `use acpi4linux` ] || rm 70*
+
+ kernel_src_unpack
+}