summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2002-11-03 11:07:11 +0000
committerMichael Imhof <tantive@gentoo.org>2002-11-03 11:07:11 +0000
commitb417ea677dfd770e2e1239f7b1aea5d0878ac7f2 (patch)
treed3bfcce4b6176598a1c6a723bbf8001ca4e5518a /sys-kernel
parentfix pam_userdb.so linking against wrong libdb problem (diff)
downloadgentoo-2-b417ea677dfd770e2e1239f7b1aea5d0878ac7f2.tar.gz
gentoo-2-b417ea677dfd770e2e1239f7b1aea5d0878ac7f2.tar.bz2
gentoo-2-b417ea677dfd770e2e1239f7b1aea5d0878ac7f2.zip
Version bumped
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r242
-rw-r--r--sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r252
-rw-r--r--sys-kernel/usermode-sources/usermode-sources-2.4.19-r24.ebuild63
-rw-r--r--sys-kernel/usermode-sources/usermode-sources-2.4.19-r25.ebuild63
4 files changed, 130 insertions, 0 deletions
diff --git a/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r24 b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r24
new file mode 100644
index 000000000000..23ad60363145
--- /dev/null
+++ b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r24
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 62a5bc033ecef3783d68f2e01c02d2a6 uml-patch-2.4.19-24.bz2 161337
diff --git a/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r25 b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r25
new file mode 100644
index 000000000000..3bd5b019be16
--- /dev/null
+++ b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r25
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 d860d92be065828caf5861fb95c00564 uml-patch-2.4.19-25.bz2 165187
diff --git a/sys-kernel/usermode-sources/usermode-sources-2.4.19-r24.ebuild b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r24.ebuild
new file mode 100644
index 000000000000..a66eff343f5f
--- /dev/null
+++ b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r24.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/usermode-sources/usermode-sources-2.4.19-r24.ebuild,v 1.1 2002/11/03 11:06:52 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+KV=${PVR}
+UML_PATCH="uml-patch-${PV}-`echo ${PR}|sed -e 's:r\+:\1:'`"
+S=${WORKDIR}/linux-${KV}
+
+# What's in this kernel?
+
+# INCLUDED:
+# User mode linux patch
+# http://user-mode-linux.sourceforge.net
+# UML clashes with the current Gentoo patch, so I've ignored it for now.
+
+DESCRIPTION="Full (vanilla) sources for the User Mode Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://uml-pub.ists.dartmouth.edu/uml/${UML_PATCH}.bz2"
+HOMEPAGE="http://www.kernel.org/ http://user-mode-linux.sourceforge.net"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc -sparc64 -alpha"
+
+#console-tools is needed to solve the loadkeys fiasco.
+#binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+DEPEND=">=sys-devel/binutils-2.11.90.0.31 sys-devel/perl"
+RDEPEND=">=sys-libs/ncurses-5.2"
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ bzcat ${DISTDIR}/${UML_PATCH}.bz2 | patch -d ${S} -p1
+ echo "Preparing for compilation..."
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+}
+
+src_compile() {
+ echo "Nothing to compile. That's up to the user"
+}
+
+src_install() {
+ dodir /usr/src/uml
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src/uml
+ cd ${D}/usr/src/uml
+ ln -sf linux-${KV} linux
+}
+
+
diff --git a/sys-kernel/usermode-sources/usermode-sources-2.4.19-r25.ebuild b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r25.ebuild
new file mode 100644
index 000000000000..2391a2b4e74b
--- /dev/null
+++ b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r25.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/usermode-sources/usermode-sources-2.4.19-r25.ebuild,v 1.1 2002/11/03 11:06:52 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+KV=${PVR}
+UML_PATCH="uml-patch-${PV}-`echo ${PR}|sed -e 's:r\+:\1:'`"
+S=${WORKDIR}/linux-${KV}
+
+# What's in this kernel?
+
+# INCLUDED:
+# User mode linux patch
+# http://user-mode-linux.sourceforge.net
+# UML clashes with the current Gentoo patch, so I've ignored it for now.
+
+DESCRIPTION="Full (vanilla) sources for the User Mode Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://uml-pub.ists.dartmouth.edu/uml/${UML_PATCH}.bz2"
+HOMEPAGE="http://www.kernel.org/ http://user-mode-linux.sourceforge.net"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc -sparc64 -alpha"
+
+#console-tools is needed to solve the loadkeys fiasco.
+#binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+DEPEND=">=sys-devel/binutils-2.11.90.0.31 sys-devel/perl"
+RDEPEND=">=sys-libs/ncurses-5.2"
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ bzcat ${DISTDIR}/${UML_PATCH}.bz2 | patch -d ${S} -p1
+ echo "Preparing for compilation..."
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+}
+
+src_compile() {
+ echo "Nothing to compile. That's up to the user"
+}
+
+src_install() {
+ dodir /usr/src/uml
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src/uml
+ cd ${D}/usr/src/uml
+ ln -sf linux-${KV} linux
+}
+
+