summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2014-05-05 13:54:18 +0000
committerMike Pagano <mpagano@gentoo.org>2014-05-05 13:54:18 +0000
commitc66564f74aa406ca826e6e462a6fec4298043bd2 (patch)
treed0b46865ffcbf5986c17e432a4ca818d09578769 /sys-kernel
parent>=upower-0.99 no longer provides the API needed for USE=upower (bug #509622, ... (diff)
downloadgentoo-2-c66564f74aa406ca826e6e462a6fec4298043bd2.tar.gz
gentoo-2-c66564f74aa406ca826e6e462a6fec4298043bd2.tar.bz2
gentoo-2-c66564f74aa406ca826e6e462a6fec4298043bd2.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B576E4E3)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/ChangeLog7
-rw-r--r--sys-kernel/git-sources/git-sources-3.15_rc4.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/sys-kernel/git-sources/ChangeLog b/sys-kernel/git-sources/ChangeLog
index 839098dd73e6..8e33dc025c11 100644
--- a/sys-kernel/git-sources/ChangeLog
+++ b/sys-kernel/git-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/git-sources
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/ChangeLog,v 1.1383 2014/04/28 12:05:55 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/ChangeLog,v 1.1384 2014/05/05 13:54:18 mpagano Exp $
+
+*git-sources-3.15_rc4 (05 May 2014)
+
+ 05 May 2014; Mike Pagano <mpagano@gentoo.org> +git-sources-3.15_rc4.ebuild:
+ Version bump
*git-sources-3.15_rc3 (28 Apr 2014)
diff --git a/sys-kernel/git-sources/git-sources-3.15_rc4.ebuild b/sys-kernel/git-sources/git-sources-3.15_rc4.ebuild
new file mode 100644
index 000000000000..00cdf06b1468
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-3.15_rc4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/git-sources-3.15_rc4.ebuild,v 1.1 2014/05/05 13:54:18 mpagano Exp $
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE=0
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="http://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at http://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.1-r3"
+
+pkg_postinst() {
+ postinst_sources
+}