summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjoern Brauel <bjb@gentoo.org>2002-10-19 11:24:04 +0000
committerBjoern Brauel <bjb@gentoo.org>2002-10-19 11:24:04 +0000
commitfa9d4861b04295f82776fa211d4ae29b5785073d (patch)
tree6313a8f3414b59e7150161fac6f0a925f7a42128 /sys-kernel
parentadd pam_open_session() support to su, fixing bug #8831. (diff)
downloadgentoo-2-fa9d4861b04295f82776fa211d4ae29b5785073d.tar.gz
gentoo-2-fa9d4861b04295f82776fa211d4ae29b5785073d.tar.bz2
gentoo-2-fa9d4861b04295f82776fa211d4ae29b5785073d.zip
new kernel version for alpha adds xfs support
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/alpha-sources/ChangeLog4
-rw-r--r--sys-kernel/alpha-sources/alpha-sources-2.4.19-r2.ebuild112
-rw-r--r--sys-kernel/alpha-sources/files/digest-alpha-sources-2.4.19-r22
3 files changed, 118 insertions, 0 deletions
diff --git a/sys-kernel/alpha-sources/ChangeLog b/sys-kernel/alpha-sources/ChangeLog
index 398f06247c4e..2a6fc874eef7 100644
--- a/sys-kernel/alpha-sources/ChangeLog
+++ b/sys-kernel/alpha-sources/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-kernel/alpha-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+*alpha-sources-2.4.19-r1 (19 Oct 2002)
+ 19 Oct 2002; Bjoern Brauel <bjb@gentoo.org>
+ new version adds support for xfs
+
*alpha-sources-2.4.19-r1 (21 Sep 2002)
21 Sep 2002; Bjoern Brauel <bjb@gentoo.org>
Added initial ebuild
diff --git a/sys-kernel/alpha-sources/alpha-sources-2.4.19-r2.ebuild b/sys-kernel/alpha-sources/alpha-sources-2.4.19-r2.ebuild
new file mode 100644
index 000000000000..0ac352678664
--- /dev/null
+++ b/sys-kernel/alpha-sources/alpha-sources-2.4.19-r2.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.19
+KV=${PVR}
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+#
+# super page patch by Naohiki Shimizu. increases load performance
+# cia fix of qlogic isp scsi on alcor boards
+# xfs filesystem patches
+
+
+DESCRIPTION="Full sources for the Gentoo Linux Alpha kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://www.tuxnetwork.de/gentoo/linux-gentoo-alpha-${KV}.patch.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha"
+
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+GENTOOPATCH=${DISTDIR}/linux-gentoo-alpha-${KV}.patch.bz2
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ pwd
+ bzcat ${GENTOOPATCH} | patch -p1 || die # Patch the kernel
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ make dep
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-alpha/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}
diff --git a/sys-kernel/alpha-sources/files/digest-alpha-sources-2.4.19-r2 b/sys-kernel/alpha-sources/files/digest-alpha-sources-2.4.19-r2
new file mode 100644
index 000000000000..fbfbc6fdc1c3
--- /dev/null
+++ b/sys-kernel/alpha-sources/files/digest-alpha-sources-2.4.19-r2
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 c56bf9e2db21e55e40ce5224359623da linux-gentoo-alpha-2.4.19-r2.patch.bz2 834096