summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-09-09 05:38:29 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-09-09 05:38:29 +0000
commitaeff5e864d8283aff65f76d324661493fb234d9f (patch)
tree00c8b252d9701ff8acd826f54c8c7e587fd88e27 /sys-libs/db/db-4.3.29_p1-r1.ebuild
parentAdd 2.6.25-r6, remove 2.6.24-r3. (diff)
downloadgentoo-2-aeff5e864d8283aff65f76d324661493fb234d9f.tar.gz
gentoo-2-aeff5e864d8283aff65f76d324661493fb234d9f.tar.bz2
gentoo-2-aeff5e864d8283aff65f76d324661493fb234d9f.zip
Fix bug #235025 for libtool-2.2 and non-bash boxes.
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc5-00283-g70bb089 x86_64)
Diffstat (limited to 'sys-libs/db/db-4.3.29_p1-r1.ebuild')
-rw-r--r--sys-libs/db/db-4.3.29_p1-r1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-libs/db/db-4.3.29_p1-r1.ebuild b/sys-libs/db/db-4.3.29_p1-r1.ebuild
index 9d64f2e23f69..47c79bc98705 100644
--- a/sys-libs/db/db-4.3.29_p1-r1.ebuild
+++ b/sys-libs/db/db-4.3.29_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.3.29_p1-r1.ebuild,v 1.3 2008/08/16 22:46:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.3.29_p1-r1.ebuild,v 1.4 2008/09/09 05:38:29 robbat2 Exp $
inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool
@@ -72,6 +72,12 @@ src_unpack() {
# END of 4.5+earlier specific
cd "${S}"/../dist
rm -f aclocal/libtool.{m4,ac} aclocal.m4
+ sed -i \
+ -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
+ configure.ac
+ sed -i \
+ -e '/^AC_PATH_TOOL/s/ sh, missing_sh/ bash, missing_sh/' \
+ aclocal/programs.m4
AT_M4DIR="aclocal aclocal_java" eautoreconf
# Upstream sucks - they do autoconf and THEN replace the version variables.
. ./RELEASE
@@ -136,7 +142,7 @@ src_compile() {
--host="${CHOST}" \
${myconf} "${javaconf}" || die "configure failed"
- emake -j1 || die "make failed"
+ emake || die "make failed"
}
src_install() {