summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-05-03 23:21:52 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-05-03 23:21:52 +0000
commit6ff087a68042c2ccd86ad018e9eafdfb3f1e9afa (patch)
tree08890573b01af1f7714bab2ce907eefbcc677b00 /sys-libs/db
parentBug #275652: Install examples with USE=examples. (diff)
downloadgentoo-2-6ff087a68042c2ccd86ad018e9eafdfb3f1e9afa.tar.gz
gentoo-2-6ff087a68042c2ccd86ad018e9eafdfb3f1e9afa.tar.bz2
gentoo-2-6ff087a68042c2ccd86ad018e9eafdfb3f1e9afa.zip
Bug #240568: Fix bad stripping output in older ebuilds.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/ChangeLog6
-rw-r--r--sys-libs/db/db-4.5.20_p2-r1.ebuild8
-rw-r--r--sys-libs/db/db-4.5.20_p2.ebuild8
-rw-r--r--sys-libs/db/db-4.6.21_p4.ebuild8
4 files changed, 17 insertions, 13 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 2ed1abdb5cea..666c2793e688 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.301 2010/05/03 21:59:12 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.302 2010/05/03 23:21:52 robbat2 Exp $
+
+ 03 May 2010; Robin H. Johnson <robbat2@gentoo.org> db-4.5.20_p2.ebuild,
+ db-4.5.20_p2-r1.ebuild, db-4.6.21_p4.ebuild:
+ Bug #240568: Fix bad stripping output in older ebuilds.
*db-4.8.30 (03 May 2010)
diff --git a/sys-libs/db/db-4.5.20_p2-r1.ebuild b/sys-libs/db/db-4.5.20_p2-r1.ebuild
index f8a6568d9b99..2dc8aeb80f91 100644
--- a/sys-libs/db/db-4.5.20_p2-r1.ebuild
+++ b/sys-libs/db/db-4.5.20_p2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.5.20_p2-r1.ebuild,v 1.14 2009/09/20 19:52:44 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.5.20_p2-r1.ebuild,v 1.15 2010/05/03 23:21:52 robbat2 Exp $
inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool
@@ -138,14 +138,14 @@ src_compile() {
--host="${CHOST}" \
${myconf} "${javaconf}" || die "configure failed"
- sed -e "s,\(^STRIP *=\).*,\1\"none\"," Makefile > Makefile.cpy \
+ sed -e "s,\(^STRIP *=\).*,\1\"true\"," Makefile > Makefile.cpy \
&& mv Makefile.cpy Makefile
emake || die "make failed"
}
src_install() {
- einstall libdir="${D}/usr/$(get_libdir)" STRIP="none" || die
+ einstall libdir="${D}/usr/$(get_libdir)" STRIP="true" || die
db_src_install_usrbinslot
diff --git a/sys-libs/db/db-4.5.20_p2.ebuild b/sys-libs/db/db-4.5.20_p2.ebuild
index 0b5d522b6716..7af8aae77068 100644
--- a/sys-libs/db/db-4.5.20_p2.ebuild
+++ b/sys-libs/db/db-4.5.20_p2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.5.20_p2.ebuild,v 1.29 2009/09/20 19:52:44 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.5.20_p2.ebuild,v 1.30 2010/05/03 23:21:52 robbat2 Exp $
inherit eutils db flag-o-matic java-pkg-opt-2
@@ -107,14 +107,14 @@ src_compile() {
--host="${CHOST}" \
${myconf} "${javaconf}" || die "configure failed"
- sed -e "s,\(^STRIP *=\).*,\1\"none\"," Makefile > Makefile.cpy \
+ sed -e "s,\(^STRIP *=\).*,\1\"true\"," Makefile > Makefile.cpy \
&& mv Makefile.cpy Makefile
emake -j1 || die "make failed"
}
src_install() {
- einstall libdir="${D}/usr/$(get_libdir)" STRIP="none" || die
+ einstall libdir="${D}/usr/$(get_libdir)" STRIP="true" || die
db_src_install_usrbinslot
diff --git a/sys-libs/db/db-4.6.21_p4.ebuild b/sys-libs/db/db-4.6.21_p4.ebuild
index c3db7784511e..9b5293cebb4c 100644
--- a/sys-libs/db/db-4.6.21_p4.ebuild
+++ b/sys-libs/db/db-4.6.21_p4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.21_p4.ebuild,v 1.10 2009/09/20 19:52:44 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.21_p4.ebuild,v 1.11 2010/05/03 23:21:52 robbat2 Exp $
inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool
@@ -131,14 +131,14 @@ src_compile() {
--host="${CHOST}" \
${myconf} "${javaconf}" || die "configure failed"
- sed -e "s,\(^STRIP *=\).*,\1\"none\"," Makefile > Makefile.cpy \
+ sed -e "s,\(^STRIP *=\).*,\1\"true\"," Makefile > Makefile.cpy \
&& mv Makefile.cpy Makefile
emake || die "make failed"
}
src_install() {
- einstall libdir="${D}/usr/$(get_libdir)" STRIP="none" || die
+ einstall libdir="${D}/usr/$(get_libdir)" STRIP="true" || die
db_src_install_usrbinslot