summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-07 09:04:45 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-07 09:04:45 +0000
commitd44d0bc2c0d079c0ba87a9d20e3427c6e0941541 (patch)
treec8e36d04c0f266c19199c6a32e8ccbb37055f3dd /sys-libs/db
parentversion bump (diff)
downloadgentoo-2-d44d0bc2c0d079c0ba87a9d20e3427c6e0941541.tar.gz
gentoo-2-d44d0bc2c0d079c0ba87a9d20e3427c6e0941541.tar.bz2
gentoo-2-d44d0bc2c0d079c0ba87a9d20e3427c6e0941541.zip
Cleanup src_compile and src_install.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/ChangeLog5
-rw-r--r--sys-libs/db/db-4.7.25_p1-r1.ebuild65
2 files changed, 27 insertions, 43 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 9f04a8c80a72..8cc910e9fc0b 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.272 2009/02/07 08:06:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.273 2009/02/07 09:04:45 vapier Exp $
+
+ 07 Feb 2009; Mike Frysinger <vapier@gentoo.org> db-4.7.25_p1-r1.ebuild:
+ Cleanup src_compile and src_install.
07 Feb 2009; Mike Frysinger <vapier@gentoo.org> db-4.6.21_p1.ebuild,
db-4.6.21_p3.ebuild, db-4.6.21_p3-r1.ebuild, db-4.7.25.ebuild,
diff --git a/sys-libs/db/db-4.7.25_p1-r1.ebuild b/sys-libs/db/db-4.7.25_p1-r1.ebuild
index 066c0716bc9d..cd1a910c5636 100644
--- a/sys-libs/db/db-4.7.25_p1-r1.ebuild
+++ b/sys-libs/db/db-4.7.25_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.7.25_p1-r1.ebuild,v 1.5 2009/02/07 08:06:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.7.25_p1-r1.ebuild,v 1.6 2009/02/07 09:04:45 vapier Exp $
inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool
@@ -27,9 +27,11 @@ done
LICENSE="OracleDB"
SLOT="4.7"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="tcl java doc nocxx"
+IUSE="doc java nocxx tcl test"
+# the entire testsuite needs the TCL functionality
DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
+ test? ( >=dev-lang/tcl-8.4 )
java? ( >=virtual/jdk-1.5 )
>=sys-devel/binutils-2.16.1"
RDEPEND="tcl? ( dev-lang/tcl )
@@ -81,62 +83,41 @@ src_compile() {
is-flag -O[s123] || append-flags -O2
fi
- local myconf=""
-
- use amd64 && myconf="${myconf} --with-mutex=x86/gcc-assembly"
-
- myconf="${myconf} $(use_enable !nocxx cxx)"
-
- use tcl \
- && myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
- || myconf="${myconf} --disable-tcl"
-
- myconf="${myconf} $(use_enable java)"
- if use java; then
- myconf="${myconf} --with-java-prefix=${JAVA_HOME}"
- # Can't get this working any other way, since it returns spaces, and
- # bash doesn't seem to want to pass correctly in any way i try
- local javaconf="-with-javac-flags=$(java-pkg_javac-args)"
- fi
-
- [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
-
- # the entire testsuite needs the TCL functionality
- if use tcl && has test $FEATURES ; then
- myconf="${myconf} --enable-test"
- else
- myconf="${myconf} --disable-test"
+ # use `set` here since the java opts will contain whitespace
+ set --
+ if use java ; then
+ set -- "$@" \
+ --with-java-prefix="${JAVA_HOME}" \
+ --with-javac-flags="$(java-pkg_javac-args)"
fi
# Add linker versions to the symbols. Easier to do, and safer than header file
# mumbo jumbo.
- if use userland_GNU; then
+ if use userland_GNU ; then
append-ldflags -Wl,--default-symver
fi
- cd "${S}" && ECONF_SOURCE="${S}"/../dist econf \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- --libdir=/usr/"$(get_libdir)" \
+ cd "${S}"
+ ECONF_SOURCE="${S}"/../dist \
+ STRIP="true" \
+ econf \
--enable-compat185 \
--enable-o_direct \
--without-uniquename \
--enable-rpc \
- --host="${CHOST}" \
- ${myconf} "${javaconf}" || die "configure failed"
-
- sed -e "s,\(^STRIP *=\).*,\1\"true\"," Makefile > Makefile.cpy \
- && mv Makefile.cpy Makefile
+ $(use amd64 && echo --with-mutex=x86/gcc-assembly) \
+ $(use_enable !nocxx cxx) \
+ $(use_enable java) \
+ $(use_enable tcl) \
+ $(use tcl && echo --with-tcl=/usr/$(get_libdir)) \
+ $(use_enable test) \
+ "$@"
emake || die "make failed"
}
src_install() {
- einstall libdir="${D}/usr/$(get_libdir)" STRIP="true" || die
+ emake install DESTDIR="${D}" || die
db_src_install_usrbinslot