summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-21 15:50:48 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-21 15:50:48 +0000
commit561812e3d5a60ae935359ff45fe7a551fae02167 (patch)
treed908df65223f84e5bb9d0f03c698ecb289b1b559 /sys-libs/e2fsprogs-libs
parentAdd postinstall warning for nxserver users about the xlib-xcb backend, bug #4... (diff)
downloadgentoo-2-561812e3d5a60ae935359ff45fe7a551fae02167.tar.gz
gentoo-2-561812e3d5a60ae935359ff45fe7a551fae02167.tar.bz2
gentoo-2-561812e3d5a60ae935359ff45fe7a551fae02167.zip
Convert to multilib and stack it for baselibs -r13. Bug #481362.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-libs/e2fsprogs-libs')
-rw-r--r--sys-libs/e2fsprogs-libs/ChangeLog8
-rw-r--r--sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.42.7-r1.ebuild67
2 files changed, 74 insertions, 1 deletions
diff --git a/sys-libs/e2fsprogs-libs/ChangeLog b/sys-libs/e2fsprogs-libs/ChangeLog
index 8a3275b6701f..8c0d8613637e 100644
--- a/sys-libs/e2fsprogs-libs/ChangeLog
+++ b/sys-libs/e2fsprogs-libs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/e2fsprogs-libs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/e2fsprogs-libs/ChangeLog,v 1.106 2013/05/20 17:42:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/e2fsprogs-libs/ChangeLog,v 1.107 2013/08/21 15:50:48 aballier Exp $
+
+*e2fsprogs-libs-1.42.7-r1 (21 Aug 2013)
+
+ 21 Aug 2013; Alexis Ballier <aballier@gentoo.org>
+ +e2fsprogs-libs-1.42.7-r1.ebuild:
+ Convert to multilib and stack it for baselibs -r13. Bug #481362.
20 May 2013; Agostino Sarubbo <ago@gentoo.org> e2fsprogs-libs-1.42.7.ebuild:
Stable for s390, wrt bug #467008
diff --git a/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.42.7-r1.ebuild b/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.42.7-r1.ebuild
new file mode 100644
index 000000000000..933c77f4b8d1
--- /dev/null
+++ b/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.42.7-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.42.7-r1.ebuild,v 1.1 2013/08/21 15:50:48 aballier Exp $
+
+EAPI="4"
+
+case ${PV} in
+*_pre*) UP_PV="${PV%_pre*}-WIP-${PV#*_pre}" ;;
+*) UP_PV=${PV} ;;
+esac
+
+inherit toolchain-funcs eutils multilib-minimal
+
+DESCRIPTION="e2fsprogs libraries (common error and subsystem)"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/e2fsprogs/${PN}-${UP_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="nls static-libs"
+
+RDEPEND="!sys-libs/com_err
+ !sys-libs/ss
+ !<sys-fs/e2fsprogs-1.41.8
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20130224-r12
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND="nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P%_pre*}
+
+src_prepare() {
+ printf 'all:\n%%:;@:\n' > doc/Makefile.in # don't bother with docs #305613
+}
+
+multilib_src_configure() {
+ # We want to use the "bsd" libraries while building on Darwin, but while
+ # building on other Gentoo/*BSD we prefer elf-naming scheme.
+ local libtype
+ case ${CHOST} in
+ *-darwin*) libtype=bsd;;
+ *) libtype=elf;;
+ esac
+
+ # we use blkid/uuid from util-linux now
+ ac_cv_lib_uuid_uuid_generate=yes \
+ ac_cv_lib_blkid_blkid_get_cache=yes \
+ ac_cv_path_LDCONFIG=: \
+ QUOTA_CMT='#' \
+ ECONF_SOURCE="${S}" \
+ econf \
+ --disable-lib{blkid,uuid} \
+ --disable-quota \
+ --enable-${libtype}-shlibs \
+ $(tc-has-tls || echo --disable-tls) \
+ $(use_enable nls)
+}
+
+multilib_src_install() {
+ emake STRIP=: DESTDIR="${D}" install || die
+ multilib_is_native_abi && gen_usr_ldscript -a com_err ss
+ # configure doesn't have an option to disable static libs :/
+ use static-libs || find "${ED}" -name '*.a' -delete
+}