summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-06-01 17:49:18 +0000
committerMike Frysinger <vapier@gentoo.org>2012-06-01 17:49:18 +0000
commit0c4aba7ffd9b82200f6a1232ea800b892e3b40e2 (patch)
tree5f59396cbcb07d3734e82db1d11cc7c2b4a028cb /sys-libs/glibc/glibc-2.11.3.ebuild
parentSync keywords with newer versions. (diff)
downloadgentoo-2-0c4aba7ffd9b82200f6a1232ea800b892e3b40e2.tar.gz
gentoo-2-0c4aba7ffd9b82200f6a1232ea800b892e3b40e2.tar.bz2
gentoo-2-0c4aba7ffd9b82200f6a1232ea800b892e3b40e2.zip
Unify alt_libdir definition and use alt_prefix where possible.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/glibc/glibc-2.11.3.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.11.3.ebuild19
1 files changed, 4 insertions, 15 deletions
diff --git a/sys-libs/glibc/glibc-2.11.3.ebuild b/sys-libs/glibc/glibc-2.11.3.ebuild
index be449a3328bc..630795eeb4f7 100644
--- a/sys-libs/glibc/glibc-2.11.3.ebuild
+++ b/sys-libs/glibc/glibc-2.11.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.11.3.ebuild,v 1.13 2012/04/21 15:54:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.11.3.ebuild,v 1.14 2012/06/01 17:49:17 vapier Exp $
inherit eutils versionator libtool toolchain-funcs flag-o-matic gnuconfig multilib
@@ -61,21 +61,10 @@ fi
is_crosscompile() {
[[ ${CHOST} != ${CTARGET} ]]
}
-alt_libdir() {
- if is_crosscompile ; then
- echo /usr/${CTARGET}/$(get_libdir)
- else
- echo /$(get_libdir)
- fi
-}
-if is_crosscompile ; then
- SLOT="${CTARGET}-2.2"
-else
- # Why SLOT 2.2 you ask yourself while sippin your tea ?
- # Everyone knows 2.2 > 0, duh.
- SLOT="2.2"
-fi
+# Why SLOT 2.2 you ask yourself while sippin your tea ?
+# Everyone knows 2.2 > 0, duh.
+SLOT="2.2"
# General: We need a new-enough binutils for as-needed
# arch: we need to make sure our binutils/gcc supports TLS