summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-16 22:23:15 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-16 22:23:15 +0000
commit0620b0a075be1eedf408a78c831519ef6c0ee687 (patch)
tree0b6a50525dbb1227c63785c7d0b4159c8141a8c5 /sys-libs/glibc/glibc-2.3.2-r12.ebuild
parentChange brltty dep to >=3.6 (diff)
downloadgentoo-2-0620b0a075be1eedf408a78c831519ef6c0ee687.tar.gz
gentoo-2-0620b0a075be1eedf408a78c831519ef6c0ee687.tar.bz2
gentoo-2-0620b0a075be1eedf408a78c831519ef6c0ee687.zip
dont install /etc/locales.build if one already exists #72596
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.2-r12.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r12.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-libs/glibc/glibc-2.3.2-r12.ebuild b/sys-libs/glibc/glibc-2.3.2-r12.ebuild
index c5f467102f69..f7c54f165886 100644
--- a/sys-libs/glibc/glibc-2.3.2-r12.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r12.ebuild,v 1.10 2005/04/22 23:04:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r12.ebuild,v 1.11 2005/05/16 22:23:15 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -151,10 +151,10 @@ install_locales() {
setup_locales() {
if ! use userlocales ; then
einfo "userlocales not enabled, installing -ALL- locales..."
- elif [ -e /etc/locales.build ]; then
+ elif [[ -e ${ROOT}/etc/locales.build ]] ; then
einfo "Installing locales in /etc/locales.build..."
echo 'SUPPORTED-LOCALES=\' > SUPPORTED.locales
- cat /etc/locales.build | grep -v -e ^$ -e ^\# | sed 's/$/\ \\/g' \
+ cat "${ROOT}"/etc/locales.build | grep -v -e ^$ -e ^\# | sed 's/$/\ \\/g' \
>> SUPPORTED.locales
cat SUPPORTED.locales > ${S}/localedata/SUPPORTED || die
elif [ -e ${FILESDIR}/locales.build ]; then
@@ -696,6 +696,11 @@ EOF
dosym /usr/lib/libbsd-compat.a /usr/lib/libbsd.a
}
+pkg_preinst() {
+ # Shouldnt need to keep this updated
+ [[ -e ${ROOT}/etc/locales.build ]] && rm -f "${D}"/etc/locales.build
+}
+
pkg_postinst() {
# Correct me if I am wrong here, but my /etc/localtime is a file
# created by zic ....