summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-27 03:17:50 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-27 03:17:50 +0000
commit60a8e75205edeea4a414d71c09bf612ef22894be (patch)
tree4b1d2f8dd1b3cfbb73cf4853dea38d21303a4d39 /sys-libs/glibc/glibc-2.3.2-r9.ebuild
parentrepoman: whitespace cleanup (Manifest recommit) (diff)
downloadgentoo-2-60a8e75205edeea4a414d71c09bf612ef22894be.tar.gz
gentoo-2-60a8e75205edeea4a414d71c09bf612ef22894be.tar.bz2
gentoo-2-60a8e75205edeea4a414d71c09bf612ef22894be.zip
fix the sparc CHOST munging
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.2-r9.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r9.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-libs/glibc/glibc-2.3.2-r9.ebuild b/sys-libs/glibc/glibc-2.3.2-r9.ebuild
index dd855cf71d0f..995fd2068d17 100644
--- a/sys-libs/glibc/glibc-2.3.2-r9.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r9.ebuild,v 1.23 2004/03/18 22:08:09 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r9.ebuild,v 1.24 2004/04/27 03:17:50 vapier Exp $
IUSE="nls pic build nptl"
@@ -409,7 +409,7 @@ setup_flags() {
use ppc || append-flags "-freorder-blocks"
# Sparc/Sparc64 support
- if [ -n "`use sparc`" ]
+ if use sparc
then
# Both sparc and sparc64 can use -fcall-used-g6. -g7 is bad, though.
@@ -429,7 +429,8 @@ setup_flags() {
# Setup the CHOST properly to insure "sparcv9"
# This passes -mcpu=ultrasparc -Wa,-Av9a to the compiler
- export CHOST="${CHOST/sparc/sparcv9}"
+ [ "${CHOST}" == "sparc-unknown-linux-gnu" ] && \
+ export CHOST="sparcv9-unknown-linux-gnu"
fi
fi
}